IGRChart 概述

图表接口

表示图表的接口。


多色显示单序列柱图

当只有一个序列时，是否用不同的颜色显示柱图。

数据类型:逻辑型

语法:对象.多色显示单序列柱图 = 逻辑型

默认值:真

特征:可读写

设计器中可见

说明

此属性仅对柱图有效


IGRChart.BarWidthPercent 属性

柱图宽度百分比 属性

指定柱图显示的总宽度占据整个宽度的百分比。

数据类型:整数型

语法:对象.柱图宽度百分比 = 整数型

默认值:70

特征:可读写

设计器中可见

说明

此属性仅对柱图有效


IGRChart.ChartType 属性

图表类型 属性

指定图表的类型。

数据类型:整数型(注:图表类型枚举值)

默认值:柱图

特征

可读写

设计器中可见


IGRChart.GroupCount 属性

组数 属性

图表的数据组数。

数据类型:整数型

语法:对象.数组 = 整数型

默认值:5

特征

可读写

设计器中可见


IGRChart.LegendCursor 属性

图例光标 属性

指定在查询显示报表时，当鼠标光标位于图例项上时要显示的鼠标光标类型。

数据类型:整数型(注:显示光标枚举值)

语法:对象.图例光标 = 显示光标枚举值

默认值:默认光标

特征

可读写

设计器中可见


IGRChart.LegendVisible 属性

图例值可见性 属性

指定是否显示图例。

数据类型:逻辑型

语法:对象.图例值可见性=逻辑型

默认值:真

特征

可读写

设计器中可见


IGRChart.LineWeight 属性

线粗细 属性

指定折线图的粗细度。

数据类型:整数型

语法:对象.线粗细 = 整数型

默认值:2

特征

可读写

设计器中可见

说明

此属性仅对折线图有效


IGRChart.MarginGap 属性

边距 属性

指定在图表的边框四周留出空白边距，以屏幕像素为计量单位。

数据类型:整数型

语法:对象.边距=整数型

默认值:0

特征

可读写

设计器中可见


IGRChart.SeriesCount 属性

序列数 属性

图表的数据序列数。

数据类型:整数型

语法:对象.序列数 = 整数型

默认值:1

特征

可读写

设计器中可见


IGRChart.SeriesCursor 属性

序列光标 属性

指定在查询显示报表时，当鼠标光标位于序列项图形上时要显示的鼠标光标类型。

数据类型:显示光标枚举

语法:对象.序列光标 = 显示光标枚举值

默认值:默认光标

特征

可读写

设计器中可见


IGRChart.Title 属性

图表.标题 属性

指定图表的标题显示文字。

数据类型:文本型

语法:对象.标题=文本型

特征

可读写

设计器中可见


IGRChart.ValueAsPercent 属性

值显示为百分比 属性

指定是否将图表的值统计并显示为加权百分比。

数据类型:逻辑型

语法:对象.值显示为百分比 =逻辑型

默认值:真

特征

可读写

设计器中可见


IGRChart.ValueFormat 属性

值格式串 属性

指定显示图表值的数字格式串。

数据类型:文本型

语法:对象.值格式串=文本型

特征

可读写

设计器中可见


IGRChart.ValueVisible 属性

值可见性 属性

指定是否显示图表的值。

数据类型:逻辑型

语法:对象.值可见性=逻辑型

默认值:真

特征

可读写

设计器中可见


IGRChart.XAxisLabel 属性

横轴标签 属性

在X轴下面显示的标签文字。

数据类型:文本型

语法:对象.横轴标签=文本型

特征

可读写

设计器中可见

说明

此属性只对柱图与折线图有效。


IGRChart.XAxisTextAngle 属性

横轴文字角度 属性

指定X轴的文字显示角度。

数据类型:整数型

语法:对象.横轴文字角度=整数型

默认值:0

特征

可读写

设计器中可见

说明

属性值的范围从0-360。此属性只对柱图与折线图有效。


IGRChart.XAxisTextVisible 属性

横轴文字可见性 属性

指定是否显示X轴的文字。

数据类型:逻辑型

语法:对象.横轴文字可见性=逻辑型

默认值:真

特征

可读写

设计器中可见

说明

此属性只对柱图与折线图有效。


IGRChart.XAxisVisible 属性

横轴可见性 属性

指定是否显示X坐标轴。

数据类型:逻辑性

语法:对象.横轴可见性=逻辑型

默认值:真

特征

可读写

设计器中可见

说明

此属性只对柱图与折线图有效。


IGRChart.YAxisLabel 属性

纵轴标签 属性

指定在Y坐标轴的左边显示的标签文字。

数据类型:文本型

语法:对象.纵轴标签=文本型

特征

可读写

设计器中可见

说明

此属性只对柱图与折线图有效。


IGRChart.YAxisMaximum 属性

纵轴最大值 属性

指定Y坐标轴表示的最大值。

数据类型:双精度小数型

语法:对象.纵轴最大值=双精度小数型

默认值:0

特征

可读写

设计器中可见

说明

如果本属性值为零，则图表在运行时将自动生成最大值。此属性只对柱图与折线图有效。


IGRChart.YAxisMinimum 属性

纵轴最小值 属性

指定Y坐标轴表示的最小值。

数据类型:双精度小数型

语法:对象.纵轴最小值=双精度小数

默认值:0

特征

可读写

设计器中可见

说明

此属性只对柱图与折线图有效。


IGRChart.YAxisSpace 属性

纵轴间距 属性

表示Y坐标轴的每刻度的步进值。

数据类型:双精度型

语法:对象.纵轴间距=双精度小数值

默认值:0

特征

可读写

设计器中可见

说明

如果本属性值为零，则图表在运行时将自动生成一个刻度布进值。此属性只对柱图与折线图有效。


IGRChart.YAxisTextFormat 属性

纵轴文字格式串 属性

指定生成Y坐标轴的刻度文字的数字格式串。

数据类型:文本型

语法:对象.纵轴文字格式串=文本型

特征

可读写

设计器中可见

说明

此属性只对柱图与折线图有效。


IGRChart.YAxisTextVisible 属性

纵轴文字可见性 属性

指定是否显示Y坐标轴的文字。

数据类型:逻辑型

语法:对象.纵轴文字可见性=逻辑型

默认值:真

特征

可读写

设计器中可见

说明

此属性只对柱图与折线图有效。


IGRChart.YAxisVisible 属性

纵轴可见性 属性

指定是否显示Y坐标轴。

数据类型:逻辑型

语法:对象.纵轴可见性=逻辑型

默认值:真

特征

可读写

设计器中可见

说明

此属性只对柱图与折线图有效。


IGRChart.PrepareSnapShot 方法

准备快照 方法

准备为明细网格中的内容行，分组头或分组尾中的图表提供数据。

调用格式： 〈无返回值〉 对象．准备快照 （）

说明

明细网格中的内容行，分组头或分组尾中的图表在报表运行时会多次显示，每次显示时其数据会不同，在设定图表的数据之前，必须调用准备快照方法，并在设定完成之后凋用快照方法。准备快照 与 快照只能在开始分组、结束分组 与 处理记录 事件响应函数中调用。


IGRChart.SnapShot 方法

快照 方法

保存为明细网格中的内容行，分组头或分组尾中的图表提供数据。

调用格式： 〈无返回值〉 对象．快照 （）

说明

明细网格中的内容行，分组头或分组尾中的图表在报表运行时会多次显示，每次显示时其数据会不同，在设定图表的数据之前，必须调用准备快照方法，并在设定完成之后凋用快照方法。准备快照 与 快照只能在开始分组、结束分组 与 处理记录 事件响应函数中调用。


E_001

获取值 方法

根据序列顺序号与组顺序号获取图表数据值。

调用格式： 〈双精度小数型〉 对象．获取值 （短整数型 系列索引，短整数型 组索引）


设置值

设置值 方法

根据序列顺序号与组顺序号设置图表数据值。

调用格式： 〈无返回值〉 对象．设置值 （短整数型 系列索引，短整数型 组索引，双精度小数型 欲设置的值）


设置边界

获取组标签 方法

根据顺序号获取或设置组标签文字。

调用格式： 〈文本型〉 对象．获取组标签 （短整数型 组索引）


设置组标签

设置组标签 方法

根据顺序号获取或设置组标签文字。

调用格式： 〈无返回值〉 对象．设置组标签 （短整数型 组索引，文本型 参数2）


设置系列标签

设置系列标签 方法

根据顺序号设置序列标签文字

调用格式： 〈无返回值〉 对象．设置序列标签 （短整数型 系列索引，文本型 参数2）


获取系列标签

获取系列标签 方法

根据顺序号设置序列标签文字

调用格式：〈文本型〉 对象．获取序列标签 （短整数型 系列索引）


IGRColumn 概述

列接口

表示明细网格的列。明细网格拥有一组列，整个明细网格在垂直方向上按列切分。

有关此接口所有成员的列表，请参阅 IGRColumn 成员。


IGRColumn.Visible 属性

可见性 属性

指定列在输出时是否可见。

数据类型:逻辑型

语法:对象.可见性=逻辑型

默认值:真

特征

可读写

设计器中可见

说明

如果本属性值为假，则本列在屏幕显示与打印生成时将被忽略掉。


IGRColumn.Width 属性

宽度 属性

列的显示宽度。

数据类型:双精度小数型

语法:对象.宽度=双精度小数型

特征

可读写

设计器中可见

说明

列的显示宽度，以报表使用的计量单位表示的输出宽度值。此属性代表列在设计时的宽度，当其输出时显示的宽度有可能与设计时的宽度不一致。例如，当明细网格的打印方法为列适应输出区域宽度，则列的宽度将按比例进行伸缩以刚好适应输出页面的输出区域宽度。


IGRColumn.Name 属性

名称 属性

列的名称标识，必须保证每个列的名称唯一。

数据类型:文本型

语法:对象.名称=文本型

特征

可读写

设计器中可见

说明

列的名称标识，必须保证每个列的名称唯一。列、对应标题格与对应内容格三者的名称始终保持一致，改变其中任一个的名称也会同时改变另外两者的名称。


获取标题格

列.获取标题格 方法

取得本列对应的标题格的接口引用。

调用格式： 〈标题格〉 对象．获取标题格 （）


获取内容格

列.获取内容格 方法

本列对应的内容格的接口引用。

调用格式： 〈内容格〉 对象．获取内容格 （）


IGRColumn.Parent 属性

列.获取父对象 方法

拥有列的明细网格的接口引用。

调用格式：〈明细网格〉 对象．获取父对象 （）
特征

只读


IGRColumnCell 概述

单元格 接口

明细网格中单元格接口的基接口。

说明

明细网格的标题行与内容行的显示区域划分为一个个的单元格，单元格可以直接显示文字，也可以作为部件框容器使用，作为部件框容器的单元格称为自由格。标题行中的单元格称为标题格，内容行中的单元格称为内容格。


IGRColumnCell.BackColor 属性

背景色 属性

指定单元格的背景色。

数据类型:整数型

语法:对象.背景色=整数型

特征

可读写

设计器中可见


IGRColumnCell.PrintType 属性

打印类别 属性

指定单元格的打印生成类别。

数据类型:整数型

语法:对象.打印类别=整数型(注:打印类型枚举值 )

默认值:套打内容

特征:可读写

设计器中可见

说明

注意：只有在格不是自由格时，才允许使用本属性。


IGRColumnCell.Name 属性

名称 属性

指定单元格的名称标识。

数据类型:文本型

语法:对象.名称=文本型

特征

可读写

设计器中可见

说明

注意：当为内容格或当为标题格而不是组标题格时，即格存在对应列，格的名称与列的名称保持一致。当改变格的名称也同时改变列的名称，反之改变列的名称也同时改变格的名称。


IGRColumnCell.EndEllipsis 属性

省略点显示文字 属性

指定是否用省略号表示超出单元格范围的文字。

数据类型:逻辑型

语法:对象.省略点显示文字=逻辑型

默认值:假

特征

可读写

设计器中可见

说明

如果本属性值为真，用省略号（...）表示超出格范围的文字。
注意：只有在格不是自由格时，才允许使用本属性。


IGRColumnCell.TextAlign 属性

文字对齐方式 属性

指定显示文本的文字对齐方式。

数据类型:整数型

语法:对象.文字对齐方式=整数型(注:文字对齐方式枚举值)

特征

可读写

设计器中可见

说明

注意：只有在格不是自由格时，才允许使用本属性。


IGRColumnCell.WordWrap 属性

文字绕行 属性

指定文字是否折行输出的标志。

数据类型:逻辑型

语法:对象.文字绕行=逻辑型

默认值:真

特征

可读写

设计器中可见

说明

如果本属性值为真，文字可以折行输出，否则不论文字多少，只在一行中输出文字。
注意：只有在格不是自由格时，才允许使用本属性。


IGRColumnCell.ForeColor 属性

文字色 属性

指定单元格的输出文本的文字颜色。

数据类型:整数型

语法:对象.文字色=整数型

默认值:0(注:黑色)

特征

可读写

设计器中可见

说明

注意：只有在格是非自由格时，才允许使用本属性。


IGRColumnCell.ShowMoneyLabel 属性

显示财务金额标签 属性

指定是否在此单元格中显示金额标签。

语法:对象.显示财务金额标签=逻辑型

默认值:假

特征

可读写

设计器中可见

说明

注意：只有在格不是自由格时，才允许使用本属性。


IGRColumnCell.ShowMoneyLine 属性

显示财务金额线 属性

指定是否在此单元格中将值显示成金额线格式。

数据类型:逻辑型

语法:对象.显示财务金额线=逻辑型

默认值:假

特征

可读写

设计器中可见

说明

注意：只有在格不是自由格时，才允许使用本属性。


IGRColumnCell.FreeCell 属性

自由格 属性

指定本单元格是否为自由格。

数据类型:逻辑型

语法:对象.自由格=逻辑型

默认值:假

特征

可读写

设计器中可见

说明

当本属性为真时，格为自由格，单元格成为部件框容器，可以添加任意个数，自由排列的部件框到格中；当本属性为假时，单元格不是部件框容器，不能向格中插入部件框，格本身可以显示输出文本。


IGRColumnCell.Controls 属性

获取部件框集合 方法

本单元格所拥有的部件框集合对象的接口引用。

调用格式： 〈部件框集合〉 对象．获取部件框集合 （）

特征:只读

说明

如果格不是自由格时，因非自由格不是部件框容器，所以本属性值为空。


IGRColumnCell.Column 属性

获取列 方法

本单元格对应的列的接口引用。

调用格式： 〈部件框集合〉 对象．获取部件框集合 （）

特征:只读

说明

单元格按照列的宽度与顺序进行排列，一个列对应有一个标题格与一个内容格。如果是组标题格，因为组标题格不存在唯一对应的某个列，所以本属性值为空。


IGRColumnCell.Font 属性

获取字体 属性

指定输出文字时应用的字体对象的接口引用。

调用格式： 〈字体〉 对象．获取字体 （）

特征:只读

设计器中可见

说明

如果单元格是非自由单元格，此属性表示输出显示文本使用的字体，如果单元格是自由单元格，此属性表示子部件框的缺省字体。


IGRColumnContent 概述

内容行 接口

表示明细网格的内容行。

有关此接口所有成员的列表

说明

内容行显示在明细网格标题之后，按照明细网格的记录的顺序每个记录生成一次内容行，如果定义有分组，在每个分组开始与结束时，要插入分组头与分组尾。内容行拥有所有内容格，内容行显示区域被一个个内容格所划分。


IGRColumnContent.AdjustRowHeight 属性

调整行高 属性

指定在每页输出固定行数时，是否自动调整行的高度。

数据类型:整数型

语法:对象.调整行高=逻辑型

默认值:真

特征

可读写

设计器中可见

仅用于打印

说明

本属性只有当‘每页行数(RowsPerPage)’属性的值大于 0 时才有效。如果本属性为真，在生成打印页面时，自动调整每行的高度，使页面的输出区域刚好被行充满。反之则按设计的高度输出。


IGRColumnContent.AlternatingBackColor 属性

交替背景色 属性

指定间隔输出内容行的交替背景色。

数据类型:整数型

语法:对象.交替背景色=整数型

默认值:与背景色相同

特征

可读写

设计器中可见

说明

如果本属性值与背景色(BackColor)属性值不相同，输出时用背景色与交替背景色轮流作为内容行的背景色，此时各个内容格本身的背景色将被忽略掉。


IGRColumnContent.Cursor 属性

光标 属性

指定在查询显示报表时，在本内容行上显示的鼠标光标。

数据类型:整数型

语法:对象.光标=整数型(注:显示光标枚举值)

默认值:默认光标

特征

可读写

设计器中可见


每页行数 属性

打印生成时，指定在一页中显示的行数。

数据类型:整数型

语法:对象.每页行数=整数型

默认值:0

特征

可读写

设计器中可见

仅用于打印

说明

指定打印生成时一页中显示的内容行个数。当本属性等于 0 时，按照内容行的设计高度输出显示内容行，每页中显示内容行的个数为页中可以容纳行的个数。当本属性大于 0 时，每页中显示的内容行个数为 RowsPerPage。默认为 0。


IGRColumnContent.ContentCells 属性

获取内容格集合 属性

获取拥有的内容格集合对象的接口引用。

调用格式： 〈内容格集合〉 对象．获取内容格集合 （）

特征

只读


IGRColumnContentCell 概述

内容格 接口

表示明细网格的内容行中每个列对应的内容格，内容行拥有一组内容格。

有关此接口所有成员的列表，请参阅 IGRColumnContentCell 成员。

派生关系
父类: 单元格

说明

每当增加一个明细网格的列之后，都会在内容行添加一个对应的显示单元格，此种显示单元格称为内容格。一般每个内容格关联一个字段，用来显示字段的内容。如果把内容格设为自由格，则内容格成为部件框容器，可以向内容格添加部件框。


IGRColumnContentCell.CanGrow 属性

可伸展 属性

指定内容格在运行时是否可以伸展高度。

数据类型:逻辑型

语法:对象.可伸展=逻辑型

默认值:假

特征

可读写

设计器中可见


IGRColumnContentCell.CanShrink 属性

可收缩 属性

指定内容格在运行时是否可以收缩高度。

数据类型:逻辑型

语法:对象.可收缩=逻辑型

默认值:假

特征

可读写

设计器中可见


IGRColumnContentCell.DataField 属性

数据字段 属性

指定本内容格关联的记录集字段的名称，在运行时将显示关联字段的显示文字。

数据类型:文本型

语法:对象.数据类型=文本型

特征

可读写

设计器中可见

说明

注意：本属性只能在内容格为非自由格时使用。


IGRColumnContentCell.ShrinkFontToFit 属性

缩小适应 属性

在格的显示区域不能完整显示出文字内容时，指定是否自动缩小文字大小让文字完整显示出来。

语法:对象.缩小适应=逻辑型

默认值

假

特征

可读写

设计器中可见

仅用于打印

说明

此属性在格为自由格时无效。


IGRColumnContentCell.Parent 属性

获取父对象 方法

获取拥有本内容格的内容行的接口引用。

调用格式： 〈对象〉 对象．获取父对象 （）

特征

只读


IGRColumnSection 概述

列行 接口

明细网格的标题行与内容行的基接口。表示标题行与内容行的共同属性与方法。


GRSectionType 枚举

报表节类型枚举

指定报表节的具体类型。

成员名称 | 说明
内容行 | 明细网格内容行。
标题行 | 明细网格标题行。
分组尾 | 分组尾。
分组头 | 分组头。
页脚 | 页脚。
页眉 | 页眉。
报表尾 | 报表尾。
报表头 | 报表头。


IGRSection.BackColor 属性

背景色 属性

报表节的背景填充色。

数据类型:整数型

语法:对象.背景色=整数型

特征:可读写

设计器中可见


IGRSection.Height 属性

高度 属性

报表节的高度。

语法:对象.高度=整数型

特征:可读写

设计器中可见

说明

以报表使用的计量单位表示的节的高度值，如果高度值为零，则本节再生成时将被忽略掉。


IGRSection.SectionType 属性

节类型 属性

指示报表节的具体类型。

数据类型:整数型

语法:对象.节类型=整数型

特征

只读

请参见

报表节类型枚举


IGRSection.CanGrow 属性

可伸展 属性

指示节高度在运行时是否可以伸展的标志。

数据类型:逻辑型

语法:对象.可伸展=逻辑型

默认值:假

特征:可读写

设计器中可见

说明

报表运行时，如果本属性为真且节拥有可伸展的部件框，节的高度伸展幅度为所有拥有部件框的伸展高度之和。


IGRSection.CanShrink 属性

可收缩 属性

指示节高度在运行时是否可以收缩的标志。

数据类型:逻辑型

语法:对象.可收缩=逻辑型

默认值:假

特征:可读写

设计器中可见

说明

报表运行时，如果本属性为真且节拥有可收缩的部件框，节的高度收缩幅度为所有拥有部件框的收缩高度之和。


IGRSection.Name 属性

名称 属性

报表节的名称标识。

数据类型:文本型

语法:对象.名称=文本型

特征:可读写

设计器中可见


IGRSection.Controls 属性

获取部件框集合 方法

获取拥有的部件框集合对象的接口引用。

调用格式： 〈部件框集合〉 对象．获取部件框集合 （）

特征:只读


IGRSection.Parent 属性

获取父对象 方法

父对象的接口引用。

调用格式： 〈部件框集合〉 对象．获取部件框集合 （）

特征:只读


IGRColumnSection.DetailGrid 属性

获取明细网格 方法

获取拥有本节的明细网格的接口引用。

调用格式： 〈对象〉 对象．获取父对象 （）

特征:只读


IGRSection.Font 属性

获取字体 方法

报表节的缺省字体。

〈字体〉 对象．获取字体 （）

特征:只读

设计器中可见


IGRColumnTitle 概述

标题行 接口

表示明细网格的标题行的接口。其拥有一组标题格，标题格在显示排列上具有层次关系，可以定义多层表头。

说明

标题行一般显示在明细网格的最上端，通常只在明细网格开始时输出一次。标题行拥有所有标题格，标题行显示区域被一个个标题格所划分。


IGRColumnSection.KeepTogether 属性

保持同页 属性

指定是否保持整个行打印生成在同一页。

数据类型:逻辑型

语法:对象.保持同页=逻辑型

默认值:真

特征:可读写

设计器中可见

仅用于打印

说明

如果本属性值为真，在当前页中不能够完整显示本节时，换新页并将本节在新页中输出。反之本节有可能被分割输出在两页中。


IGRSection.Visible 属性

可见性 属性

是否显示报表节的标志。

数据类型:逻辑型

语法:对象.可见性=逻辑型

默认值:真

特征

可读写

设计器中可见


IGRColumnTitle.RepeatStyle 属性

重复方式 属性

在打印生成时，指定明细网格标题的重复输出方式。

数据类型:整数型

语法:对象.重复方式=整数型(注:重复方式枚举值)

默认值:不应用

特征

可读写

设计器中可见

仅用于打印

说明

一般标题行只在明细网格的开始位置输出显示一次，当指定重复方式之后，标题行就可以多次输出。

重复方式枚举


IGRColumnTitle.TitleCells 属性

获取标题格集合 方法

获取拥有的标题格集合对象的接口引用。

调用格式： 〈标题格集合〉 对象．获取标题格集合 （）

特征:只读


IGRColumnTitleCell 概述

标题格 接口

表示明细网格的标题行中的标题格。每个列对应一个标题格，一个拥有下级标题格的标题格称为组标题格，组标题格不与某个具体的列唯一对应。

说明

每当增加一个明细网格的列之后，都会在标题行添加一个对应的显示单元格。当我们需要定义多层标题时，具有下级标题的标题也要在标题行添加一个对应的显示单元格，这两种类型的单元格称为标题格。一般在明细网格的标题格中定义列的标题文字。如果把标题格设为自由格，则标题格成为部件框容器，可以向标题格添加部件框。


IGRColumnTitleCell.GroupTitle 属性

是否组标题格 属性

指定本标题格是否为组标题格。

数据类型:文本型

特征:只读

说明

本属性为真，标题格称为组标题格。组标题格不是由列自动创建，也不与一个列关联。组标题格包含数个下级标题格，从而使网格标题具有层次关系。


IGRColumnTitleCell.Visible 属性

可见性 属性

指定是否显示本标题格。

数据类型:逻辑型

语法:对象.可见性=逻辑型

默认值:真

特征

可读写

设计器中可见

说明

当标题格不是组标题格时，本属性与其对应的列的 可见性 属性保持一致。当标题格是组标题格时，当本属性为假时，本组标题格所包含的所有列在输出时都将被忽略掉，而不管所包含的列自身的 可见性 属性为何值。


IGRColumnTitleCell.Text 属性

文字 属性

指定标题格的显示文本。

数据类型:文本型

语法:对象.文字=文本型

特征:可读写

设计器中可见

说明

注意：本属性只能在标题格为非自由格时使用。


IGRColumnTitleCell.EncloseColumn 方法

包含列 方法

将一个列对应的标题格包含到此组标题格中，新包含进来的列标题格在显示顺序上处于本组的最后。

调用格式： 〈无返回值〉 对象．包含列 （通用型 列索引）

参数

列索引:指定被包含列的名称或顺序号。

说明

只有当标题格为组标题格时，才能调用本方法。


IGRColumnTitleCell.AddSubGroupTitle 方法

增加下级组标题格 方法

在此组标题格中增加一个下级组标题格。

调用格式： 〈标题格〉 对象．增加下级组标题格 （文本型 名称，文本型 标题）

返回值:标题格

新增下级组标题格对象的接口引用。

参数

名称

新增组标题格的名称标识。

标题

新增组标题格的显示文本。

说明

在一个组标题格中，如果还需要包括下级组标题格，则调用本方法进行定义。


IGRControl 概述

部件框 接口

部件框的基接口，定义各种类型的部件框所具有的共同属性与方法。

说明

部件框是对报表中最基本可显示单元的统称，部件框在其父容器中占据一个矩形区域，部件框的内容输出在此矩形区域中，部件框包括背景填充方式与背景色、边框输出模式、以及具体类型的部件框的输出前景色。


IGRControl.BackStyle 属性

背景模式 属性

部件框显示时背景的填充方式。

数据类型:整数型

语法:对象.背景模式=整数型(注:背景模式枚举值)

默认值:#背景模式枚举.透明

特征:可读写

设计器中可见

请参见

背景模式枚举


IGRControl.BackColor 属性

背景色 属性

部件框的背景色。

数据类型:整数型

语法:对象.背景色=整数型

默认值:继承父组件背景色.

特征:可读写

设计器中可见

说明

如果 背景框 属性为 透明 时，部件框生成时不填充背景，本属性此时被忽略掉。


IGRControl.BorderWidth 属性

边框宽度 属性

边框线的宽度。

数据类型:整数型

语法:对象.边框宽度=整数型

默认值:1

特征

可读写

设计器中可见

说明

以屏幕像素作为计量单位，默认是 1。


IGRControl.BorderStyles 属性

边框模式 属性

边框线的显示方式。

数据类型:整数型(注:边框模式枚举值的组合)

语法:对象.边框模式=整数型(边框模式枚举值)

默认值:0

特征:可读写

设计器中可见

说明

本属性值是 边框模式枚举值的按位组合。默认值是 0，不显示任何边框。

请参见

边框模式枚举


IGRControl.BorderColor 属性

边框色 属性

边框线的显示颜色。

数据类型:整数型

语法:对象.边框色=整数型

默认值:黑色

特征

可读写

设计器中可见


IGRControl.Tag 属性

标签 属性

部件框的标识值。

数据类型:整数型

语法:对象.标签=整数型

默认值:0

特征

可读写

设计器中可见

说明

可以按自己意愿任意使用本属性，如可以将此属性作为对象的身份标识,相当于语言中各种组件的标记属性。


IGRControl.ControlType 属性

部件框类型 属性

获取本部件框的具体类型。

数据类型:整数型(注:部件框类型枚举值)

语法:对象.部件框类型

特征

只读

请参见

部件框类型枚举


IGRControl.PrintType 属性

打印类别 属性

部件框的打印输出方式。

数据类型:整数型

语法:对象.打印类别=整数型(注:打印类型枚举值)

特征

可读写

设计器中可见

仅用于打印

请参见

打印类别枚举


IGRControl.AlignColumn 属性

对齐列 属性

指定部件框水平位置对齐到明细网格列的名称。

数据类型:文本型

语法:对象.对齐列=文本型(注:列名称)

特征:可读写

设计器中可见

说明

如果本属性值不为空时，配合 对齐列方式 属性一起指定部件框与列的对齐方式，部件框的水平位置将跟随列位置的改变而改变。
注意：只有当部件框在分组头与分组尾中时才能使用本属性。


IGRControl.AlignColumnSide 属性

对齐列方式 属性

部件框对齐到明细网格列的方式。

数据类型:整数型

语法:对象.对齐列方式=整数型(注:对齐列方式枚举)

默认值:#对齐列方式枚举.左右两端

特征

可读写

设计器中可见

说明

注意：只有当部件框在分组头与分组尾中时才能使用本属性。

请参见

对齐列方式枚举


IGRControl.AlignColumnEx 属性

对齐列扩展 属性

指定部件框水平位置对齐到明细网格另一个列的名称。

数据类型:文本型

语法:对象.对齐列扩展=文本型(注:列名称)

特征

可读写

设计器中可见

说明

如果本属性值不为空时，配合 对齐列方式 属性一起指定部件框与列的对齐方式，部件框的水平位置将跟随列位置的改变而改变。

对齐列扩展 与 对齐列 可以指定到不同的列，这样部件框就可以跨列对齐到不同的列。如果 对齐列扩展 与 对齐列 只设定了其中之一的，则部件框只对齐到一个列。如果两者都没有设定，则部件框不会对齐到任何列。


IGRControl.Height 属性

高度 属性

部件框的显示高度。

数据类型:双精度小数型

语法:对象.高度=双精度小数型

特征:可读写

设计器中可见

说明

以报表使用的计量单位表示的显示高度值。


IGRControl.Cursor 属性

光标 属性

指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。

数据类型:整数型

语法:对象.光标=整数型(注:显示光标枚举值)

默认值:#显示光标枚举值.默认光标

特征

可读写

设计器中可见

请参见

显示光标枚举


IGRControl.Center 属性

居中 属性

指定水平与垂直方向的居中对齐方式。

数据类型:整数型

语法:对象.居中=整数型(注:居中方式枚举值)

默认值:无

特征

可读写

设计器中可见

说明

指定部件框在容器中水平与垂直方向上的居中对齐方式。


IGRControl.Visible 属性

可见性 属性

是否显示部件框的标志。

数据类型:逻辑型

语法:对象.可见性=逻辑型

默认值:真

特征

可读写

设计器中可见

说明

当此属性为假时，部件框在输出时将被忽略掉。


IGRControl.Width 属性

宽度 属性

部件框的显示宽度。

数据类型:双精度小精型

语法:对象.宽度=双精度小数型

特征

可读写

设计器中可见

说明

以报表使用的计量单位表示的显示宽度值。


IGRControl.Anchor 属性

锚定 属性

指定部件框的哪些边缘锚定到其容器边缘。

数据类型:整数型

语法:对象.锚定=整数型(注:锚定方式枚举组合值)

默认值:左边|上边

特征

可读写

设计器中可见

说明

本属性值是 锚定方式枚举 值的按位组合。默认值是左边和 上边 。

请参见

锚定方式枚举


IGRControl.Name 属性

名称 属性

部件框的名称标识。

数据类型:文本型

语法:对象.名称=文本型

特征 可读写

设计器中可见


IGRControl.Top 属性

上 属性

部件框的顶端显示位置。

数据类型:双精度小数型

语法:对象.上=双精度小数型

特征:可读写

设计器中可见

说明

以报表使用的计量单位表示的顶端显示位置值，相对于父容器。


IGRControl.Dock 属性

停靠 属性

指定部件框停靠到父容器的哪一个边缘。

数据类型:整数型

语法:对象.停靠=整数型(注:停靠方式枚举值)

默认值:无

特征

可读写

设计器中可见

停靠方式枚举


IGRControl.ForeColor 属性

文字色 属性

部件框输出内容的前景色。

数据类型:整数型

语法:对象.文字色=整数型

默认值:从父部件继承

特征

可读写

设计器中可见

说明

一般表示输出文字的显示颜色。


IGRControl.Left 属性

左 属性

部件框的左端显示位置。

数据类型:双精度小精型

语法:对象.左=双精度小精型

特征:可读写

设计器中可见

说明

以报表使用的计量单位表示的左端显示位置值，相对于父容器。


IGRControl.AsRichTextBox 属性

获取为RTF文字框 方法

将本部件框转换为丰富格式文字框的接口引用。

调用格式： 〈丰富格式文字框〉 对象．获取为RTF文字框 （）

特征

只读

仅运行时可用

说明

只有当本部件框确实是丰富格式文字框(RichTextBox)时，才能成功读取本属性值。

请参见

部件框 接口 | 丰富格式文字框 接口


IGRControl.AsStaticBox 属性

获取为静态文字框 方法

将本部件框转换为静态框的接口引用。

调用格式： 〈静态文字框〉 对象．获取为静态文字框 （）

特征

只读

说明

只有当本部件框确实是静态框(StaticBox)时，才能成功读取本属性值。

请参见

部件框接口 | 静态文字框接口


IGRControl.AsSummaryBox 属性

获取为统计框 方法将本部件框转换为统计框的接口引用。

调用格式： 〈统计框〉 对象．获取为统计框 （）

特征

只读

说明

只有当本部件框确实是统计框(SummaryBox)时，才能成功读取本属性值。

请参见

部件框接口 | 统计框接口


IGRControl.AsChart 属性

获取为图表 方法

将本部件框转换为图表部件框的接口引用。

调用格式： 〈图表〉 对象．获取为图表 （）

特征

只读

说明

只有当本部件框确实是图表(Chart)时，才能成功读取本属性值。

请参见

部件框 接口 | 图表接口


IGRControl.AsPictureBox 属性

获取为图像框 方法

将本部件框转换为图像框的接口引用。

调用格式： 〈图像框〉 对象．获取为图像框 （）

特征

只读

仅运行时可用

说明

只有当本部件框确实是图像框(PictureBox)时，才能成功读取本属性值。

请参见

部件框接口 | 图像框接口


IGRControl.AsShapeBox 属性

获取为图形框 方法

将本部件框转换为图形框的接口引用。

调用格式： 〈图形框〉 对象．获取为图形框 （）

特征

只读

说明

只有当本部件框确实是图形框(ShapeBox)时，才能成功读取本属性值。

请参见

部件框接口 | 图形框接口


IGRControl.AsTextBox 属性

获取为文字框 方法
转换本部件框为文字框基类的接口引用。

调用格式： 〈文字框〉 对象．获取为文字框 （）

特征

只读

说明

只有当本部件框确实是文字基类框(TextBox)派生类的对象时，才能成功读取本属性值。文字基类派生的类包括：静态文本框、综合文本框、字段框、统计框、系统变量框。

请参见

部件框接口 | 文字框接口


IGRControl.AsSystemVarBox 属性

获取为系统变量框 方法

将本部件框转换为系统变量框的接口引用。

调用格式： 〈系统变量框〉 对象．获取为系统变量框 （）

特征

只读

说明

只有当本部件框确实是系统变量框(SystemVarBox)时，才能成功读取本属性值。

请参见

部件框接口 | 系统变量框接口


IGRControl.AsLine 属性

获取为线段 方法

将本部件框转换为线段的接口引用。

调用格式： 〈线段〉 对象．获取为线段 （）

特征

只读

说明

只有当本部件框确实是线段(Line)时，才能成功读取本属性值。

请参见

部件框接口 | 线段接口


IGRControl.AsSubReport 属性

获取为子报表 方法

转换本部件框为子报表的接口引用。

调用格式： 〈子报表〉 对象．获取为子报表 （）

特征

只读

说明

只有当本部件框确实是子报表(SubReport)时，才能成功读取本属性值。

请参见

部件框接口 | 子报表接口


IGRControl.AsFieldBox 属性

获取为字段框 方法

将本部件框转换为字段框的接口引用。

调用格式： 〈字段框〉 对象．获取为字段框 （）

特征

只读

说明

只有当本部件框确实是字段框(FieldBox)时，才能成功读取本属性值。

请参见

部件框接口 | 字段框接口


IGRControl.AsMemoBox 属性

获取为综合文字框 方法

转换本部件框为综合文本框的接口引用。

调用格式： 〈综合文字框〉 对象．获取为综合文字框 （）

特征

只读

说明

只有当本部件框确实是综合文本框(MemoBox)时，才能成功读取本属性值。

请参见

部件框接口 | 综合文字框接口


IGRControl.Font 属性

获取字体 属性

输出文字时使用的字体。

调用格式： 〈字体〉 对象．获取字体 （）

默认值:从父组件继承

只读

设计器中可见

请参见

部件框接口 | 字体接口


IGRControl.SetBounds 方法

设置边界 方法

设置部件框在其父容器中的边界位置。

调用格式： 〈无返回值〉 对象．设置边界 （双精度小数型 左边，双精度小数型 顶边，双精度小数型 右边，双精度小数型 底边)


IGRControl.SendToBack 方法

显示到后端 方法

将部件框发送到 Z 顺序的后面。

调用格式： 〈无返回值〉 对象．显示到后端 （）

说明

此部件框将在同一容器中的其它部件框之前输出显示，如果后输出的部件框与其在位置上有重叠，则后输出的部件框将覆盖此部件框。


IGRControl.BringToFront 方法

显示到前端 方法

将部件框带到 Z 顺序的前面。

调用格式： 〈无返回值〉 对象．显示到前端 （）

说明

此部件框将在同一容器中的其它部件框之后输出显示，如果前面输出的部件框与其在位置上有重叠，则此部件框将覆盖前面输出的部件框。


IGRDetailGrid 概述

明细网格 接口

表示明细网格对象。绝大多数报表都拥有明细网格，并且明细网格是多数报表的主体。

说明

明细网格就是处理报表明细数据生成的实现定义，一般的报表都需要一个明细网格，明细网格一般生成在报表头之后及报表尾之前，一般明细网格构成了一个报表的主体，报表的主要信息输出在明细网格中，明细网格由实现明细数据生成需要的多种子对象组成。


IGRDetailGrid.BackColor 属性

背景色 属性

指定明细网格的标题行、内容行、分组头与分组尾的默认背景色。

数据类型:整数型

语法:对象.背景色=整数型

特征:可读写

设计器中可见

说明

此属性作为明细网格拥有的各种子对象的缺省背景色。


IGRDetailGrid.BorderWidth 属性

边框宽度 属性

边框线宽度。

数据类型:整数型

语法:对象.边框宽度=整数型

默认值:1

特征

可读写

设计器中可见

说明

以屏幕像素表示属性值。


IGRDetailGrid.BorderStyles 属性

边框模式 属性

指定网格边框线的输出方式。

数据类型:整数型

语法:对象.边框模式=整数型(注:边框模式枚举组合)

默认值 画左|画上|画右|画下

特征

可读写

设计器中可见

请参见

边框模式枚举


IGRDetailGrid.BorderColor 属性

边框色 属性

边框线颜色。

数据类型:整数型

语法:对象.边框色=整数型

默认值:#黑色

特征

可读写

设计器中可见


IGRDetailGrid.PrintAdaptMethod 属性

打印适应策略 属性

打印输出时，根据输出页面的情况，指定列的输出策略。

数据类型:整数型

语法:对象.打印适应策略=整数型(注:打印策略枚举值)

默认值:缩小适应

特征

可读写

设计器中可见

仅用于打印

请参见

打印策略枚举


IGRDetailGrid.PrintAdaptRepeat 属性

打印重复策略 属性

当打印策略为‘另起新页’或‘另起新页并重复固定列’时，报表头与报表尾是否在新页中再次输出。

数据类型:逻辑型

语法:对象.打印重复策略=逻辑型

默认值:真

特征:可读写

设计器中可见


IGRDetailGrid.NewPage 属性

换新页方式 属性

打印生成时，指定强制换新页的方式。

数据类型:整数型

语法:对象.换新页方式=整数型(注:换新页方式枚举值)

默认值:不应用

特征

可读写

设计器中可见

仅用于打印

请参见

换新页方式枚举


IGRDetailGrid.CenterView 属性

居中显示 属性

当明细网格的列总宽度小于显示区域宽度时，指定是否水平居中显示明细网格。

数据类型:逻辑型

语法:对象.居中显示=逻辑型

默认值:真

特征

可读写

设计器中可见

说明

当列的总宽度小于显示区域的宽度时，当本属性值为真时，在水平方向上将明细网格居中显示，反之则靠左边显示。


IGRDetailGrid.BackgroundColor 属性

空白背景色 属性

查询显示时，网格外围的空白区域的背景填充色。

数据类型:整数型

语法:对象.空白背景色=整数型

特征

可读写

设计器中可见

仅用于查询


IGRDetailGrid.ColumnMove 属性

列可移动 属性

查询显示时，指定是否可以用鼠标拖放改变列的显示顺序。

数据类型:逻辑型

语法:对象.列可移动=逻辑型

默认值:真

特征

可读写

设计器中可见

仅用于查询

说明

注意：本属性只应用于查询显示器中。


IGRDetailGrid.ColumnResize 属性

列宽可变 属性

查询显示时，指定是否可以通过鼠标拖放改变列的显示宽度。

数据类型:逻辑型

语法:对象.列宽可变=逻辑型

默认值:真

特征

可读写

设计器中可见

仅用于查询

说明

注意：本属性只应用于查询显示器中。


IGRDetailGrid.ColLineWidth 属性

列线宽度 属性

网格列线的宽度，以屏幕像素为计量单位。

数据类型:整数型

语法:对象.列线宽度=整数型

默认值

1

特征

可读写

设计器中可见


IGRDetailGrid.FixCols 属性

锁定列数 属性

查询显示时，指定锁定的列数，左边被锁定的列始终不进行水平滚动。

数据类型:整数型

语法:对象.锁定列数=整数型

默认值

0

特征

只读

设计器中可见

仅用于查询

说明

指定固定列的个数，默认时0。当属性值大于0时，前 FixCols 个列不跟随水平滚动条的滚动而滚动，而是始终显示在明细网格的左端。
注意：本属性只应用于查询显示器中。

请参见


IGRDetailGrid.ShowColLine 属性

显示列线 属性

指定是否显示网格列分隔线。

数据类型:逻辑型

语法:对象.显示列线=逻辑型

默认值 真

特征

可读写

设计器中可见


IGRDetailGrid.ShowRowLine 属性

显示行线 属性

指定是否显示网格行分隔线。

数据类型:逻辑型

语法:对象.显示行线=逻辑型

默认值:真

特征

可读写

设计器中可见


IGRDetailGrid.LineColor 属性

行线颜色 属性

指定行列分隔线的颜色。

数据类型:整数型

语法:对象.行线颜色=整数型

默认值

特征

可读写

设计器中可见


IGRDetailGrid.ColLineColor 属性

列线颜色 属性

指定列分隔线的颜色。

数据类型:整数型

语法:对象.列线颜色=整数型

默认值 黑色

特征

可读写

设计器中可见


IGRDetailGrid.RowLineWidth 属性

行线宽度 属性

网格行线的宽度，以屏幕像素为计量单位。

数据类型:整数型

语法:对象.行线宽度=整数型

默认值

1

特征

可读写

设计器中可见


IGRDetailGrid.SelectionBackColor 属性

选中背景色 属性

查询显示时，选中格或行的背景填充色。

数据类型:整数型

语法:对象.选中背景色=整数型

默认值 蓝色

特征

可读写

设计器中可见

仅用于查询


IGRDetailGrid.SelectionForeColor 属性

选中前景色 属性

查询显示时，选中格或行的前景色。

数据类型:整数型

语法:对象.选中前景色=整数型

默认值

特征

可读写

设计器中可见

仅用于查询


IGRDetailGrid.PageColumnDirection 属性

页栏方向 属性

在输出多栏报表时，数据行生成到输出位置的方向。

数据类型:整数型

语法:对象.页栏方向=整数型(注:页栏显示方向枚举值)

默认值 上到下左到右

特征

可读写

设计器中可见

仅用于打印


IGRDetailGrid.PageColumnSpacing 属性

页栏间距 属性

指定多栏报表的栏间距，以报表的计量单位表示。

数据类型:双精度小数型

语法:对象.页栏间距=双精度小数型

默认值

0

特征

可读写

设计器中可见

仅用于打印


IGRDetailGrid.PageColumnCount 属性

页栏数 属性

在水平方向上均分打印输出区域的个数，也就是报表栏数。

数据类型:整数型

语法:对象.页栏数=整数型

默认值

1

特征

可读写

设计器中可见

仅用于打印

说明

值范围：1-50


IGRDetailGrid.RowSelection 属性

整行选中 属性

指定在查询显示报表时是否整行选中内容行。

数据类型:逻辑型

语法:对象.整行选中=逻辑型

默认值 真

特征

可读写

设计器中可见

仅用于查询


IGRDetailGrid.AppendBlankRow 属性

追加空白行 属性

打印输出时，是否在页的剩余区域补充显示空白内容行的标志。

数据类型:逻辑型

语法:对象.追加空白行=逻辑型

默认值 假

特征

可读写

设计器中可见

仅用于打印


IGRDetailGrid.AlwaysShowVScrollBar 属性

总显示垂直滚动条 属性

查询显示时，是否始终显示垂直滚动条的标志。

数据类型:逻辑型

语法:对象.总显示垂直滚动条=逻辑型

默认值 假

特征

可读写

设计器中可见

仅用于查询

说明

注意：本属性只应用于屏幕显示


IGRDetailGrid.AlwaysShowHScrollBar 属性

总显示水平滚动条 属性

查询显示时，是否始终显示水平滚动条的标志。

数据类型:逻辑型

语法:对象.总显示水平滚动条=逻辑型

特征

可读写

设计器中可见

仅用于查询

说明

注意：本属性只应用于查询显示器中输出。


IGRDetailGrid.FindGroupTitleCell 方法

查找组标题格 方法

根据名称找到组标题格对象的接口引用。

调用格式： 〈标题格〉 对象．查找组标题格 （文本型 标题格名称）

名称匹配的组标题格对象的接口引用。

参数

标题格名称

指定要查找组标题格的名称。

说明

如果存在与输入名称参数匹配的组标题格对象，则返回组标题格对象的接口引用，否则返回NULL。例如使用此方法取得组标题格的接口引用，然后向其中添加包含的列。

请参见

IGRDetailGrid 接口 | IGRDetailGrid 成员 | IGRColumnTitleCell 接口 | IGRDetailGrid.AddGroupTitle 方法 | IGRDetailGrid.ClearGroupTitles 方法 | IGRColumnTitle.TitleCells 属性


IGRDetailGrid.ColumnTitle 属性

获取标题行 方法

获取明细网格拥有的标题行对象的接口引用。

调用格式： 〈标题行〉 对象．获取标题行 （）只读

请参见

明细网格 接口 | 标题行接口


IGRDetailGrid.Groups 属性

获取分组集合 属性

获取网格拥有的分组集合对象的接口引用。

调用格式：〈分组集合〉 对象．获取分组集合 （）

特征

只读

请参见

明细网格接口 | 分组集合接口


IGRDetailGrid.Columns 属性

获取列集合 属性

获取网格拥有的列集合对象的接口引用。

调用格式： 〈列集合〉 对象．获取列集合 （）

特征

只读

请参见

明细网格接口 | 列集合接口


IGRDetailGrid.ColumnContent 属性

获取内容行 属性

明细网格拥有的内容行的接口引用。

调用格式： 〈内容行〉 对象．获取内容行 （）特征

只读

说明

在输出时，每条明细记录将根据内容行定义输出一次。

请参见

明细网格接口 | 内容行接口


IGRDetailGrid.Recordset 属性

获取数据集 属性

获取网格拥有的记录集对象的接口引用。

调用格式： 〈记录集〉 对象．获取数据集 （）

特征

只读

请参见

明细网格 接口 | 记录集接口


IGRDetailGrid.Font 属性

获取字体 属性

获取明细网格拥有的子对象的缺省字体对象的接口引用。

调用格式： 〈字体〉 对象．获取字体 （）

特征

只读

设计器中可见

请参见

明细网格接口 | 字体接口


IGRDetailGrid.StartNewGroup 方法

开始新分组 方法

在报表生成时，开始生成一个新的分组项。

调用格式： 〈无返回值〉 对象．开始新分组 （通用型 分组名称序号）

参数

分组名称或者序号

指定分组对象的标识，可以是分组对象的名称，也可以是分组对象的顺序号。

说明

只能在报表生成时的 处理记录 事件中调用本方法，目的是为了生成自定义的分组。


IGRDetailGrid.ClearColumns 方法

清空列 方法

删除所有的列。

调用格式： 〈无返回值〉 对象．清空列 （）


IGRDetailGrid.ClearGroupTitles 方法

清空组标题格 方法

删除全部组标题格。

调用格式： 〈无返回值〉 对象．清空组标题格 （）


IGRDetailGrid.ColumnMoveToEnd 方法

移动列到最后 方法

将列地显示顺序移动到最后。

调用格式： 〈无返回值〉 对象．移动列到最后 （通用型 列名称或序号）

参数

列名称或序号

指定列的标识，可以是列的名称，也可以识列的顺序号。


IGRDetailGrid.AddColumn 方法

增加列 方法

增加一个新列。

调用格式： 〈列〉 对象．增加列 （文本型 列名称，文本型 列标题，文本型 关联字段名，双精度小数型 列宽度）

返回值

列

新增列对象的接口引用。

参数

文本型 列名称

列的名称标识。

文本型 列标题

列的标题文本。

文本型 关联字段名

列关联的字段名称。

双精度小数型 列宽度

列的宽度。


IGRDetailGrid.AddGroupTitle 方法

增加组标题格 方法

增加一个新组标题格。

调用格式： 〈标题格〉 对象．增加组标题格 （文本型 名称，文本型 标题）

返回值: 标题格

返回新增组标题格对象的接口引用。

参数

文本型 名称

指定新增组标题格的名称。

文本型 标题

指定新增组标题格的显示文本。


IGRField 概述

字段 接口

定义各种类型的数据字段的类。

说明

定义记录的每个数据项，字段存储的数据类型由子段的类型确定。在运行时，记录的读写就是通过各个字段值的读写实现。在编辑记录时，不允许对不定长字符字段与二进制字段进行改变。


IGRField.Length 属性

获取或设置字符类型字段的字符长度，为 0 表示不定长类型字符类型字段。

ULONG Length

默认值

0

特征

可读写

设计器中可见

说明

不定长字符类型字段可以保存任意长度的字符数据，但在编辑记录时，不定长字符类型字段的值不允许改变。

请参见


IGRField.AsFloat 属性

获取或设置字段的用浮点数类型表示的值。

DOUBLE AsFloat

特征

可读写

仅运行时可用


IGRField.Format 属性

获取或设置将字段值转换为显示文本时所应用的格式文字串。

BSTR Format

特征

可读写

设计器中可见

说明

本属性只对布尔、整数、浮点数、货币及日期时间类型的字段有效。

请参见


IGRField.AsCurrency 属性

获取或设置字段的用货币类型表示的值。

CURRENCY AsCurrency

特征

可读写

仅运行时可用

请参见


IGRField.AsBoolean 属性

获取或设置字段的用布尔类型表示的值。

VARIANT_BOOL AsBoolean

特征

可读写

仅运行时可用

请参见


IGRField.Name 属性

获取或设置字段的名称标识。

BSTR Name

特征

可读写

设计器中可见

请参见


IGRField.AsDateTime 属性

获取或设置字段的用日期时间类型表示的值。

DATE AsDateTime

特征

可读写

仅运行时可用

请参见


IGRField.DataSize 属性

获取存储二进制字段值的数据缓冲区的大小，以字节为计量单位。

ULONG DataSize

特征

只读

仅运行时可用

说明

本属性只对二进制类型的字段有效，存储字段值的数据缓冲区的字节大小。用 DataBuffer 属性可以得到数据缓冲区的内存指针。

请参见


IGRField.DataBuffer 属性

获取存储二进制字段值的数据缓冲区内存地址指针。

LONG_PTR DataBuffer

特征

只读

仅运行时可用

说明

本属性只对二进制类型的字段有效，存储字段值的数据缓冲区内存地址指针。用 DataSize 属性可以得到数据缓冲区的大小。

请参见


IGRField.IsNull 属性

获取字段值是否为空的标志。

VARIANT_BOOL IsNull

特征

只读

仅运行时可用

请参见


IGRField.DisplayText 属性

显示文字 属性

获取或设置部件框的输出显示文本。

语法:对象.显示文字=文本型

特征

可读写

仅运行时可用

说明

获取或设置部件框的输出显示文本。只有在运行时才能使用本属性，当不能由Grid++Report根据字段的值自动产生显示文本时，在请求字段显示文字事件中为字段的显示文字属性赋一个新的显示文本。

例如当需要将金额的负数值显示为红字时，需要将数字显示文字前面的负号去掉，就必须响应请求字段显示文字事件并使用显示文字属性。

请参见


IGRField.AsInteger 属性

获取或设置字段的用整数类型表示的值。

LONG AsInteger

特征

可读写

仅运行时可用

请参见


IGRField.FieldType 属性

获取或设置字段的数据类型。

GRFieldType FieldType

默认值

grftString

特征

可读写

设计器中可见


IGRField.AsString 属性

获取或设置字段的用字符串类型表示的值。

BSTR AsString

特征

可读写

仅运行时可用


IGRField.LoadFromMemory 方法

运行时从内存数据缓冲区中载入二进制字段的值。

void LoadFromMemory(LONG_PTR pBuffer, ULONG ByteCount);

参数

LONG_PTR pBuffer

指定内存数据缓冲区的地址指针。

ULONG ByteCount

指定内存数据缓冲区的字节大小。

说明

注意：本方法只对二进制类型的字段有效。

请参见

IGRField 接口 | IGRField 成员 | IGRField.LoadFromFile 方法 | IGRField.FieldType 属性


IGRField.LoadFromFile 方法

运行时从文件中载入二进制字段的值。

void LoadFromFile(BSTR PathFile);

参数

BSTR PathFile

指定载入文件的完整路径名称。

说明

注意：本方法只对二进制类型的字段有效。

请参见

IGRField 接口 | IGRField 成员 | IGRField.LoadFromMemory 方法 | IGRField.FieldType 属性


IGRField.Clear 方法

将字段的值设为空。

void Clear(void);

说明

应只在报表主对象的 FetchRecord 与 BeforePostRecord 事件响应函数中调用此方法。

请参见

IGRField 接口 | IGRField 成员 | IGRField.IsNull 属性 | IGridppReport.FetchRecord 事件 | IGridppReport.BeforePostRecord 事件


IGRFieldBox 概述

字段框 接口

表示字段部件框。关联一个记录集的字段，显示字段的值。

说明

用来显示字段内容的部件框，在设计时关联一个字段对象，在输出显示时根据输出格式信息将字段对象在当前记录的显示文本画出来。字段框一般使用在明细网格的自由内容格、分组头、分组尾中。

请参见

字段 接口


IGRFieldBox.DataField 属性

数据字段 属性

获取或设置关联字段对象的名称。

语法:对象.数据字段=文本型

特征

可读写

设计器中可见

请参见

字段框 接口 | 字段 接口


IGRTextBox.TextAlign 属性

文字对齐方式 属性

文字的输出对齐方式。

语法:对象.文字对齐方式=整数型(注:文字对齐方式枚举值)

默认值:左上

特征

可读写

设计器中可见

请参见

文字框 接口 | 文字对齐方式枚举 | 省略点显示文字 属性 | 文字绕行属性


IGRTextBox.WordWrap 属性

文字绕行 属性

是否多行显示文本标志。

语法:对象.文字绕行=逻辑型

默认值:假

特征

可读写

设计器中可见

请参见

文字框接口 | 省略点显示文字 属性 | 文字对齐方式属性


IGRTextBox.GetDisplayTextScript 属性

显示文字脚本 属性

表示报表 请求文字框显示文字 事件对应的脚本语言代码。

语法:对象.显示文字脚本=文本型

特征

可读写

设计器中可见

请参见

文字框接口 | 报表.请求文字框显示文字 事件


IGRTextBox.ShrinkFontToFit 属性

缩小适应 属性

在文字框的显示区域不能完整显示出文字内容时，指定是否自动缩小文字大小让文字完整显示出来。

语法:对象.缩小适应=逻辑型
默认值 假

特征

可读写

设计器中可见

仅用于打印


IGRFont 概述

字体接口

表示报表对象显示文字所使用字体的对象。

说明

表示报表对象显示文字所使用字体的对象。字体对象提供属性用来获取与设置字体定义，需要显示文本或需要为子对象提供缺省字体的报表对象拥有字体对象。当报表对象不使用其缺省字体时，它的字体对象拥有一个OLE字体对象，其字体定义由OLE字体对象表示，可以通过 OleFont 属性取得OLE字体对象的接口引用。当报表对象使用缺省字体时，其字体对象不拥有一个OLE字体对象，其字体定义来自其上级对象的字体定义，OleFont 属性为NULL。

报表开发者可以在 格式化报表节 事件响应函数中改变触发事件报表节本身或其拥有的单元格或部件框的字体定义，从而改变对应文本的显示。通过设定字体对象的属性来改变字体定义，如果将 OleFont 属性设为NULL，将导致使用缺省字体。

Grid++Report中拥有字体对象的报表对象有：
(1).报表主对象IGridppReport)。其字体对象定义整个报表的缺省字体。OleFont 属性永远不为NULL。
(3).明细网格(IGRDetailGrid),其字体对象定义其拥有的字节（标题行、内容行、分组头、分组尾）的缺省字体。其缺省字体来自报表主对象。
(2).报表节(IGRSection)。其字体对象定义其拥有全部部件框或单元格的缺省字体。如果报表节的类型为页眉、页脚、报表头、报表尾，其缺省字体来自报表主对象。如果报表节的类型为标题行、内容行、分组头、分组尾，其缺省字体来自明细网格。
(4).单元格(IGRColumnCell)。如果为非自由格，其字体对象定义单元格文本的显示字体；如果为非自由格，其字体对象定义单元格拥有全部部件框的缺省字体。标题格的缺省字体来自标题行，内容格的缺省字体来自内容行。
(5).部件框(IGRControl)。其字体对象定义部件框文本的显示字体。其缺省字体来自父容器。

请参见

IGRFont 成员 | IGridppReport 接口 | IGRDetailGrid 接口 | IGRSection 接口 | IGRColumnCell 接口 | IGRControl 接口


IGRFont.Bold 属性

粗体 属性

该值指示此字体对象是否为粗体。

语法:对象.粗体=逻辑型

特征

可读写

设计器中可见


IGRFont.Weight 属性

粗细度 属性

该值用数字指示此字体对象的字体粗细，比 Bold 属性更具灵活性。

语法:对象.粗细度=整数型
特征

可读写

设计器中可见


IGRFont.Point 属性

点数 属性

指示此字体对象的字体大小尺寸，一般此值等同字体在字体对话框中显示的大小值。

语法:对象.点数=整数型
特征

可读写

设计器中可见


IGRFont.Name 属性

名称 属性

此字体对象的字体名称。

语法:对象.名称=文本型

特征

可读写

设计器中可见


IGRFont.Strikethrough 属性

删除线 属性

该值指示此字体对象是否指定通过该字体的横线。

语法:对象.删除线=逻辑型
特征

可读写

设计器中可见


IGRFont.Underline 属性

下划线 属性

该值指示此字体对象是否有下划线。

语法:对象.下划线=逻辑型
特征

可读写

设计器中可见


IGRFont.Italic 属性

斜体 属性

指示此字体对象是否为斜体。

语法:对象.斜体=逻辑型
特征

可读写

设计器中可见


IGRFont.Charset 属性

字符集 属性

该值指定此字体对象使用的 GDI 字符集。

语法:对象.字符集=整数型

特征

可读写

设计器中可见


IGRFont.OleFont 属性

获取OLE字体 方法
设置OLE字体 方法

指定字体对象拥有的OLE字体对象的接口引用。

调用格式： 〈对象〉 对象．获取OLE字体 （）

调用格式： 〈无返回值〉 对象．设置OLE字体 （对象 属性值）

说明

指定字体对象拥有的OLE字体的接口引用。如果报表对象使用缺省字体，此属性为NULL，反之此属性为一个有效的OLE字体对象的接口引用。将此属性设为NULL使报表对象使用缺省字体。


IGRFont.UsingOleFont 属性

获取使用OLE字体 属性

指定拥有此字体的报表对象在显示文本时所应用的OLE字体的接口引用。

调用格式： 〈对象〉 对象．获取使用OLE字体 （）

特征

只读

说明

当报表对象使用自己定义的字体时，此属性的值等于 OleFont 属性的值。当报表对象使用缺省字体时，此属性的值来自上级对象的 UsingOleFont 属性。

注意：如果使用本属性取得的OLE字体对象的接口引用进行改变字体的操作，有可能改变的是上级报表对象，或上级报表对象的上级报表对象的字体定义。


IGRGroup 概述

分组 接口

表示记录的分组。可以定义不同的分组方式，分组对象拥有一个分组头与分组尾。

说明

定义分组规则，对所有的记录数据进行归类，并将归类统计数据显示在分组头或分组尾。当属性页分组为真，在打印生成页面时，每个页产生一个分组项；当属性页分组为假，如果属性依据字段关联字段，将相同字段值的记录归类为一个分组项，通常记录的顺序应按分组字段进行排序，如果属性依据字段没有定义，表示全部记录形成一个分组项。在报表主对象的处理记录事件中每执行明细网格接口的开始新分组方法，将生成指定分组的一个分组项。


IGRGroup.Name 属性

名称 属性

获取或设置分组的名称标识。

语法:对象.名称=文本型

特征

可读写

设计器中可见

说明

分组的名称与其拥有的分组头与分组尾的名称保持相同。当改变三者中任何一个名称都会引起其它两个名称跟随改变。


IGRGroup.PageGroup 属性

页分组 属性

获取或设置本分组是否为页分组的标志。

语法:对象.页分组=逻辑型

默认值:假

特征

可读写

设计器中可见

仅用于打印

说明

如果本属性为真，表示分组按打印页进行归类，即每个打印页生成一个分组项。按页分组在查询显示器中不应用。


IGRGroup.ByFields 属性

依据字段 属性

获取或设置分组依据字段的名称。

语法:对象.依据字段=文本型

特征

可读写

设计器中可见

说明

如果要根据多个字段进行分组，字段名称之间用分号（;）隔开。如果本属性值为空，则为全程分局，即全部明细记录只产生一个分组项。


IGRGroup.GroupEndScript 属性

分组结束脚本 属性

表示报表 结束分组 事件对应的脚本语言代码。

语法:对象.分组结束脚本=文本型
特征

可读写

设计器中可见

结束分组事件


IGRGroup.GroupBeginScript 属性

分组开始脚本 属性

表示报表 分组开始 事件对应的脚本语言代码。

语法:对象.分组开始脚本=文本型
特征

可读写

设计器中可见

请参见

分组结束事件


IGRGroup.Header 属性

获取分组头 方法

获取本分组拥有的分组头对象的接口引用。

调用格式： 〈分组头〉 对象．获取分组头 （）

特征

只读


IGRGroup.Footer 属性

获取分组尾 属性

获取本分组拥有的分组尾对象的接口引用。

调用格式： 〈分组尾〉 对象．获取分组尾 （）

特征

只读


IGRGroupFooter 概述

分组尾 接口

表示明细网格分组的分组尾。分组尾显示在每个分组的最后一行。

说明

一个报表可以定义一个或多个嵌套分组，每个分组对应一个分组头与一个分组尾。分组尾显示在每个分组结束位置，一般在分组尾上定义定义分组的统计信息及其它只需在分组开始时显示一次的信息。

请参见

| 分组尾 接口


IGRGroupSection.KeepTogether 属性

保持同页 属性

获取或设置是否保持本分组节输出显示在相同页的标志。

语法:对象.保持同页=逻辑型

默认值:真

特征

可读写

设计器中可见

仅用于打印


IGRGroupSection.PrintGridBorder 属性

打印网格边框 属性

获取或设置是否打印本分组节对应位置的明细网格边框。

语法:对象.打印网格边框=逻辑型

默认值: 真

特征

可读写

设计器中可见

仅用于打印


IGRGroupFooter.PrintAtBottom 属性

打印在页底 属性

打印输出时，指定是否将本节显示在页面底部。

语法:对象.打印在页底=逻辑型

默认值:假

特征

可读写

设计器中可见

仅用于打印


IGRGroupSection.NewPage 属性

换新页方式 属性

获取或设置换新页的产生方式。

语法:对象.换新页方式=整数型(注:换新页方式枚举)

默认值:不应用

特征

可读写

设计器中可见

仅用于打印

请参见

换新页方式枚举


IGRGroupSection.Group 属性

获取分组 属性

获取拥有本分组节的分组对象的接口引用。

调用格式： 〈分组〉 对象．获取分组 （）

特征

只读


IGRGroupHeader 概述

分组头 接口

表示明细网格分组的分组头。分组头显示在每个分组的第一行。

说明

一个报表可以定义一个或多个嵌套分组，每个分组对应一个分组头与一个分组尾。分组头显示在每个分组开始位置，一般在分组头上定义分组的标识信息，分组初始值及其它只需在分组开始时显示一次的信息。


IGRGroupHeader.IncludeFooter 属性

包括分组尾 属性

为占列式分组头时，获取或设置分组尾是否被包含在占列分组中的标志。

语法:对象.包括分组尾=逻辑型

默认值:真

特征

可读写

设计器中可见


IGRGroupHeader.GroupKeepTogether 属性

保持同页 属性

打印输出时，指定本分组项的分组头与其它行保持同页的方式。

语法:对象.保持同页=逻辑型

默认值:不应用

特征

可读写

设计器中可见

仅用于打印


IGRGroupHeader.VAlign 属性

垂直对齐方式 属性

为占列式分组头时，获取或设置显示位置在垂直方向上的对齐方式。

语法:对象.垂直对齐方式=整数型(注:占列分组头对齐方式枚举)

默认值:上端特征

可读写

设计器中可见

请参见

占列分组头对齐方式 枚举


IGRGroupHeader.NewPageColumn 属性

换新页栏方式 属性

指定强制换新页栏的方式。

语法:对象.换新页栏方式=整数型(注:换新页栏方式枚举)

默认值 不应用

特征

可读写

设计器中可见

仅用于打印

请参见

换新页栏方式 枚举


IGRGroupHeader.RepeatOnPage 属性

每页重复 属性

指定是否在新页中重复显示当前分组项的分组头。

语法:对象.每页重复=逻辑型

默认值:假

特征

可读写

设计器中可见

仅用于打印

说明

当本属性值为真时，如果一个分组项的所有行在分组开始页没有全部显示完，则在输出本分组项的后续页面的开始位置再次显示分组头。


IGRGroupHeader.SameAsColumn 属性

显示同列 属性

为占列式分组头时，获取或设置是否采用占据列的内容格定义进行显示的标志。

语法:对象.显示同列=逻辑型

默认值:假

特征

可读写

设计器中可见

说明

为占列式分组头时，输出定义采用列内容格的定义。当此属性为真时，分组头中不用定义任何显示部件框，此时在报表设计器中禁止向此分组头插入部件框。


IGRGroupHeader.OccupiedColumns 属性

占据列 属性

为占列式分组头时，指定占据列的名称。

语法:对象.占据列=逻辑型

特征

可读写

设计器中可见

说明

如果要占据多个列，列名称之间用分号（;）隔开。

明


IGRGroupHeader.OccupyColumn 属性

占列式 属性

获取或设置是否为占列式分组头的标志。

语法:对象.占列式=逻辑型

默认值 假

特征

可读写

设计器中可见

说明

当 占列式 属性为真时，在输出显示时，分组头不是独立占据一个水平带状区域，而是在 占据列 属性指定列的显示区域中与内容行一起显示。占据列 属性指定的列本身的输出显示被忽略掉。


IGRGroupSection 概述

分组节 接口

分组头与分组尾的基类，表示分组头与分组尾相同的属性与方法。


IGridppReport 概述

报表 接口

表示报表的主对象。其他报表元素对象都是其子孙对象，对其它对象的访问与使用都是以此对象作为进入起点。

说明

是一个COM自动化（COM Automation）对象的接口定义，是Grid++Report组件对象模型的最外层对象。报表主对象是所有其它报元素对象的直接或间接拥有者，直接拥有的报表元素对象有：明细网格，报表节集合、参数集合、打印机对象。另也包括报表有关的公共信息，如设计行为属性、计量单位、整个报表的缺省字体等。


IGridppReport.PrintAsDesignPaper 属性

按设计页打印 属性

指定是否按设计时的页面设置生成打印页面。

语法:对象.按设计页打印=逻辑型

默认值 假

特征

可读写

设计器中可见

仅用于打印

说明

如果此属性为真，则打印页面按设计时的页面设置进行生成，反之则按系统中打印机的当前页面设置进行生成。


IGridppReport.Version 属性

版本号 属性

指示Grid++Report的当前运行版本。

语法:对象.版本号

特征

只读


IGridppReport.BackColor 属性

背景色 属性

报表对象的缺省背景色。

语法:对象.背景色=整数型

默认值 特征

可读写

设计器中可见


IGridppReport.BackImageFile 属性

背景图文件 属性

指定报表在设计器中进入页面视图时显示的背景图文件的路径与名称。

语法:对象.背景图文件=文本型

特征

可读写

设计器中可见

仅用于设计

说明

背景图仅在报表设计时使用，只有当报表进入页面视图中才会显示背景图。如果同时设定了 背景图像与 背景图文件属性，此时只有 背景图像 属性指定的图像被显示。使用背景图可以根据背景图精确定位报表布局，快速实现套打定位。


IGridppReport.ShowMoneySepLineColor 属性

财务金额分隔线颜色 属性

指定元与角位之间的分隔线的颜色。

语法:对象.财务金额分隔线颜色=整数型

默认值:grclPurple

特征

可读写

设计器中可见


IGridppReport.ShowMoneyDigit 属性

财务金额位数 属性

指定在报表中显示金额线或金额位标签时显示的位数。

语法:对象.财务金额位数=整数型

默认值

9

特征

可读写

设计器中可见

说明

位数不包括角与分位。


IGridppReport.ShowMoneyWidth 属性

财务金额位总宽度 属性

指定在报表中显示金额线或金额位标签时显示全部位的宽度。

语法:对象.财务金额位总宽度=整数型
默认值

0

特征

可读写

设计器中可见

说明

以报表的计量单位表示属性值。当属性值为零时，报表在运行时将自动确定金额显示宽度。


IGridppReport.ShowMoneyLineColor 属性

财务金额线颜色 属性

指定金额位分隔线的颜色。

语法:对象.财务金额线颜色=逻辑型

默认值

grclTeal

特征

可读写

设计器中可见


IGridppReport.Unit 属性

单位 属性

用来表示报表元素位置与大小的计量单位。

语法:对象.单位=整数型(注:单位枚举)

默认值 厘米

特征

可读写

设计器中可见

| 单位枚举


IGridppReport.AlignToGrid 属性

对齐到栅格 属性

当在设计器中设计报表模板时，是否将部件框的边框对齐到设计栅格点。

语法:对象.对齐到栅格=逻辑型

默认值 真

特征

可读写

仅用于设计

说明

如果本属性为真时，通过鼠标拖放改变部件框的位置与大小，设计器将强制部件边框对齐到设计栅格点，但通过其他方式改变部件框的位置与大小时，不受此属性约束。


IGridppReport.SharePrintSetupOptions 属性

共享打印选项 属性

指定共享全局打印设置参数的选项。

语法:对象.共享打印选项=整数型

默认值

0

特征

可读写

设计器中可见

说明

用二进制Bit位表示相应的共享全局打印设置参数是否被当前报表使用。如果使用某个或某类全局打印设置参数，这对当前报表应用或设置打印设置参数都是对共享全局打印设置参数进行操作。


IGridppReport.ContinuePrint 属性

连续打印 属性

指定是否采用连续打印，即打即停的方式打印输出报表。

语法:对象.连续打印=逻辑型

默认值 假

特征

可读写

设计器中可见

仅用于打印


IGridppReport.GridColsPerUnit 属性

每单位栅格点列数 属性

在设计器中，水平方向上每个计量单位显示的设计栅格点个数。

语法:对象.每单位栅格点列数=整数型

默认值

5

特征

可读写

设计器中可见

仅用于设计

说明

有效值范围：1-50


IGridppReport.GridRowsPerUnit 属性

每单位栅格点行数 属性

在设计器中，垂直方向上每个计量单位显示的设计栅格点个数。

语法:对象.每单位栅格点行数=整数型

默认值

5

特征

可读写

设计器中可见

仅用于设计

说明

有效值范围：1-50


IGridppReport.DesignPaperLength 属性

设计页长度 属性

指定设计报表时所定义的页面长度，仅自定义纸张设置此属性有效。

语法:对象.设计页长度=双精度小数型

特征

可读写

设计器中可见


IGridppReport.DesignPaperWidth 属性

设计页宽度 属性

指定设计报表时所定义的页面宽度，仅自定义纸张设置此属性有效。

语法:对象.设计页宽度=双精度小数型

特征

可读写

设计器中可见


IGridppReport.DesignTopMargin 属性

设计页上边距 属性

指定设计报表时所定义的页面上边距。

语法:对象.设计页上边距=双精度小数型

默认值

2.5cm

特征

可读写

设计器中可见


IGridppReport.DesignBottomMargin 属性

设计页下边距 属性

指定设计报表时所定义的页面下边距。

语法:对象.设计页下边距=双精度小数型

默认值

2.5cm

特征

可读写

设计器中可见


IGridppReport.DesignRightMargin 属性

设计页右边距 属性

指定设计报表时所定义的页面右边距。

语法:对象.设计页右边距=双精度小数型

默认值

2.5cm

特征

可读写

设计器中可见


IGridppReport.DesignLeftMargin 属性

设计页左边距 属性

指定设计报表时所定义的页面左边距。

语法:对象.设计页左边距=双精度小数型

默认值

2.5cm

特征

可读写

设计器中可见


IGridppReport.DesignPaperOrientation 属性

设计纸张方向 属性

指定设计报表时所定义的纸张打印方向。

语法:对象.设计纸张方向=整数型(注:纸张方向枚举)

默认值

纵向

特征

可读写

设计器中可见

请参见

纸张方向枚举


IGridppReport.DesignPaperName 属性

设计纸张名称 属性

指定设计报表时所定义的纸张名称。

语法:对象.设计纸张名称=文本型

默认值

A4

特征

可读写

设计器中可见


IGridppReport.DesignPaperSize 属性

设计纸张型号 属性

指定设计报表时所定义的纸张大小代号。

语法:对象.设计纸张型号=整数型

默认值

A4

特征

可读写

设计器中可见

说明

参考Windows SDK中DEVMODE的成员dmPaperSize的说明。其中256代表自定义纸张，当定义为自定义纸张时，可以设置纸张宽度与长度属性指定打印纸张的大小。


IGridppReport.WatermarkAlignment 属性

水印图对齐方式 属性

指定水印图在页面中显示时的位置对齐方式。

语法:对象.水印图对齐方式=整数型(注:图像对齐方式枚举)

默认值 居中

特征

可读写

设计器中可见

仅用于打印

请参见

图像对齐方式枚举


IGridppReport.WatermarkSizeMode 属性

水印图缩放方式 属性

指定水印图在页面中显示时使用的缩放方式。

语法:对象.水印图缩放方式=整数型(注:图像缩放方式枚举)

默认值 剪裁

特征

可读写

设计器中可见

仅用于打印

请参见

图像缩放方式枚举


IGridppReport.Title 属性

文档标题 属性

指定报表文档的标题文字。

语法:对象.文档标题=文本型

特征

可读写

设计器中可见

说明

当打印输出报表时，打印文档的标题是此属性的值。


IGridppReport.DisplayMode 属性

显示模式 属性

指示报表的输出显示状态。

语法:对象.显示模式

特征

只读

仅运行时可用

说明

指示报表的输出显示状态。在SectionFormat事件处理函数中，获取本属性的值以知道当前的显示输出过程，可以对查询显示器中报表的子画显示输出和打印页面生成显示输出采取不同的处理。


IGridppReport.PageDivideLine 属性

显示页切分线 属性

打印输出时，是否显示纸张在垂直方向均分的分隔线。

语法:对象.显示页切分线=逻辑型

默认值 假

特征

可读写

设计器中可见

仅用于打印


IGridppReport.ShowGrid 属性

显示栅格 属性

获取或设置是否在设计器中显示设计栅格点的标志。

语法:对象.显示栅格=逻辑型

默认值 真

特征

可读写

设计器中可见

仅用于设计


IGridppReport.PageDivideSpacing 属性

页切分间隔 属性

打印输出时，纸张在垂直方向均分时的分隔间距。

语法:对象.页切分间隔=双精度小数型

默认值

0

特征

可读写

设计器中可见

仅用于打印

说明

以报表使用的计量单位表示属性值。


IGridppReport.PageDivideCount 属性

页切分数 属性

打印输出时，纸张在垂直方向上的均分个数。

语法:对象.页切分数=整数型

默认值

1

特征

可读写

设计器中可见

仅用于打印


IGridppReport.ControlByName 方法

按名称取部件框 方法

从报表主对象包括的所有部件框中根据部件框名称找到对应部件框对象的接口引用。

调用格式： 〈部件框〉 对象．按名称取部件框 （文本型 名称）

如果找到名称匹配的部件框，则返回该部件框对象的接口引用，否则返回NULL。

参数:名称,指定部件框的名称标识。

说明

注意：匹配名称时不区分字母的大小写。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGRControl 接口


IGridppReport.ColumnByName 方法

按名称取列 方法

根据名称找到对应列对象的接口引用。

调用格式： 〈列〉 对象．按名称取列 （文本型 名称）

如果找到名称匹配的列，则返回该列对象的接口引用，否则返回NULL。

参数:名称

指定要查找列的名称。

说明

注意：匹配名称时不区分字母的大小写。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGRColumn 接口


IGridppReport.ParameterByName 方法

按名称取参数 方法

根据名称找到对应参数对象的接口引用。

〈参数〉 对象．按名称取参数 （文本型 名称）

如果找到名称匹配的参数，则返回该参数对象的接口引用，否则返回NULL。

参数:名称,指定要查找参数的名称。

说明

注意：匹配名称时不区分字母的大小写。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGRParameter 接口


IGridppReport.FieldByName 方法

按名称取字段 方法

根据字段名称得到匹配字段对象的接口引用。

调用格式： 〈字段〉 对象．按名称取字段 （文本型 Name）

如果找到名称匹配的字段，则返回该字段对象的接口引用，否则返回NULL。

参数:名称,指定字段的名称。

说明

注意：匹配名称时不区分字母的大小写。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGRField 接口


IGridppReport.SaveToVariant 方法

保存到变量 方法

保存报表模板数据保存至内存缓冲区。

调用格式： 〈变体型〉 对象．保存到变量 （）

返回值:变体型

保存数据的内存缓冲区。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.LoadFromVariant 方法 | IGridppReport.SaveToFile 方法 | IGridppReport.SaveToMemory 方法 | IGridppReport.SaveToStr 方法


IGridppReport.SaveToFile 方法

保存到文件 方法

将报表模板数据保存到报表模板文件中去。

调用格式： 〈逻辑型〉 对象．保存到文件 （文本型 文件名）

返回值:逻辑型,指示保存报表模板数据是否成功。

参数:文件名,指定模板文件的完全路径名称。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.LoadFromFile 方法 | IGridppReport.SaveToMemory 方法 | IGridppReport.SaveToStr 方法 | IGridppReport.SaveToVariant 方法


IGridppReport.SaveToStr 方法

保存到字符串 方法

保存报表模板数据保存至字符串。

调用格式： 〈文本型〉 对象．保存到字符串 （）

返回值:文本型,保存的报表模板数据。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.LoadFromStr 方法 | IGridppReport.SaveToFile 方法 | IGridppReport.SaveToMemory 方法 | IGridppReport.SaveToVariant 方法


IGridppReport.InsertReportHeader 方法

插入报表头 方法

增加一个报表头。

调用格式： 〈报表头〉 对象．插入报表头 （）

返回值:报表头,新增报表头对象的接口引用。

>


IGridppReport.InsertReportFooter 方法

插入报表尾 方法

增加一个报表尾。

调用格式： 〈报表尾〉 对象．插入报表尾 （）

返回值:报表尾, 新增报表尾对象的接口引用。


IGridppReport.InsertDetailGrid 方法

插入明细网格 方法

向报表主对象插入明细网格，使报表主对象具有明细网格。

调用格式： 〈明细网格〉 对象．插入明细网格 （）

返回值:明细网格, 明细网格接口引用。

说明

只有当报表主对象不存在明细网格对象时，才能成功插入明细网格，报表主对象只能拥有一个明细网格。此方法一般在以编程方式定义报表模板时使用。


IGridppReport.InsertPageFooter 方法

插入页脚 方法

增加页脚定义。

调用格式： 〈页脚〉 对象．插入页脚 （）

返回值:页脚, 页脚接口引用。

说明

增加页脚定义，使报表主对象具有一个页脚。如果报表主对象已经定义了页脚，此方法直接返回页脚的接口引用。


IGridppReport.InsertPageHeader 方法

插入页眉 方法

增加页眉定义。

调用格式： 〈页眉〉 对象．插入页眉 （）

返回值:页眉,页眉接口引用。

说明

增加页眉定义，使报表主对象具有一个页眉。如果报表主对象已经定义了页眉，此方法直接返回页眉的接口引用。


IGridppReport.LoadFromVariant 方法

从变量加载报表 方法

调用格式： 〈逻辑型〉 对象．从变量加载报表 （通用型 变量名）

返回值:逻辑型, 指示载入报表模板数据是否成功。

参数:变量名,数据包


IGridppReport.LoadFromFile 方法

从文件加载报表 方法

从报表模板文件中载入报表模板定义。

调用格式： 〈逻辑型〉 对象．从文件加载报表 （文本型 文件名）

返回值:逻辑型, 指示载入报表模板数据是否成功。

参数:文件名,指定模板文件的完全路径名称。


IGridppReport.LoadBackImageFromFile 方法

从文件加载背景图 方法

从指定的图像文件中载入报表设计页面背景图。

调用格式： 〈无返回值〉 对象．从文件加载背景图 （文本型 文件名）

参数:文件名,指定图像文件的路径与名称。


IGridppReport.LoadWatermarkFromFile 方法

从文件加载水印图 方法

从指定的图像文件中载入水印背景图。

调用格式： 〈无返回值〉 对象．从文件加载水印图 （文本型 文件名）

参数:文件名,指定图像文件的路径与文件名。


IGridppReport.LoadFromStr 方法

从字符串加载报表 方法

从字符串中载入报表模板数据。

调用格式： 〈逻辑型〉 对象．从字符串加载报表 （文本型 字符串）

返回值:逻辑型,指示载入报表模板数据是否成功。

参数:字符串,指定报表模板数据。


IGridppReport.Print 方法

打印 方法

执行打印报表。

调用格式： 〈无返回值〉 对象．打印 （逻辑型 显示打印对话框）

参数:指示在打印前是否显示打印对话框。

说明

调用此方法后，首先生成报表数据，过程中会触发一系列事件；然后生成打印页面数据，过程中也会触发一系列事件；最后将生成的打印数据送至打印机进行打印。


IGridppReport.PrintEx 方法

打印扩展 方法

打印报表,按指定方式生成生成打印数据。

调用格式： 〈无返回值〉 对象．打印扩展 （打印生成方式枚举 打印生成方式枚举值，逻辑型 显示打印对话框）

参数1:打印生成方式枚举值,指定打印数据的生成类型。

参数2:显示打印对话框,指示在打印前是否显示打印对话框。

说明

类同 打印 方法。当生成方式为全部时，与 打印 方法完全一样；当成方式为 套打 时，生成打印页面时将忽略掉属于表单类型的数据；当成方式为 表单 时,不会触发 请求数据 事件，生成打印页面时仅生成属于表单类型的数据。

请参见

IGridppReport 接口 | IGridppReport 成员 | GRPrintGenerateStyle 枚举 | IGridppReport.Print 方法


IGridppReport.PrintPreview 方法

打印预览 方法

在Grid++Report提供的缺省打印预览窗口中预览报表。

调用格式： 〈无返回值〉 对象．打印预览 （逻辑型 显示模）

参数:指定是否以有模的方式显示窗口。

说明

调用此方法后，首先生成报表数据，过程中会触发一系列事件；然后生成打印页面，过程中也会触发一系列事件；最后打开缺省预览窗口并将生成的打页面显示在窗口中。


IGridppReport.PrintPreviewEx 方法

打印预览扩展 方法

在Grid++Report提供的缺省打印预览窗口中预览报表，可以指定打印数据的生成方式。

调用格式： 〈无返回值〉 对象．打印预览扩展 （打印生成方式枚举 打印生成方式枚举值，逻辑型 显示模，逻辑型 最大化预览窗口）

参数1:指定打印数据的生成方式。

参数2:指定是否以有模的方式显示打印预览窗口。

参数3:指定是否最大化显示打印预览窗口。

说明

类同　打印预览　方法。当生成方式为 全部 时，与 打印预览 方法完全一样；当成方式为 套打 时，生成打印页面时将忽略掉属于表单类型的数据；当成方式为 表单 时,不会触发 请求记录 事件，生成打印页面时仅生成属于表单类型的数据。


IGridppReport.Export 方法

导出方法

执行数据导出。

调用格式： 〈逻辑型〉 对象．导出 （逻辑型 调用关联程序打开导出文件）

返回值:逻辑型,指示数据导出是否成功执行。

参数:指示是否在导出数据之后用关联程序打开导出文件。

说明

在调用导出方法之前一定要调用准备导出方法，在其后一定要调用完成导出方法。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.PrepareExport 方法 | IGridppReport.UnprepareExport 方法 | IGridppReport.ExportDirect 方法


挂接事件

挂接事件方法

调用格式： 〈逻辑型〉 对象．挂接事件 （报表事件 欲挂接的事件组件） - 锐浪报表引擎->报表
如果对象具有事件，调用本方法即可将对象与其事件窗口组件挂接起来，从而达到通过事件窗口组件获得此对象事件通知的目的。挂接成功返回真，失败返回假。本命令为初级对象成员命令。
参数<1>的名称为“欲挂接的事件组件”，类型为“报表事件（_IGridppReportEvents）”。本参数指定欲挂接到的事件窗口组件，该事件组件必须对应于该对象，否则将挂接失败。


IGridppReport.About 方法

关于 方法

显示Grid++Report关于对话框。

调用格式： 〈无返回值〉 对象．关于 （）


IGridppReport.ReportHeader 属性

获取报表头 属性

根据名称或序号取得某个报表头对象的接口引用。

调用格式： 〈报表头〉 对象．获取报表头 （通用型 序号或名称）

特征

只读

请参见

报表头接口


IGridppReport.ReportFooter 属性

获取报表尾 属性

根据名称或序号取得某个报表尾对象的接口引用。

调用格式： 〈报表尾〉 对象．获取报表尾 （通用型 序号或名称）

特征

只读

请参见

报表尾接口


IGridppReport.BackImage 属性

获取背景图像 方法
指定报表在设计器中进入页面视图时显示的背景图。

调用格式： 〈对象〉 对象．获取背景图像 （）

特征

可读写

设计器中可见

仅用于设计

说明

背景图仅在报表设计时使用，只有当报表进入页面视图中才会显示背景图。如果同时设定了 背景图像 与 背景图像文件 属性，此时只有 背景图像 属性指定的图像被显示。使用背景图可以根据背景图精确定位报表布局，快速实现套打定位。


IGridppReport.Parameters 属性

获取参数集合 属性

获取参数集合对象的接口引用。

调用格式： 〈参数集合〉 对象．获取参数集合 （）

特征

只读

设计器中可见


IGridppReport.Printer 属性

获取打印机 属性

获取打印机对象的接口引用。

调用格式： 〈打印机〉 对象．获取打印机 （）

特征

只读

请参见

打印机接口


IGridppReport.SharePrintSetupObject 属性

获取共享打印设置对象 方法

获取当前应用程序的共享全局打印设置对象的接口引用。

调用格式： 〈共享打印设置对象〉 对象．获取共享打印设置对象 （）

特征

只读

说明

通过此属性取得当前应用程序的共享全局打印设置对象的接口引用，从而可以对共享全局打印设置参数进行操作。

请参见

共享打印设置对象接口 |
 报表.共享打印选项 属性 |
报表禁止全部共享打印选项方法 |
 报表.开启全部共享打印选项方法 |
 报表.对象．获取共享打印选项值方法 |
报表.设置共享打印选项值方法 |


IGridppReport.DetailGrid 属性

获取明细网格 属性

获取明细网格对象的接口引用。

调用格式： 〈明细网格〉 对象．获取明细网格 （）

特征

只读


IGridppReport.Watermark 属性

设置水印图像 属性

指定报表在生成打印页面时在每页中显示的水印背景图像。

调用格式： 〈无返回值〉 对象．设置水印图像 （对象 属性值）

特征

可读写

设计器中可见

仅用于打印


IGridppReport.ImageList 属性

获取图像集合 属性

获取报表对象中图像集合对象的接口引用。

调用格式： 〈图像集合〉 对象．获取图像集合 （）

特征

只读

设计器中可见


IGridppReport.PageFooter 属性

获取页脚 属性

获取页脚对象的接口引用。

调用格式： 〈页脚〉 对象．获取页脚 （）

特征

只读


IGridppReport.PageHeader 属性

获取页眉 属性

获取页眉对象的接口引用。

调用格式： 〈页眉〉 对象．获取页眉 （）

特征

只读


IGridppReport.Font 属性

获取字体 属性

获取报表对象的缺省字体对象的引用。

调用格式： 〈字体〉 对象．获取字体 （）

特征

只读

设计器中可见


IGridppReport.EndLoopPrint 方法

结束循环打印 方法

结束循环打印。

调用格式： 〈无返回值〉 对象．结束循环打印 （）

请参见

IGridppReport 接口 | IGridppReport 成员


IGridppReport.SharePrintSetupDisableAllOptions 方法

禁止全部共享打印选项 方法

指定禁用全部的共享打印设置参数。

调用格式： 〈无返回值〉 对象．禁止全部共享打印选项 （）

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.SharePrintSetupEnableAllOptions 方法 | IGridppReport.SharePrintSetupGetOptionEnabled 方法 | IGridppReport.SharePrintSetupSetOptionEnabled 方法 | IGridppReport.SharePrintSetupObject 属性 | IGridppReport.SharePrintSetupOptions 属性


IGridppReport.SharePrintSetupEnableAllOptions 方法

开启全部共享打印选项 方法

指定应用全部的共享打印设置参数。

调用格式： 〈无返回值〉 对象．开启全部共享打印选项 （）

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.SharePrintSetupDisableAllOptions 方法 | IGridppReport.SharePrintSetupGetOptionEnabled 方法 | IGridppReport.SharePrintSetupSetOptionEnabled 方法 | IGridppReport.SharePrintSetupObject 属性 | IGridppReport.SharePrintSetupOptions 属性


IGridppReport.BeginLoopPrint 方法

开始循环打印 方法

准备开始循环打印。

调用格式： 〈逻辑型〉 对象．开始循环打印 （打印生成方式枚举 打印生成方式枚举值）

参数:指定打印数据的生成方式。

说明

开始循环打印,循环打印,结束循环打印三个方法必须在一起调用，在要进行循环打印开始时调用开始循环打印，在循环打印完成时调用结束循环打印，在中间根据需要多次调用结束循环打印。

请参见

IGridppReport 接口 | IGridppReport 成员 | GRPrintGenerateStyle 枚举 | IGridppReport.LoopPrint 方法 | IGridppReport.EndLoopPrint 方法 | IGridppReport.Print 方法 | IGridppReport.PrintEx 方法


IGridppReport.ForceNewPage 方法

强制换新页 方法

在报表生成过程中，结束当前页，开始一个新页面。

调用格式： 〈无返回值〉 对象．强制换新页 （）

说明

在报表生成过程中，可以调用此方法强制进行分页。只能在页处理记录事件 与 格式化报表节 事件中调用，在 格式化报表节 中调用时必须保证是在打印生成状态中。

请参见

IGridppReport 接口 | IGridppReport 成员


IGridppReport.DeletePageHeader 方法

删除报表头 方法

删除页眉的定义，报表主对象将不具有页眉。

调用格式： 〈无返回值〉 对象．删除报表头 （通用型 序号或名称）


IGridppReport.DeletePageFooter 方法

删除报表尾 方法

删除页脚的定义，报表主对象将不具有页脚。

调用格式： 〈无返回值〉 对象．删除报表尾 （通用型 序号或名称）


IGridppReport.DeleteDetailGrid 方法

删除明细网格 方法

删除整个明细网格的定义，报表主对象将不具有明细网格。

调用格式： 〈无返回值〉 对象．删除明细网格 （）

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.DetailGrid 属性 | IGridppReport.InsertDetailGrid 方法


IGridppReport.GenerateDocumentFile 方法

生成报表文档 方法

生成报表的 Grid++Report 文档文件到指定的文件。

调用格式： 〈无返回值〉 对象．生成报表文档 （文本型 文件名）

保存数据的文件的路径与名称。


IGridppReport.UnprepareExport 方法

完成导出 方法

数据导出完成之后，进行一些内部释放任务。

调用格式： 〈无返回值〉 对象．完成导出 （）

说明

在调用导出方法之前一定要调用准备导出方法，在其后一定要调用完成导出方法。


IGridppReport.SystemVarValue 方法

系统变量值 方法

在报表运行时，取得本报表某个指定系统参数的当前值。

用格式： 〈整数型〉 对象．系统变量值 （系统变量枚举 系统变量枚举值）

返回值:整数型

指定系统参数的当前值。

参数:系统变量枚举值,指定某个系统参数。


IGridppReport.PixelsToUnit 方法

像素转换为单位 方法

将屏幕像素值转换为报表当前使用的计量单位值。

调用格式： 〈双精度小数型〉 对象．像素转换为单位 （整数型 像素值）

返回值:双精度小数型

转换得到的计量单位值。

参数:像素值,指定要转换的屏幕像素值。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.Unit 属性


IGridppReport.LoopPrint 方法

循环打印 方法

在循环打印过程中，执行一次打印生成过程。

用格式： 〈无返回值〉 对象．循环打印 （）

说明

每调用一次循环打印方法，就会首先生成报表数据，然后生成打印页面数据，最后将打印页面数据送至打印机进行打印输出。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.BeginLoopPrint 方法 | IGridppReport.EndLoopPrint 方法 | IGridppReport.Print 方法 | IGridppReport.PrintEx 方法


IGridppReport.AddParameter 方法

增加参数 方法

增加一个参数定义。

调用格式： 〈参数〉 对象．增加参数 （文本型 参数名称，参数数据类型枚举 参数类型）

返回值:参数,返回新增参数对象的接口引用。

参数

参数名:

指定参数的名称标识。

参数类型:

指定参数的类型。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGRParameter 接口 | GRParameterDataType 枚举


IGridppReport.ExportDirect 方法

直接导出 方法

直接进行数据导出。

调用格式： 〈逻辑型〉 对象．直接导出 （导出类型枚举 导出类型，文本型 文件名，逻辑型 显示导出选项对话框，逻辑型 导出完成后打开文件）

参数

导出类型:

指定导出的文件类型。

文件名:

指定导出的完整文件路径与文件名称。

显示导出选项对话框:

指定是否在导出之前显示选项设置对话框。

导出完成后打开文件:

指定在导出完成后调用关联程序打开文件.


IGridppReport.Register 方法

注册 方法

用Grid++Report的产品序列号进行注册。

调用格式： 〈逻辑型〉 对象．注册 （文本型 注册码）

返回值:逻辑型
指示注册是否成功。

参数:

注册码: 产品序列号

说明

当你用Grid++Report开发一个应用程序时，如果没有进行对其注册，Grid++Report将运行在试用版状态下。你必须在应用程序启动之后，对Grid++Report进行注册。具体办法是创建一个零时的报表主对象，并调用其注册方法。一个应用程序只用进行一次注册。在例子程序ManualFillRecord中有怎样实现注册的示例。
当你购买Grid++Report之后，你将收到Grid++Report的产品序列号。另外你也可以通过注册获得Grid++Report免费版的产品序列号。有关本产品版本与注册方面的信息请查看相关文档。


IGridppReport.PrepareExport 方法

准备导出 方法

准备进行数据导出，指定要导出的文件类型。

调用格式： 〈导出基选项〉 对象．准备导出 （导出类型枚举 导出类型）

返回值:导出基选项,返回导出选项对象的接口引用。

参数

导出类型:指定导出的文件类型。

说明

在调用导出方法之前一定要调用本方法，在其后一定要调用完成导出方法。本方法返回的选项对象的接口引用可以用来设定选项值。


IGridppReport.Initialize 事件

初始化事件

在报表生成开始时触发。

语法: 无返回值 _报表事件_初始化事件 ()

说明

在报表生成开始时触发。在此事件中，报表开发者可以对报表模板定义进行修改调整。例如用户在报表生成之从所有可选的列中选择一部分列显示，就可以在此事件中以编程方式动态定义列。


IGridppReport.ProcessRecord 事件

处理记录 事件

当报表生成时，会按顺序遍历每一条记录，每当遍历一条记录时触发本事件。

语法:无返回值 _报表事件_处理记录事件 ()
说明

当报表生成时，会按顺序遍历每一条记录，每当遍历一条记录时触发本事件。在此事件中，可以取记录的各个字段的值。报表开发者可以在此事件中对数据进行一些自定义的分析统计。


IGridppReport.SectionFormat 事件

格式化报表节 事件

当报表节在输出之前触发。包括查询显示预打印生成显示。

语法:_报表事件_格式化报表节 (报表节)

参数:报表节,指示触发本事件的节的接口引用。

说明

当报表节在输出显示之前触发。一般在格式化报表节事件中改变节及节中的部件框或单元格的显示外观属性，已达到某些突出显示的效果。

当节在查询显示器中显示时，每当查询显示器窗口需要刷新显示时，都会触发节的格式化报表节，所以节的格式化报表节事件会频繁触发。当报表节打印生成阿时，当每个节在输出之前会触发格式化报表节事件。一个节每显示一次，就会触发一次格式化报表节事件，一个节如果多次显示，就会多次触发格式化报表节t事件。


IGridppReport.ProcessEnd 事件

结束处理 事件

语法: 无返回值 _报表事件_结束处理事件 ()

当报表对填入的数据进行分析处理完成之后触发本事件。


IGridppReport.GroupEnd 事件

结束分组 事件

在生成报表数据时，结束一个分组触发。

语法: 无返回值 _报表事件_结束分组事件 (分组)

参数:分组,指示触发事件的分组对象的接口引用。


IGridppReport.PageEnd 事件

结束页 事件

在完成一个打印页面生成时触发本事件。

语法:无返回值 _报表事件_结束页事件 ()


IGridppReport.ProcessBegin 事件

开始处理 事件

当报表准备对填入的数据进行分析处理之前触发本事件。

语法:无返回值 _报表事件_开始处理事件 ()


IGridppReport.GroupBegin 事件

开始分组 事件

在生成报表数据时，开始一个分组触发。

语法:无返回值 _报表事件_开始分组事件 (分组)

参数:分组,指示触发事件的分组对象的接口引用。


IGridppReport.PageStart 事件

开始页事件

在开始生成一个打印页面时触发本事件。

语法:无返回值 _报表事件_开始页事件 ()


IGridppReport.BeforeSort 事件

排序之前 事件

当要对记录集中的记录进行重新排序之前触发本事件。

语法:无返回值 _报表事件_排序之前 (排序字段)

参数:排序字段,指定进行排序的字段，当按多个字段进行排序时，字段名称之间用‘;’隔开。

说明

如果设置了记录集的排序字段(SortFields)属性，在每次生成报表时，在开始处理事件之前会触发排序之前事件。另当查询显示器设定为可排序时，点击明细网格的列标题会按点击的列对记录进行重新排序，此时也会触发排序之前事件。


IGridppReport.FetchRecord 事件

请求记录数据 事件

在报表生成时，报表主对象请求数据时触发。

语法:无返回值 _报表事件_请求记录数据 (参考 是否完成)

参数:是否完成,指向一个存储是否完成取数过程的变量的指针。

说明

在报表生成时，报表主对象请求数据时触发。任何具有明细网格的报表在报表生成时，都会触发此事件，报表开发者必须在此事件中向记录集填入数据，此事件也是报表开发者必须要响应的事件。


IGridppReport.FieldGetDisplayText 事件

请求字段显示文字 事件

当字段对象准备生成其显示文本时触发。

语法:无返回值 _报表事件_请求字段显示文字 (字段)

参数:字段

指定触发此事件的字段对象的接口引用。

说明

当字段对象准备生成其显示文本时触发。如果一个字段的显示文本不是字段对象内部生成的文本，就需要在此事件中为字段设定显示文本，通过给字段的 显示文字 属性赋值改变字段的显示文本。


IGridppReport.BeforePostRecord 事件

提交记录之前 事件

在向报表中填入记录数据的过程中，每当提交一条记录之前触发本事件。

语法:无返回值 _报表事件_提交记录之前

说明

在此事件中，我们可以对当前记录的各个字段值进行重新设置，记录提交之后就不能修改其字段值。譬如可以在此事件中设置需要由其它字段通过计算得来的字段值。


IGridppReport.PageProcessRecord 事件

页处理记录 事件

当报表在生成打印数据时，会再次按顺序遍历每一条记录，每当遍历一条记录时触发本事件。

语法:无返回值 _报表事件_页处理记录事件()


IGRImageList 概述

图像集合 接口

管理在整个报表对象中共享使用的图像数据集合。

说明

图像框通过指定引用的图像序号来显示某个共享的图像，图像序号从1开始。


IGRImageList.Count 属性

数目 属性

获取当前图像集合中图像个数。

语法:图像集合.数目

特征

只读


IGRImageList.AddFromFile 方法

从文件增加 方法

根据图像文件路径名将该图像添加到图像集合中。

调用格式： 〈短整数型〉 对象．从文件增加 （文本型 文件名）

返回值:指定新增图像的序号。

参数:文件名,指定添加图像的文件路径名。

请参见

IGRImageList 接口 | IGRImageList 成员 | IGRImageList.Add 方法 | IGRImageList.AddFromMemory 方法


IGRImageList.Item 属性

获取项目 方法

通过图像序号获取共享图像的引用。

调用格式： 〈对象〉 对象．获取项目 （短整数型 序号）

特征

只读

说明

图像序号从1开始。


全部删除

全部删除 方法

删除图像集合中的全部图像

调用格式： 〈无返回值〉 对象．全部删除 （） - 锐浪报表引擎->图像集合


删除

删除 方法

删除图像集合中指定序号的图像.

调用格式： 〈无返回值〉 对象．删除 （短整数型 序号）


IGRImageList.Add 方法

增加 方法

根据图像对象引用增加该图像到图像集合中。

调用格式： 〈短整数型〉 对象．增加 （对象 图片对象）

返回值:指定新增图像的序号。

参数:准备添加的图像对象引用。

请参见

IGRImageList 接口 | IGRImageList 成员 | IGRImageList.AddFromFile 方法 | IGRImageList.AddFromMemory 方法


IGRLine 概述

线段 接口

表示直线段。

说明

用来显示两点之间的直线段的部件框。


IGRLine.PenWidth 属性

画笔宽度 属性

指定画线条的画笔的宽度。

语法:对象.画笔宽度=整数型

默认值

1

特征

可读写

设计器中可见

说明

以屏幕像素表示属性值。


IGRLine.PenColor 属性

画笔颜色 属性

画线段的颜色

语法:对象.画笔颜色=整数型

默认值:黑色

特征

可读写

设计器中可见


IGRLine.PenStyle 属性

画笔样式 属性

指定画线条的画笔类型

语法:对象.画笔样式=整数型(画笔样式枚举值)

默认值 画实线

特征

可读写

设计器中可见

请参见

画笔样式枚举


IGRLine.X1 属性

起点X 属性

线段的起点X坐标位置。

语法:对象.起点X=双精度小精型

特征

可读写

设计器中可见

说明

以报表使用的计量单位表示的线段的起点X坐标位置，相对于父容器。


IGRLine.Y1 属性

起点Y 属性

线段的起点Y坐标位置。

语法:对象.起点Y=双精度小数型

特征

可读写

设计器中可见

说明

以报表使用的计量单位表示的线段的起点Y坐标位置，相对于父容器。


IGRLine.X2 属性

终点X 属性

线段的终点X坐标位置。

语法:对象.终点X=双精度小数型

特征

可读写

设计器中可见

说明

以报表使用的计量单位表示的线段的终点X坐标位置，相对于父容器。


IGRLine.Y2 属性

终点Y 属性

线段的终点Y坐标位置。

语法:对象.终点Y=双精度小数型

特征

可读写

设计器中可见

说明

以报表使用的计量单位表示的线段的终点Y坐标位置，相对于父容器。


IGRMemoBox 概述

综合文字框 接口

最常用的文字部件框。可以在文字中包含数据域，数据域在运行时被替换为对应的对象或函数的值。另域可以进行算术四则运算。

说明

可以用来显示静态文本的部件框，一般在设计时设定要显示的文本，在输出显示时依原样输出。除了显示静态框文字之外，MemoBox 更可以显示多种多样的同态内容，通过在文字中定义数据域，数据域在运行时被替换为对应的对象或函数的值。MemoBox 的数据域可以关联字段、参数、文字类型部件框、统计函数与系统变量。多个值为数字类型的数据域可以进行数字四则运算。数据域可以设定其显示的格式化字符串，以便得到想要的显示文字。


IGRMemoBox.Text 属性

文字 属性

显示文本，文本中可以包含多种树据域。

语法:对象.文字=文本型

特征

可读写

设计器中可见

说明

数据域定义在此文本中，数据域通过“[#”与“#]”扩起来，中间包含的文字可以成功解析为数据域或数据域表达式，则在运行时对应文本将被数据域的值替换，反之文字将以原样输出。


IGRMemoBox.TextOrientation 属性

文字方向 属性

获取或设置文字的显示方向。

语法:对象.文字方向=整数型(文字方向枚举值)

默认值: t

特征

可读写

设计器中可见

请参见

文字方向枚举


IGRMemoBox.TextAngle 属性

文字角度 属性

获取或设置文字的显示角度，以1/10度为计量单位。

语法:对象.文字角度=整数型

默认值

0

特征

可读写

设计器中可见

说明

综合文字框的文字角度大于0时，只有当文字方向为默认值时才会生效，此时文字只能单行显示，文字对齐方式设定也不起作用，否则将按特定的文字方向显示文字。


IGRMemoBox.LineSpacing 属性

行间距 属性

获取或设置输出文字的行间距。

语法:对象.行间距=整数型

默认值

0

特征

可读写

设计器中可见

说明

当文字按任意角度显示时，字间距与行间距设置不会起作用。


IGRMemoBox.CharacterSpacing 属性

字间距 属性

获取或设置输出文字的字间距。

语法:对象.字间距=整数型

默认值

0

特征

可读写

设计器中可见

说明

当文字按任意角度显示时，字间距与行间距设置不会起作用。


IGRPageFooter 概述

页脚 接口

表示报表的页脚。页脚只在打印生成时显示，紧靠每页下边距的下面显示。

说明

页脚在打印生成时，输出在每页的上边距之上；在屏幕查询显示时，页脚被忽略掉，即屏幕查询显示不使用页脚。一个报表只能定义一个页脚。在页脚中一般定义页号，总页数，文档名称，打印时间及其它需要显示在输出纸张页脚区域的信息。


IGRSection.FormatScript 属性

格式化脚本 属性

表示报表 格式化报表节 事件对应的脚本语言代码。

语法:对象.格式化脚本=文本型

特征

可读写

设计器中可见


IGRPageHeader 概述

页眉 接口

表示报表的页眉。页眉只在打印生成时显示，紧靠每页上边距的上面显示。

说明

页眉在打印生成时，输出在每页的上边距之上；在屏幕查询显示时，页眉被忽略掉，即屏幕查询显示不使用页眉。一个报表只能定义一个页眉。在页眉中一般定义页号，总页数，文档名称，打印时间及其它需要显示在输出纸张页眉区域的信息。


IGRParameter 概述

参数 接口

表示报表中的可变参数值。报表拥有一组参数，参数在报表运行时可以通过编程的方式改变其值。

说明

参数对象用来在报表运行时存储生成过程中的数据，参数具有多种数据类型，参数可以被静态框关联，静态框输出参数当前值的显示文本。报表开发者可以在报表生成过程中的事件中读取与设置参数的值，例如利用参数，我们可以进行自定义的数据统计计算。


IGRParameter.AsFloat 属性

浮点数值 属性

获取或设置浮点数值，只有当为浮点数类型参数时才能成功使用此属性。

语法:对象.浮点数值=双精度小数型
号

特征

可读写


IGRParameter.Format 属性

格式串 属性

整数、浮点数、日期时间类型的参数生成输出显示文本的格式串。

语法:对象.格式串=文本型

特征

可读写

设计器中可见


IGRParameter.AsBoolean 属性

逻辑值 属性

获取或设置布尔值，只有当为布尔类型参数时才能成功使用此属性。

语法:对象.逻辑值=逻辑型

特征

可读写

仅运行时可用


IGRParameter.Name 属性

名称 属性

参数的名称标识。

语法:对象.名称=文本型

特征

可读写

设计器中可见


IGRParameter.AsDateTime 属性

日期时间值 属性

获取或设置日期时间值，只有当为日期时间类型参数时才能成功使用此属性。

语法:对象.日期时间值=日期时间型

特征

可读写

仅运行时可用


IGRParameter.DataType 属性

数据类型 属性

指示参数的数据类型。

语法:对象.数据类型=整数型(参数数据类型枚举值)

默认值:字符 特征

可读写

设计器中可见

请参见

参数数据类型枚举


IGRParameter.IsNull 属性

为空 属性

参数的值是否为空标志。

语法:对象.为空

特征

可读写

仅运行时可用


IGRParameter.DisplayText 属性

显示文字属性

参数的输出显示文本。

语法:对象.显示文字=文本型

特征

只读

仅运行时可用


IGRParameter.AsInteger 属性

整数值 属性

获取或设置整数值，只有当为整数类型参数时才能成功使用此属性。

语法:对象.整数值=整数值

特征

可读写

仅运行时可用


IGRParameter.AsString 属性

字符串值 属性

获取或设置文本值，只有当为文本类型参数时才能成功使用此属性。

语法:对象.字符串值=文本型

特征

可读写

仅运行时可用


IGRParameter.Value 属性

设置值 方法

设置参数的值。

调用格式： 〈无返回值〉 对象．设置值 （通用型 属性值）

特征

可读写

仅运行时可用


获取值

获取值方法

设置参数的值。

调用格式： 〈通用型〉 对象．获取值（）

特征

可读写

仅运行时可用


IGRPictureBox 概述

图像框 接口

表示图像部件框。

说明

用来显示各种类型的图像数据的部件框，图像数据可以直接保存在报表模板文件中，也可以在运行时从磁盘文件、二进制字段和内存中载入。


IGRPictureBox.Alignment 属性

指定图像在图像框中的显示对齐方式。

GRPictureAlignment Alignment

默认值

grpaCenter

特征

可读写

设计器中可见

请参见

IGRPictureBox 接口 | IGRPictureBox 成员 | GRPictureAlignment 枚举 | 属性特征说明


IGRPictureBox.DataField 属性

数据字段 属性

关联字段对象的名称。

语法:对象.数据字段=文本型

特征

可读写

设计器中可见


IGRPictureBox.SizeMode 属性

缩放方式 属性

指定图像在图像框中显示时的伸缩方式。

语法:对象.缩放方式=整数型(图像缩放方式枚举值)

默认值 伸缩

特征

可读写

设计器中可见


IGRPictureBox.ImageIndex 属性

图像序号 属性

指定图像框关联图像集合中某个图像的序号。

语法:对象.图像序号=整数型

默认值

0

特征

可读写

设计器中可见

说明

图像的序号从1开始，0表示不关联。Grid++Report在报表引擎中定义了一些系统内建图像，其图像序号通过枚举系统图像的枚举项来指定，也可以通过设定本属性为某个枚举项的值来关联一个系统图像。


IGRPictureBox.LoadFromFile 方法

从文件加载 方法

运行时从磁盘文件中载入图像文件。

调用格式： 〈无返回值〉 对象．从文件加载 （文本型 文件名）

参数:载入图像文件的路径与文件名。

说明

载入图像文件的时机:
1. 如果图像框位于报表头、报表尾、页眉与页脚中，应在报表主对象的 初始化 事件响应函数中执行载入文件。
2. 如果图像框位于明细网格的内容格中，应在报表主对象的 处理记录 事件响应函数中执行载入文件。
3. 如果图像框位于明细网格的分组头或分组尾中，应在报表主对象的 开始分组或 分组结束 事件响应函数中执行载入文件。

请参见

IGRPictureBox 接口 | IGRPictureBox 成员 | IGRPictureBox.LoadFromMemory 方法


IGRPrinter 概述

打印机 接口

表示打印机与纸张。定义获取与设置打印机与纸张信息的属性与方法。


IGRPrinter.PrintRangeType 属性

指定打印输出选定的页范围。

GRPrintRangeType PrintRangeType

默认值

grprtAllPages

特征

可读写

请参见

IGRPrinter 接口 | IGRPrinter 成员 | GRPrintRangeType 枚举 | 属性特征说明


IGRPrinter.PrinterName 属性

在运行时，获取或设置使用打印机的名称。

BSTR PrinterName

特征

可读写

仅运行时可用

请参见

IGRPrinter 接口 | IGRPrinter 成员 | 属性特征说明


IGRPrinter.PrintOffsetY 属性

指示报表的输出位置在垂直方向上的偏移量，以报表的计量单位表示，向下为正，向上为负。

DOUBLE PrintOffsetY

默认值

0

特征

可读写

设计器中可见

仅用于打印

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.PrintOffsetX 属性 | IGridppReport.Unit 属性 | 属性特征说明


IGRPrinter.SelectionPrintPages 属性

用文本指定的页范围，仅当PrintRangeType为grprtSelectionPages时才有效。

BSTR SelectionPrintPages

特征

可读写

说明

范围文本为单页页号文本，如1、3、8；或有效的页区间文本，如1-5、6-10。可以指定多个页或页区间，中间用AssII字符‘,’隔开。

请参见

IGRPrinter 接口 | IGRPrinter 成员 | 属性特征说明


IGRPrinter.PrintPageType 属性

指定从选定的页范围中输出的页类型。

GRPrintPageType PrintPageType

默认值

grpptAllSelectionPages

特征

可读写

请参见

IGRPrinter 接口 | IGRPrinter 成员 | GRPrintPageType 枚举 | 属性特征说明


IGRPrinter.PrintOffsetX 属性

指示报表的输出位置在水平方向上的偏移量，以报表的计量单位表示，向右为正，向左为负。

DOUBLE PrintOffsetX

默认值

0

特征

可读写

设计器中可见

仅用于打印

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.PrintOffsetY 属性 | IGridppReport.Unit 属性 | 属性特征说明


IGRPrinter.Copies 属性

获取或设置要打印的文档份数。

SHORT Copies

特征

可读写

仅用于打印

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.Collate 属性 | 属性特征说明


IGRPrinter.TopMargin 属性

页面的上边距。

DOUBLE TopMargin

默认值

2.5

特征

可读写

设计器中可见

仅用于打印

说明

以报表使用的计量单位表示属性值。

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.BottomMargin 属性 | IGRPrinter.LeftMargin 属性 | IGRPrinter.RightMargin 属性 | 属性特征说明


IGRPrinter.Duplex 属性

指示报表打印输出应用的双面打印模式。

GRDuplexKind Duplex

特征

可读写

设计器中可见

请参见

IGRPrinter 接口 | IGRPrinter 成员 | GRDuplexKind 枚举 | IGridppReport.DesignPrintDuplex 属性 | 属性特征说明


IGRPrinter.BottomMargin 属性

页面的下边距。

DOUBLE BottomMargin

默认值

2.5

特征

可读写

设计器中可见

仅用于打印

说明

以报表使用的计量单位表示属性值。

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.LeftMargin 属性 | IGRPrinter.RightMargin 属性 | IGRPrinter.TopMargin 属性 | 属性特征说明


IGRPrinter.PageCount 属性

指示当前打印文档的总页数。

SHORT PageCount

特征

可读写

仅用于打印

请参见

IGRPrinter 接口 | IGRPrinter 成员 | 属性特征说明


IGRPrinter.RightMargin 属性

页面的右边距。

DOUBLE RightMargin

默认值

2.5

特征

可读写

设计器中可见

仅用于打印

说明

以报表使用的计量单位表示属性值。

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.BottomMargin 属性 | IGRPrinter.LeftMargin 属性 | IGRPrinter.TopMargin 属性 | 属性特征说明


IGRPrinter.PaperLength 属性

获取或设置打印纸张的长度。

DOUBLE PaperLength

特征

可读写

仅用于打印

说明

以报表使用的计量单位表示属性值。只有当设置纸张类型为自定义纸张时，设置本属性才生效。

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.PaperWidth 属性 | IGRPrinter.PaperSize 属性 | 属性特征说明


IGRPrinter.PaperOrientation 属性

打印纸张的方向。

GRPaperOrientation PaperOrientation

默认值

Portrait

特征

可读写

仅用于打印

请参见

IGRPrinter 接口 | IGRPrinter 成员 | GRPaperOrientation 枚举 | 属性特征说明


IGRPrinter.PaperWidth 属性

获取或设置打印纸张的宽度。

DOUBLE PaperWidth

特征

可读写

仅用于打印

说明

以报表使用的计量单位表示属性值。只有当设置纸张类型为自定义纸张时，设置本属性才生效。

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.PaperLength 属性 | IGRPrinter.PaperSize 属性 | 属性特征说明


IGRPrinter.PaperSource 属性

指定打印机的纸张来源。

GRPaperSourceKind PaperSource

特征

可读写

设计器中可见

请参见

IGRPrinter 接口 | IGRPrinter 成员 | GRPaperSourceKind 枚举 | 属性特征说明


上边缩进

成员属性“纸张类型”所在数据类型为“打印机”，英文名称为“PaperKind”，类型为“整数型（int）”。
property PaperKind。
可供选择的属性值：
255. grpkDefault
256. grpkCustom
1. grpkLetter
5. grpkLegal
16. grpk10X14
17. grpk11X17
90. grpk12X11
8. grpkA3
9. grpkA4
10. grpkA4Small
11. grpkA5
70. grpkA6
12. grpkB4
13. grpkB5
88. grpkB6
24. grpkCSheet
25. grpkDSheet
19. grpkEnvelope9
20. grpkEnvelope10
21. grpkEnvelope11
22. grpkEnvelope12
23. grpkEnvelope14
28. grpkEnvelopeC5
29. grpkEnvelopeC3
30. grpkEnvelopeC4
31. grpkEnvelopeC6
32. grpkEnvelopeC65
33. grpkEnvelopeB4
34. grpkEnvelopeB5
35. grpkEnvelopeB6
27. grpkEnvelopeDL
36. grpkEnvelopeItaly
37. grpkEnvelopeMonarch
38. grpkEnvelopePersonal
26. grpkESheet
7. grpkExecutive
39. grpkFanfold
14. grpkFolio
4. grpkLedger
2. grpkLetterSmall
18. grpkNote
93. grpkP16K
94. grpkP32K
15. grpkQuarto
6. grpkStatement
3. grpkTabloid


IGRPrinter.PaperName 属性

打印纸张的名称。

BSTR PaperName

默认值

A4

特征

可读写

仅用于打印

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.PaperLength 属性 | IGRPrinter.PaperWidth 属性 | IGRPrinter.PaperName 属性 | 属性特征说明


IGRPrinter.PaperSize 属性

表示打印纸张的大小。

SHORT PaperSize

特征

可读写

仅用于打印

说明

参考Windows SDK中DEVMODE的成员dmPaperSize的说明。其中256代表自定义纸张，当定义为自定义纸张时，可以设置纸张宽度与长度属性指定打印纸张的大小。

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.PaperName 属性 | IGRPrinter.PaperLength 属性 | IGRPrinter.PaperWidth 属性 | 属性特征说明


IGRPrinter.Collate 属性

指示打印文档是否逐份打印。

VARIANT_BOOL Collate

特征

可读写

仅用于打印

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.Copies 属性 | 属性特征说明


IGRPrinter.LeftMargin 属性

页面的左边距。

DOUBLE LeftMargin

默认值

2.5

特征

可读写

设计器中可见

仅用于打印

说明

以报表使用的计量单位表示属性值。

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.BottomMargin 属性 | IGRPrinter.RightMargin 属性 | IGRPrinter.TopMargin 属性 | 属性特征说明


IGRPrinter.PrintDialog 方法

显示打印对话框。

VARIANT_BOOL PrintDialog(void);

返回值

VARIANT_BOOL

如果成功显示打印对会框，返回真，否则返回假。

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.PageSetupDialog 方法 | IGRPrinter.PrinterSetupDialog 方法


IGRPrinter.PrinterSetupDialog 方法

显示打印机设置对话框

VARIANT_BOOL PrinterSetupDialog(void);

返回值

VARIANT_BOOL

如果成功显示打印机对会框，返回真，否则返回假。

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.PageSetupDialog 方法 | IGRPrinter.PrintDialog 方法


IGRPrinter.PageSetupDialog 方法

显示页面设置对话框。

VARIANT_BOOL PageSetupDialog(void);

返回值

VARIANT_BOOL

如果成功显示页面设置对会框，返回真，否则返回假。

请参见

IGRPrinter 接口 | IGRPrinter 成员 | IGRPrinter.PrintDialog 方法 | IGRPrinter.PrinterSetupDialog 方法


IGRRecordset 概述

数据集 接口

表示明细网格的记录集。拥有一组字段，在报表运行时可以读取与添加记录数据。


IGRRecordset.FetchRecordScript 属性

请求记录脚本 属性

表示报表 请求记录 事件对应的脚本语言代码。

语法:对象.请求记录脚本=文本型

特征

可读写

设计器中可见


IGRRecordset.QuerySQL 属性

查询SQL 属性

从数据源中取数的SQL语句。

语法:对象.查询SQL=文本型

特征

可读写

设计器中可见


IGRRecordset.PageProcessRecordScript 属性

打印生成记录处理脚本 属性

表示报表 页处理记录事件对应的脚本语言代码。

语法:对象.打印生成记录处理脚本=文本型

特征

可读写

设计器中可见


IGRRecordset.SortCaseSensitive 属性

大小写区分排序 属性

当排序字段为字符型时，指定排序比较是否为大小写字符敏感。

语法:对象.大小写区分排序=逻辑型

默认值 假

特征

可读写

设计器中可见


IGRRecordset.SkipQuery 属性

忽略数据绑定 属性

指示在生成报表时，是否忽略从数据源取数的属性设置。

语法:对象.忽略数据绑定=逻辑型

默认值:假

特征

可读写

设计器中可见


IGRRecordset.RecordNo 属性

记录号 属性

指示当前记录的记录号，记录号从1开始。

语法:对象.记录号

特征

只读

仅运行时可用


IGRRecordset.RecordCount 属性

记录数 属性

指示记录集中的记录条数。

语法:对象.记录数

特征

只读

仅运行时可用


IGRRecordset.Editable 属性

可编辑 属性

指定记录集在报表运行时是否为可编辑。

语法:对象.可编辑=逻辑型

默认值 :真

特征

可读写

设计器中可见


IGRRecordset.ConnectionString 属性

链接串 属性

与数据源连接的参数文字串

语法:对象.链接串=文本型

特征

可读写

设计器中可见


IGRRecordset.SortFields 属性

排序字段 属性

指定在报表生成时对记录进行排序的依据字段。

语法:对象.排序字段=文本型

特征

可读写

设计器中可见

说明

如果设置了本属性，在记录集记录填充完成之后和对记录进行处理之前，报表引擎会根据排序字段对记录进行排序。如果要按多个字段进行排序，字段名称之间用‘;’隔开。


IGRRecordset.SortAsc 属性

升序排序 属性

指定是否按升序排列记录,本属性为真,则排序时按升序排序,返之则按降序排序。

语法:对象.升序排序=逻辑型

默认值:真

特征

可读写

设计器中可见


IGRRecordset.ProcessRecordScript 属性

生成记录处理脚本 属性

表示报表 记录记录 事件对应的脚本语言代码。

语法:对象.生成记录处理脚本=文本型

特征

可读写

设计器中可见


IGRRecordset.BeforePostRecordScript 属性

提交记录前脚本 属性

表示报表 提交记录之前 事件对应的脚本语言代码。

语法:对象.提交记录前脚本=文本型

特征

可读写

设计器中可见


IGRRecordset.Edit 方法

编辑 方法

使当前记录进入可编辑状态，从而可以改变字段的值。

调用格式： 〈无返回值〉 对象．编辑 （）

说明

只有当报表处于运行时且记录集是可以编辑的，才能成功使当前记录进入可编辑状态。在记录进入可编辑状态之后，可以给各个字段赋值，最后调用 提交 方法将编辑后的记录保存到记录集中；也可以调用 取消 方法取消编辑改变，将当前记录还原为原来的数据。

注意：不能在记录编辑状态中改变不定长字符字段与二进制字段的值。

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.Editable 属性 | IGRRecordset.Post 方法 | IGRRecordset.Cancel 方法


IGRRecordset.First 方法

第一条 方法

使第一条记录成为当前记录。

调用格式： 〈无返回值〉 对象．第一条 （）

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.Last 方法 | IGRRecordset.MoveBy 方法 | IGRRecordset.MoveTo 方法 | IGRRecordset.Next 方法 | IGRRecordset.Prior 方法


IGRRecordset.Fields 属性

获取字段集合 方法

拥有的字段集合对象的接口引用。

调用格式： 〈字段集合〉 对象．获取字段集合 （）

特征

只读

设计器中可见

请参见

字段集合 接口


IGRRecordset.Eof 方法

记录头 方法

判断记录集的游标是否位于最后一条记录之后。

调用格式： 〈逻辑型〉 对象．记录头 （）

返回值:逻辑型,游标位于最后一条记录之后，返回真，否则返回假。

说明

当游标位于最后一条记录之后，各个字段的值为最后一条记录的数据。当记录集中不存在记录时，Eof始终返回真。

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.Bof 方法


IGRRecordset.Bof 方法

记录尾 方法

判断记录集的游标是否位于第一条记录之前。

调用格式： 〈逻辑型〉 对象．记录尾 （）

返回值:逻辑型,游标位于第一条记录之前，返回真，否则返回假。

说明

当游标位于第一条记录之前，各个字段的值为第一条记录的数据。当记录集中不存在记录时，记录尾始终返回真。

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.Eof 方法


IGRRecordset.Empty 方法

清空 方法

请空记录集中的全部记录。

调用格式： 〈无返回值〉 对象．清空 （）

请参见

IGRRecordset 接口 | IGRRecordset 成员


IGRRecordset.RemoveAllFields 方法

清空字段 方法

删除所有的字段定义。

调用格式： 〈无返回值〉 对象．清空字段 （）

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.AddField 方法


IGRRecordset.Cancel 方法

取消 方法

取消当前记录的可编辑状态，并还原记录的原来数据。

调用格式： 〈无返回值〉 对象．取消 （）

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.Append 方法 | IGRRecordset.Edit 方法


IGRRecordset.Prior 方法

上一条 方法

使当前记录的上一条记录成为当前记录。

调用格式： 〈无返回值〉 对象．上一条 （）

说明

如果当前记录已经是第一条记录，调用本方法将使记录集游标位于记录头。

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.First 方法 | IGRRecordset.Last 方法 | IGRRecordset.MoveBy 方法 | IGRRecordset.MoveTo 方法 | IGRRecordset.Next 方法


IGRRecordset.Post 方法

提交 方法

提交新增记录。

调用格式： 〈无返回值〉 对象．提交 （）

说明

在调用追加方法之后，然后向各个字段赋值，最后调用提交方法将新记录提交。新记录只有提交之后才会存储打记录集中。此方法只能在 请求记录数据 事件响应函数中使用。

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.Append 方法


IGRRecordset.Next 方法

下一条 方法

使当前记录的下一条记录成为当前记录。

调用格式： 〈无返回值〉 对象．下一条 （）

说明

如果当前记录已经是最后一条记录，调用下一条方法将使记录集游标位于记录尾。

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.First 方法 | IGRRecordset.Last 方法 | IGRRecordset.MoveBy 方法 | IGRRecordset.MoveTo 方法 | IGRRecordset.Prior 方法


IGRRecordset.MoveBy 方法

相对移动 方法

将游标向前或向后移动指定个数的记录。

调用格式： 〈无返回值〉 对象．相对移动 （整数型 移动距离）

 参数:移动距离,当前记录移动偏移量，为正向前移动，为负向后移动。

说明

如果移动偏移量超出记录集的范围，将使记录集位置处于Bof或Eof的位置。

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.First 方法 | IGRRecordset.Last 方法 | IGRRecordset.MoveTo 方法 | IGRRecordset.Next 方法 | IGRRecordset.Prior 方法


IGRRecordset.MoveTo 方法

移动到 方法

将记录集的当前记录设为指定记录号的记录。

调用格式： 〈无返回值〉 对象．移动到 （整数型 记录号）

参数:记录号,指定移动到目标记录的记录号。

说明

记录好的编号从零开始，依次递增。

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.First 方法 | IGRRecordset.Last 方法 | IGRRecordset.MoveBy 方法 | IGRRecordset.Next 方法 | IGRRecordset.Prior 方法


IGRRecordset.AddField 方法

增加字段 方法

增加一个字段。

调用格式： 〈字段〉 对象．增加字段 （文本型 字段名称，字段类型枚举 字段类型）

返回值:字段,返回新增字段对象的接口引用。

参数

字段名称: 指定字段的名称标识。

字段类型: 指定字段的类型。

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRField 接口 | GRFieldType 枚举 | IGRFields 接口 | IGRRecordset.RemoveAllFields 方法


IGRRecordset.Resort 方法

重排序 方法

对记录集中的记录进行重新排序。

调用格式： 〈逻辑型〉 对象．重排序 （文本型 排序字段，逻辑型 是否升序排序，逻辑型 是否大小写敏感）

参数

排序字段: 指定排序字段，如果要按多个字段进行排序，字段名称之间用‘;’隔开。

是否升序排序: 指定是否按升序进行排序。

是否大小写敏感: 指定字符进行排序比较时是否大小写敏感。

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.SortFields 属性 | IGridppReport.BeforeSort 事件


IGRRecordset.Append 方法

追加 方法

添加一条形记录。

调用格式： 〈无返回值〉 对象．追加 （）

说明

在调用追加方法之后，然后向各个字段赋值，最后调用提交方法将新记录提交。新记录只有提交之后才会存储打记录集中。此方法只能在 请求记录 事件响应函数中使用。

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.Post 方法


IGRRecordset.Last 方法

最后一条 方法

使最后一条记录成为当前记录。

调用格式： 〈无返回值〉 对象．最后一条 （）

请参见

IGRRecordset 接口 | IGRRecordset 成员 | IGRRecordset.First 方法 | IGRRecordset.MoveBy 方法 | IGRRecordset.MoveTo 方法 | IGRRecordset.Next 方法 | IGRRecordset.Prior 方法


IGRReportFooter 概述

报表尾 接口

表示报表的报表尾。报表尾一般显示在报表的最后面。

说明

报表尾在打印生成时，如果不选择每页重复输出，则只在报表的最后输出一次；在屏幕查询显示时，显示在明细网格之下。一个报表可以定义多个报表尾，在一般情况下我们只需定义一个报表尾就可以了。在报表尾中一般定义报表的统计信息及其它只需在报表结束时显示一次的信息。


IGRReportFooter.KeepTogether 属性

保持同页 属性

是否保持本节输出显示在同一页标志。

语法:对象.保持同页=逻辑型

默认值:真

特征

可读写

设计器中可见

仅用于打印


IGRReportFooter.PrintAtBottom 属性

打印在页底 属性

是否将本节输出在页面底部标志。

语法:对象.打印在页底=逻辑型

默认值:假

特征

可读写

设计器中可见

仅用于打印


IGRReportFooter.NewPage 属性

换新页方式 属性

指定新页的产生方式。

语法:对象.换新页方式=整数型(换新页方式枚举值)

默认值:drnpsNone

特征

可读写

设计器中可见

仅用于打印

请参见

换新页方式枚举


IGRRichTextBox 概述

丰富格式文字框 接口

表示RTF格式文本部件框。

用来定义RTF格式文本部件框，RTF格式文本数据可以直接保存在报表模板文件中，也可以在运行时从磁盘文件、二进制字段和内存中载入。


IGRRichTextBox.RTF 属性

数据 属性

表示拥有RTF文本的数据。

语法:对象.数据=文本型

特征

可读写

设计器中可见


IGRRichTextBox.DataField 属性

数据字段 属性

关联字段对象的名称。

语法:对象.数据字段=文本型
号

特征

可读写

设计器中可见


IGRSection 概述

报表节 接口

报表节的基类，表示各种报表节相同的属性与方法。

说明

整个报表的输出显示由多种类型的占据整个水平输出区域宽度的矩形区域组成，以上各种类型显示区域统称为报表节。Grid++Report节类型包括：页眉、页脚、报表头、报表尾、标题行，内容行、分组头、分组尾。


IGRShapeBox 概述

图形框 接口

表示图形框。

说明

用来显示各种图形的部件框，在设计时设定某种图形类别，并设定该种图形的一些参数信息。图形框一般用来对报表进行一些修饰。


IGRShapeBox.PenWidth 属性

画笔宽度 属性

指定画线条的画笔的宽度。

语法:对象.画笔宽度=整数型

默认值

1

特征

可读写

设计器中可见

说明

以屏幕像素表示属性值。


IGRShapeBox.PenColor 属性

画笔颜色 属性

画图形线条的颜色。

语法:对象.画笔颜色=整数型

默认值 黑色

特征

可读写


IGRShapeBox.PenStyle 属性

画笔样式 属性

指定画线条的画笔类型。

语法:对象.画笔样式=整数型(画笔样式枚举值)

默认值

grpsSolid

特征

可读写

设计器中可见

请参见

画笔样式枚举

画线条时，指定画线笔的类型。

成员名称 | 说明
不应用 | 不画线。
段线 | 画段虚线。
点划线 | 画点段虚线。
双点划线 | 画双点段虚线。
虚线 | 画点虚线。
凹框线 | 画内框线。
实线 | 画实线。


IGRShapeBox.FillStyle 属性

填充方式 属性

封闭图形对象的内部填充方式。

语法:对象.填充方式=整数型号(填充方式枚举值)

默认值

通常

特征

可读写

设计器中可见

背景模式枚举

指定部件再显示时用来填充其所占区域背景的方式。

成员名称 | 说明
通常 | 部件框使用背景色填充他占据的矩形区域。
透明 | 部件框背景透明，允许任何背景图像或其他部件框透过自身显示。


IGRShapeBox.FillColor 属性

填充色 属性

封闭图形对象的内部填充色。

语法:对象.填充色=整数型

默认值:黑色 特征

可读写

设计器中可见


IGRShapeBox.ShapeType 属性

图形类型 属性

指定图形的类型。

语法:对象.图形类型=整数型(图形类型枚举值)

默认值 矩形

特征

可读写

设计器中可见

图形类型枚举

指定图形部件框的具体类型。

成员名称 | 说明
圆 | 圆。
椭圆 | 椭圆。
直线 | 直线。
矩形 | 矩形。
圆角矩形 | 圆角矩形。
圆角正方形 | 圆角正方形。
正方形 | 正方形。


IGRShapeBox.CornerDy 属性

圆角高度 属性

圆角矩形框的圆角椭圆高度。

语法:对象.圆角高度=整数型

默认值

4

特征

可读写

设计器中可见


IGRShapeBox.CornerDx 属性

圆角宽度属性

圆角矩形框的圆角椭圆宽度。

语法:对象.圆角宽度=整数型

默认值

4

特征

可读写

设计器中可见


IGRSharePrintSetupObject 概述

共享打印设置对象 接口

表示共享的打印机与纸张设置参数。

说明

在一个应用程序中存在且仅存在一个本类对象，所有应用共享答应设置的报表都从此对象存取共享的答应参数。


IGRSharePrintSetupObject.PrinterName 属性

打印机名称 属性

获取或设置工作打印机的名称。

语法:对象.打印机名称=文本型

特征

可读写


IGRSharePrintSetupObject.Unit 属性

单位 属性

获取或设置表示本对象计量类型属性的计量单位。

语法:对象.单位=整数型(单位枚举值)

特征

可读写

请参见

单位枚举


IGRSharePrintSetupObject.TopMargin 属性

上边距 属性

页面的上边距。

语法:对象.上边距=双精度小数型

特征

可读写

说明

以本对象定义的计量单位表示属性值。


IGRSharePrintSetupObject.BottomMargin 属性

下边距 属性

页面的下边距。

语法:对象.下边距=双精度小数型

特征

可读写

说明

以本对象定义的计量单位表示属性值。


IGRSharePrintSetupObject.RightMargin 属性

右边距 属性

页面的右边距。

语法:对象.右边距=双精度小数型

特征

可读写

说明

以本对象定义的计量单位表示属性值。


IGRSharePrintSetupObject.LeftMargin 属性

左边距 属性

页面的左边距。

语法:对象.左边距=双精度小数型

特征

可读写

说明

以本对象定义的计量单位表示属性值。


IGRSharePrintSetupObject.PaperLength 属性

纸张长度 属性

获取或设置打印纸张的长度。

语法:对象.纸张长度=双精度小数型

特征

可读写

说明

以本对象定义的计量单位表示属性值。只有当设置纸张类型为自定义纸张时，设置本属性才生效。


IGRSharePrintSetupObject.PaperOrientation 属性

纸张方向 属性

打印纸张的方向。

语法:对象.纸张方向=整数型(纸张方向枚举值)

特征

可读写

请参见

纸张方向 枚举


IGRSharePrintSetupObject.PaperWidth 属性

纸张宽度 属性

获取或设置打印纸张的宽度。

语法:对象.纸张宽度=双精度小数型

特征

可读写

说明

以本对象定义的计量单位表示属性值。只有当设置纸张类型为自定义纸张时，设置本属性才生效。


IGRSharePrintSetupObject.PaperSource 属性

纸张来源 属性

获取或设置打印机的纸张来源。

语法:对象.纸张来源=整数型(纸张来源枚举值)

特征

可读写

请参见

纸张来源 枚举


IGRSharePrintSetupObject.PaperName 属性

纸张名称 属性

打印纸张的名称。

语法:对象.纸张名称=文本型

特征

可读写


IGRSharePrintSetupObject.PaperSize 属性

纸张型号 属性

表示打印纸张的类型。

语法:对象.纸张型号=整数型

特征

可读写

说明

参考Windows SDK中DEVMODE的成员dmPaperSize的说明。其中256代表自定义纸张，但定义为自定义纸张时，可以设置纸张宽度与长度属性指定打印纸张的大小。


IGRSharePrintSetupObject.PrintDialog 方法

打印对话框 方法

显示打印对话框。

调用格式： 〈逻辑型〉 对象．打印对话框 （）

返回值:指示是否成功进行了设置任务。

请参见

IGRSharePrintSetupObject 接口 | IGRSharePrintSetupObject 成员


IGRSharePrintSetupObject.PrinterSetupDialog 方法

调用格式： 〈逻辑型〉 对象．打印机设置对话框 （）

显示打印机设置对话框

调用格式： 〈逻辑型〉 对象．打印机设置对话框 （）

返回值:指示是否成功进行了设置任务。

请参见

IGRSharePrintSetupObject 接口 | IGRSharePrintSetupObject 成员


IGRSharePrintSetupObject.PageSetupDialog 方法

页面设置对话框 方法

显示页面设置对话框。

调用格式： 〈逻辑型〉 对象．页面设置对话框 （）

返回值:指示是否成功进行了设置任务。

请参见

IGRSharePrintSetupObject 接口 | IGRSharePrintSetupObject 成员


IGRStaticBox 概述

静态文字框 接口

文字部件框。可以与参数对象关联，显示参数对象的值。

说明

用来显示静态文本的部件框，一般在设计时设定要显示的文本，在输出显示时根据输出格式信息将显示文本画出来。静态框可以关联某个参数对象，在这种情况下，在输出显示时部件框的显示文本为参数对象的显示文本，当一个部件框在输出时要显示多次，而其关联的参数对象的值是变化的，则此静态框在不同位置输出时的显示文字是变化的。


IGRStaticBox.Text 属性

显示文本。

BSTR Text

特征

可读写

设计器中可见

说明

当静态框关联参数时，此属性在显示时被忽略。

请参见

IGRStaticBox 接口 | IGRStaticBox 成员 | 属性特征说明


IGRTextBox.DisplayText 属性

显示文字 属性

运行时文字框的显示文本。

语法:对象.显示文字

特征

只读

仅运行时可用


IGRSubReport 概述

子报表 接口

表示子报表部件框。

说明

通过关联另一个报表对象，在此报表中显示另外一个报表。子报表受以下规则限制：
1。子报表只能应用在报表头与报表尾中应用。
2。子报表所在的节不允许重复打印。
3。子报表在数据导出时被忽略掉。
4。子报表本身的页眉与页脚在生成时被忽略掉。


IGRSubReport.Report 属性

设置关联报表 方法

关联的报表对象。

调用格式： 〈无返回值〉 对象．设置关联报表 （报表 属性值）

特征

可读写

请参见


IGRSummaryBox 概述

统计框 接口

表示统计框。

说明

用来显示统计数据的部件框，在设计时设定某种统计函数，除计数（Count）函数外，其余统计函数都需要关联一个字段对象。在统计框中可以定义统计值的输出格式。统计框一般使用在分组头、分组尾中。有时为了统计全部记录的统计数据，可以将部件框使用在报表尾，报表头中。


IGRSummaryBox.Format 属性

格式串 属性

统计值生成显示文字所应用的格式串。

语法:对象.格式串=文本型

格式串设置请参阅报表设计器格式串设置窗口.

特征

可读写

设计器中可见


IGRSummaryBox.DataField 属性

数据字段 属性

关联的数据字段对象名称。

语法:对象.数据字段=文本型

特征

可读写


IGRSummaryBox.SummaryFun 属性

统计函数 属性

指定应用的统计函数。

语法:对象.统计函数=整数型(统计函数枚举值)

默认值 :合计

特征

可读写

统计函数 枚举

指定统计部件框应用的统计函数。

成员名称 | 说明
平均 | 统计某个字段的平均值。
数目 | 统计明细记录的个数。
最大值 | 找出某个字段的最大值。
最小值 | 找出某个字段的最小值。
合计 | 统计某个字段的合计值。


IGRSummaryBox.Value 属性

值 属性

再生成过程中，统计部件框的当前统计值。

语法:对象.值=双精度小数型

特征

可读写

设计器中可见

仅运行时可用


IGRSystemVarBox 概述

系统变量框 接口

表示系统变量框。

说明

用来显示系统变量值的部件框，在设计时设定某种系统变量，在系统变量框中可以定义值的输出格式。系统变量框可以使用在任何部件框容器中，例如页号、页总数一般使用在页眉与页脚中。


IGRSystemVarBox.SystemVar 属性

系统变量 属性

指定应用的系统变量类型。

语法:对象.系统变量=整数型(系统变量枚举值)

默认值:当前页号

特征

可读写

设计器中可见

请参见

系统变量枚举

指定系统变量部件框应用的系统变量类型。

成员名称 | 说明
当前日期时间 | 计算机的当前日期时间。
一级分组行号 | 一级分组的当前分组项的序号，从1开始计数。
二级分组行号 | 二级分组的当前分组项的序号，从1开始计数。
三级分组行号 | 三级分组的当前分组项的序号，从1开始计数。
总页数 | 总页数。
当前页号 | 当前页号。
记录号 | 明细记录的当前记录号，从1开始计数。
行号 | 明细网格的当前行号，从1开始计数。


IGRTextBox 概述

文字框 接口

各种文字部件框的基类，表示各种文字部件框的相同属性与方法。

说明

各种显示文本的部件框的统称，包括：静态框、字段框、统计框、系统变量框。

请参见

IGRTextBox 成员


IGRColumnContentCells 概述

内容格集合 接口

公开内容行的所有内容格的集合对象。

说明

内容格伴随列的创建而创建，伴随列的移除而移除，所以在此集合对象中不提供增加与移除集合元素的方法。


IGRColumnContentCells.Count 属性

数目 属性

指示拥有内容格的个数。

特征

只读


IGRColumns 概述

列集合 接口

公开明细网格的所有列的集合对象。


IGRColumnContentCells.Item 属性

获取项目 方法

根据内容格的顺序号或名称得到内容格的接口引用。

调用格式： 〈内容格〉 对象．获取项目 （通用型 项目名称或者序号）

特征

只读

说明

在读取时要传入一个通用型类型的参数，指定内容格的顺序号或名称，内容格的顺序号从一开始。


IGRColumnContentCells.IndexByName 方法

根据名称得序号 方法

根据内容格的名称取得其顺序号，如果不存在与名称匹配的内容格，则返回值为-1。内容格的名称不区分字母的大小写。

调用格式： 〈整数型〉 对象．根据名称得序号 （文本型 内容格名称）

如果存在名称匹配的内容格，返回内容格的顺序号，否则返回-1。


IGRColumns.Count 属性

数目 属性

指示拥有列的个数。

特征

只读


IGRColumns.Item 属性

获取项目 方法
根据列的顺序号或名称得到列的接口引用。

调用格式： 〈列〉 对象．获取项目 （通用型 列名称或者序号）

特征

只读

说明

在读取时要传入一个通用型类型的参数，指定列的顺序号或名称，列的顺序号从一开始。名称在匹配时不区分字母大小写。


IGRColumns.Add 方法

增加 方法

增加一个列并返回新增列的接口引用。

调用格式： 〈列〉 对象．增加 （）

新增列的接口引用。


IGRColumns.Remove 方法

删除 方法

根据列的顺序号或名称将列移除。

调用格式： 〈无返回值〉 对象．删除 （通用型 列名称或序号）

指定列的顺序号或名称。


IGRColumns.RemoveAll 方法

全部删除 方法

清除全部列。

调用格式： 〈无返回值〉 对象．全部删除 （）


IGRColumns.IndexByName 方法

根据名称得序号 方法

根据列的名称取得其顺序号，如果不存在与名称匹配的列，则返回值为-1。列的名称不区分字母的大小写。

调用格式： 〈整数型〉 对象．根据名称得序号 （文本型 列名称）

如果存在名称匹配的列，返回列的顺序号，否则返回-1。


IGRColumnTitleCells 概述

标题格集合 接口

标题行的拥有的标题格集合对象的接口。

与列对应的标题格伴随列的创建而创建，伴随列的移除而移除，但组标题格不存在唯一对应的列，其创建与移除独立于列，所以在此集合对象中不提供增加与移除集合元素的通常方法，但提供增加组标题格与删除组标题格方法专门用来增加与移除组标题格。


IGRColumnTitleCells.Count 属性

数目 属性

指示拥有标题格的个数。

特征

只读


IGRColumnTitleCells.Item 属性

获取项目 属性

根据标题格的顺序号或名称得到标题格的接口引用。

调用格式： 〈标题格〉 对象．获取项目 （通用型 名称或者序号）

特征

只读

说明

在读取时要传入一个通用型类型的参数，指定标题格的顺序号或名称，标题格的顺序号从一开始。


IGRColumnTitleCells.IndexByName 方法

根据名称得序号 方法

根据标题格的名称取得其顺序号，如果不存在与名称匹配的标题格，则返回-1。标题格的名称不区分字母大小写。

调用格式： 〈整数型〉 对象．根据名称得序号 （文本型 名称）

如果有匹配的标题格，返回其顺序号，否则返回-1。

参数

名称

指定查找标题格的名称。


IGRColumnTitleCells.AddGroup 方法

增加组标题格 方法

增加一个组标题格。

调用格式： 〈标题格〉 对象．增加组标题格 （文本型 名称，文本型 标题）

新增组标题格的接口引用。

参数

名称

新增组标题格的名称。

标题

新增组标题格的显示文本。


IGRColumnTitleCells.RemoveGroup 方法

删除组标题格 方法

根据组标题格的顺序号或名称移除一个组标题格。

调用格式： 〈无返回值〉 对象．删除组标题格 （通用型 名称或序号）

参数

名称或序号

指示准备移除的组标题格的顺序号或名称。

说明

根据组标题格的顺序号或名称移除一个组标题格。只有当指定名称或序号的标题格存在，并且此标题格是组标题格时，才能成功移除标题格。


IGRControls 概述

部件框集合 接口

公开部件框容器中的所有部件框的集合对象。


IGRControls.Count 属性

数目 属性

指示拥有部件框的个数。

特征

只读


IGRControls.Item 属性

获取项目 方法

根据部件框的顺序号或名称得到部件框的接口引用。

调用格式： 〈标题格〉 对象．获取项目 （通用型 顺序号或名称）

特征

可读写

说明

在读取时要传入一个通用型类型的参数，指定部件框的顺序号或名称，部件框的顺序号从一开始。


IGRControls.Add 方法

增加 方法

根据部件框的类型参数增加一个部件框并返回新增部件框的接口引用。

调用格式： 〈部件框〉 对象．增加 （部件框类型枚举 类型）

返回值:新增部件框对象的接口引用。

参数

类型

指定新增部件框的类型。


IGRControls.Remove 方法

删除 方法

根据部件框的顺序号或名称将部件框移除，在输入参数种指定要移除部件框的顺序号或名称。

调用格式： 〈无返回值〉 对象．删除 （通用型 序号或名称）


IGRControls.RemoveAll 方法

全部删除 方法

清除全部部件框。

调用格式： 〈无返回值〉 对象．全部删除 （）


IGRControls.SetItemOrder 方法

设置项目顺序 方法

改变指定部件框的顺序。

调用格式： 〈无返回值〉 对象．设置项目顺序 （通用型 名称或序号，整数型 新顺序号）

参数

名称或序号:

指定部件框的名称或序号。

新顺序号:

指定部件框的新顺序号。


IGRControls.IndexByName 方法

根据名称得序号 方法

根据部件框的名称取得其顺序号，如果不存在与名称匹配的部件框，则返回-1。部件框的名称不区分字母的大小写。

调用格式： 〈整数型〉 对象．根据名称得序号 （文本型 名称）

如果有匹配的部件框，返回其顺序号，否则返回-1。

参数

名称:指定部件框的名称。


IGRFields 概述

字段集合 接口

公开记录集的所有字段的集合对象。


IGRFields.Count 属性

数目 属性

指示拥有字段的个数。

特征

只读


IGRFields.Item 属性

数目 属性

根据字段的顺序号或名称得到字段的接口引用。

调用格式： 〈字段〉 对象．获取项目 （通用型 顺序号或名称）
特征

只读

说明

在读取时要传入一个通用型类型的参数，指定字段的顺序号或名称，字段的顺序号从一开始。


IGRFields.Add 方法

增加 方法

根据字段类型参数增加一个字段并返回新增字段的接口引用。

调用格式： 〈字段〉 对象．增加 （）

新增字段的接口引用。


IGRFields.Remove 方法

删除 方法

根据字段的顺序号或名称将字段移除，在输入参数种指定要移除字段的顺序号或名称。

调用格式： 〈无返回值〉 对象．删除 （通用型 顺序号或名称）

参数

顺序号或名称:

指定字段的顺序号或名称。


IGRFields.IndexByName 方法

根据名称得序号 方法

根据字段的名称取得其顺序号，如果不存在与名称匹配的字段，则返回-1。字段的名称不区分字母的大小写。

调用格式： 〈整数型〉 对象．根据名称得序号 （文本型 名称）

如果有匹配的字段，返回其顺序号，否则返回-1。

参数

名称:指定字段的名称。


IGRFields.RemoveAll 方法

全部删除 方法

清除全部字段。

调用格式： 〈无返回值〉 对象．全部删除 （）


IGRGroups 概述

IGRGroups 接口

公开明细网格的所分组的集合对象。

有关此接口所有成员的列表，请参阅 IGRGroups 成员。

IDispatch
IGRGroups

请参见

IGRGroups 成员 | IGRGroup 接口


IGRGroups.Count 属性

数目 属性

指示拥有分组的个数。

特征

只读


IGRGroups.Item 属性

获取项目 属性

根据分组的顺序号或名称得到列分组接口引用。

调用格式： 〈分组〉 对象．获取项目 （通用型 顺序号或名称）

特征

只读

说明

在读取时要传入一个通用型类型的参数，指定分组的顺序号或名称，分组的顺序号从一开始。


IGRGroups.Add 方法

增加 方法

增加一个分组并返回新增分组的接口引用。

调用格式： 〈分组〉 对象．增加 （）

返回值 :新增分组的接口引用。

<


IGRGroups.Remove 方法

删除 方法

根据分组的顺序号或名称将分组移除，在输入参数种指定要移除分组的顺序号或名称。

调用格式： 〈无返回值〉 对象．删除 （通用型 I顺序号或名称）

参数:指定分组的顺序号或名称。


IGRGroups.RemoveAll 方法

全部删除 方法

清除全部分组。

调用格式： 〈无返回值〉 对象．全部删除 （）


IGRGroups.IndexByName 方法

根据名称得序号 方法

根据分组的名称取得其顺序号，如果不存在与名称匹配的分组，则返回-1。分组的名称不区分字母的大小写。

调用格式： 〈整数型〉 对象．根据名称得序号 （文本型 名称）

返回值:如果有匹配的分组，返回其顺序号，否则返回-1。

参数

名称:指定分组的名称。


IGRParameters 概述

IGRParameters 接口

公开报表组对象的所有参数的集合对象。

有关此接口所有成员的列表，请参阅 IGRParameters 成员。

IDispatch
IGRParameters

请参见

IGRParameters 成员 | IGRParameter 接口


IGRParameters.Count 属性

数目 属性

指示拥有参数的个数。

特征

只读


IGRParameters.Item 属性

获取项目 方法

根据参数的顺序号或名称得到参数的接口引用。

调用格式： 〈参数〉 对象．获取项目 （通用型 顺序号或名称）

特征

只读

说明

在读取时要传入一个通用型类型的参数，指定参数的顺序号或名称，参数的顺序号从一开始。


IGRParameters.Add 方法

增加 方法

增加一个参数并返回新增参数的接口引用。

调用格式： 〈参数〉 对象．增加 （）

返回值:新增参数的接口引用。


IGRParameters.Remove 方法

删除 方法

根据参数的顺序号或名称将参数移除，在输入参数种指定要移除参数的顺序号或名称。

调用格式： 〈无返回值〉 对象．删除 （通用型 顺序号或名称）

参数:指定参数的顺序号或名称。


IGRParameters.RemoveAll 方法

全部删除 方法

清除全部参数。

调用格式： 〈无返回值〉 对象．全部删除 （）


IGRParameters.IndexByName 方法

根据名称得序号 方法

根据参数的名称取得其顺序号，如果不存在与名称匹配的参数，则返回-1。参数的名称不区分字母的大小写。

调用格式： 〈整数型〉 对象．根据名称得序号 （文本型 名称）


IGRSections 概述

IGRSections 接口

公开报表主对象直接拥有节的集合对象。

有关此接口所有成员的列表，请参阅 IGRSections 成员。

IDispatch
IGRSections

说明

报表主对象直接拥有的节包括页眉，页脚，报表头，报表尾，所以在此集合对象中只能拥有以上四种类型的节。

请参见

IGRSections 成员 | IGRSection 接口


IGRSections.Count 属性

数目 属性

指示拥有报表节的个数。


IGRSections.Item 属性

获取项目 方法

根据列的顺序号或名称得到列的接口引用。

调用格式： 〈报表节〉 对象．获取项目 （通用型 顺序号或名称）特征

只读

说明

在读取时要传入一个通用型类型的参数，指定子对象的顺序号或名称，子对象的顺序号从一开始。


IGRSections.Add 方法

增加 方法

增加一个子对象并返回新增子对象的接口引用，如果子对象具有具体类型，则此方法有一个类型参数，通过此参数指定子对象的类型。

调用格式： 〈报表节〉 对象．增加 （报表节类型枚举 类型 ）

返回值:新增报表节对象的接口引用。

参数

类型:指定报表节的类型。


IGRSections.Remove 方法

删除 方法

根据子对象的顺序号或名称将子对象移除掉，在输入参数种指定要移除子对象的顺序号或名称。

调用格式： 〈无返回值〉 对象．删除 （通用型 顺序号或名称）参数


IGRSections.RemoveAll 方法

全部删除 方法

清除全部报表节。

调用格式： 〈无返回值〉 对象．全部删除 （）


IGRSections.IndexByName 方法

根据名称得序号 方法

根据报表节的名称取得其顺序号，如果不存在与名称匹配的报表节，则返回-1。参数的名称不区分字母的大小写。

调用格式： 〈整数型〉 对象．根据名称得序号 （文本型 名称）


GRAlignColumnStyle 枚举

对齐到列方式 枚举

指定用来对齐部件框到明细网格列方式。

成员名称 | 说明
两端对齐 | 对齐到列的左右两端，部件框宽度与列保持一致。
左对齐 | 对齐到列的左端。
右对齐 | 对齐到列的右端。


GRAnchorStyles 枚举

锚定方式枚举

指定部件框如何锚定到其容器的边缘。

成员名称 | 说明
下边 | 该部件框锚定到其容器的下边缘。
左边 | 该部件框锚定到其容器的左边缘。
右边 | 该部件框锚定到其容器的右边缘。
上边 | 该部件框锚定到其容器的上边缘。

说明

如果将部件框锚定到其容器的边缘，当调整该容器的大小时，该部件框与指定边缘间的距离保持不变。例如，如果将控件锚定到其容器的右边缘，则当调整该容器的大小时，该控件的右边缘与容器的右边缘之间的距离保持不变。可以将控件锚定到任何控件边缘的组合上。如果将控件锚定到其容器的相对边缘上（例如，锚定到顶部和底部），当调整容器的大小时，控件大小就会随之改变。


GRBackStyle 枚举

背景模式枚举

指定部件再显示时用来填充其所占区域背景的方式。

成员名称 | 说明
通常 | 部件框使用背景色填充他占据的矩形区域。
透明 | 部件框背景透明，允许任何背景图像或其他部件框透过自身显示。


GRBorderStyles 枚举

边框模式枚举

指定是否画部件框的上下左右边框线的组合方式。

成员名称 | 说明
画下 | 部件框或明细网格显示下边边框线。
画左 | 部件框或明细网格显示左边边框线。
画右 | 部件框或明细网格显示右边边框线。
画上 | 部件框或明细网格显示上边边框线。


GRCenterStyle 枚举

居中方式枚举

指定用来在容器中居中对齐部件框的方式。

成员名称 | 说明
水平垂直 | 部件框始终位于父容器水平与垂直方向的正中间
水平 | 部件框始终位于父容器水平方向的正中间。
无 | 部件框在父容器中不居中对齐。
垂直 | 部件框始终位于父容器垂直方向的正中间。

说明

可以在水平与垂直两个方向上设定部件框的居中对齐方式，如果设定水平方向上居中对齐，不论部件框父容器改变大小，还是部件框自身改变大小与位置，系统自动将部件框放置在父容器水平方向上的居中位置。在垂直方向上的居中对齐有类似行为。
注意：如果部件框设定了停靠（Dock）方式，则先以停靠方式自动调整部件框位置与大小，然后再应用居中对齐方式。


GRChartType 枚举

图表类型枚举

表示图表的类型。

成员名称 | 说明
柱图 | 柱图。
折线图 | 折线图。
饼图 | 饼图。


GRColumnPrintAdaptMethod 枚举

打印策略枚举

打印生成时，明细网格列对输出页面的适应方法。

成员名称 | 说明
丢弃 | 在打印输出时，超出页面输出范围的列内容将被忽略掉，即不输出显示。
缩放适应 | 在打印输出时，如果列的总宽度超出页面输出范围，与grcpamResizeToFit相同，反之按设计时宽度输出。
缩小适应 | 在打印输出时，根据列的宽度按比列将所有要输出的列的总宽度调整到页面输出区域的宽度。
横向分页 | 在打印输出时，超出页面输出范围的列内容将另起新页输出显示。
横向分页并重复锁定列 | 在打印输出时，超出页面输出范围的列内容将另起新页输出显示，且左边的固定列在每页中重复输出。
绕行 | 在打印输出时，超出页面输出范围的列内容将另起新行输出显示。

说明

在打印输出到纸张页面中，输出列的总宽度与页面的输出宽度（除掉左右页边距的宽度）很可能不一样，系统可以采用几种方法来处理列的输出。如采用调整列的宽度以适应输出区域的宽度，则系统根据每个列的设计宽度按比列调整其打印输出宽度，使所有打印输出列的打印输出总宽度与打印输出区域宽度保持一样；如果列的设计总宽度小于输出区域宽度，所有列的打印宽度将放大，反之则缩小。


GRControlType 枚举

部件框类型枚举

指定部件框的具体类型。

成员名称 | 说明
图表 | 图表。
字段框 | 字段框。
线段 | 线段。
综合文字框 | 综合文字框。
图像框 | 图像框。
文字RTF框 | RTF格式文字框
图形框 | 图形框。
静态文字框 | 静态文字框。
子报表 | 子报表。
统计框 | 统计框。
系统变量框 | 系统变量框。


GRDisplayCursor 枚举

显示光标枚举

指定查询显示报表时，可供使用的鼠标光标类型。

成员名称 | 说明
确定光标 | 肯定光标。
箭头光标 | 普通箭头光标。
默认光标 | 默认光标。
手指光标 | 手指光标。
方大镜光标 | 方大镜光标。
否定光标 | 否定光标。


GRDockStyle 枚举

停靠方式枚举

指定部件框停靠的位置和方式。

成员名称 | 说明
下边 | 该部件框的下边缘停靠在父容器的底部。
填充 | 部件框的各个边缘分别停靠在父容器的各个边缘，并且适当调整大小。
左边 | 该部件框的左边缘停靠在父容器的左边缘。
无 | 该部件框未停靠。
右边 | 该部件框的右边缘停靠在父容器的右边缘。
上边 | 该部件框的上边缘停靠在父容器的顶端。

说明

当部件框停靠到其容器的一条边缘时，调整容器的大小时，始终使部件框与那条边缘对齐。如果多个部件框停靠到一条边缘，那么这些部件框将按照它们的 Z 顺序并排出现，部件框在 Z 顺序中的位置越高，距离容器边缘就越远。

如果选择了 左边、右边、上边 或 下边，则调整部件框的指定边缘和相对边缘的尺寸至包含部件框的相应边缘的尺寸。如果选择了填充 ，则调整部件框的所有四条边以匹配包含部件框的边缘。


GRFieldType 枚举

字段类型枚举

指定字段对象的具体类型。

成员名称 | 说明
二进制 | 二进制字段。
逻辑 | 布尔字段。
货币 | 货币字段。
日期时间 | 日期时间字段。
浮点数 | 浮点数字段。
整数 | 整数字段。
字符 | 字符字段。


GRGrpKpTogetherStyle 枚举

分组保持同页方式枚举

指定分组头行与本分组项其他行在打印输出时聚集在相同页的方式。

成员名称 | 说明
全部 | 要求分组头行与本分组项的其他所有行尽量打印输出在相同页。
第一明细行 | 要求分组头行与本分组项的第一个明细记录行打印输出在相同页。
不应用 | 不要求分组头行与本分组项其他行打印输出聚集在相同页。


GRNewPageColumnStyle 枚举

换新页栏方式枚举

在打印生成明细网格的分组头时，指定是否强制产生新页列的方式。

成员名称 | 说明
节后 | 分组头在打印输出之后另起新页栏。后续内容输出在新页栏中。
节前 | 分组头在打印输出之前另起新页栏进行输出。
节前节后 | 分组头在打印输出之前与之后都另起新页栏。
不应用 | 分组头在任何时候都不另起新页栏。


GRNewPageStyle 枚举

换新页方式枚举

在打印生成报表节时，指定是否强制产生新页的方式。

成员名称 | 说明
节后 | 报表节在打印输出之后要求产生新页，保证本节之后的后续节在新页中输出。
节前 | 报表节在打印输出之前要求产生新页，保证本节在新页中输出。
节前节后 | 报表节在打印输出之前与之后要求产生新页。
不应用 | 报表节不强制产生新页。


GROCGroupHeaderVAlign 枚举

占列分组头对齐方式枚举

指定占列式分组头在整个分组列区域的垂直方向上对齐位置。

成员名称 | 说明
下端 | 占列式分组头显示在整个分组列区域的底部。
居中 | 占列式分组头显示在整个分组列区域的中部（垂直方向）。
上端 | 占列式分组头显示在整个分组列区域的顶部。


GRPageColumnDirection 枚举

页栏显示方向枚举

在明细网格打印生成时，如果生成多栏报表，指定明细网格的各种行的在各页栏中的输出次序。

成员名称 | 说明
左到右上到下 | 按从左到右，再从上到下的顺序在页栏中打印输出。
上到下左到右 | 按从上到下，再从左到右的顺序在页栏中打印输出。


GRPaperOrientation 枚举

纸张方向枚举

指定生成打印页面时在纸张中的输出方向。

成员名称 | 说明
横向 | 纸张输出方向为横向。
纵向 | 纸张输出方向为纵向。


GRPaperSourceKind 枚举

纸张来源枚举

指定打印机的各种纸张来源方式。

成员名称 | 说明
自动选择 | 自动送入的纸张。
磁带纸盒 | 卡式纸盒。
自定义纸盒 | 打印机特定的纸张来源。
信封纸盒 | 信封。
格式源纸盒 | 打印机的默认送纸盒。
大容量纸盒 | 打印机的大容量纸盒。
大号纸盒 | 大纸。
下部纸盒 | 打印机的下层纸盒。
手动送纸器 | 以手动方式送入的纸张。
手动信封送纸器 | 以手动方式送入的信封。
中部纸盒 | 打印机的中层纸盒。
小号纸盒 | 小纸。
跟踪送纸器 | 牵引器送纸。
上部纸盒 | 打印机的上层纸盒（如果打印机只有一个纸盒，那么这个纸盒就是上层纸盒）。

请参见


GRParameterDataType 枚举

参数数据类型枚举

指示参数对象值的具体数据类型。

成员名称 | 说明
逻辑 | 布尔类型，可以真值与假值的显示文字。
日期时间 | 日期时间类型，可以设定格式化串。
浮点数 | 浮点数类型，可以设定格式化串。
整数 | 整数类型，可以设定格式化串。
字符串 | 字符串类型，可以为任意长度。


GRPenStyle 枚举

画笔样式枚举

画线条时，指定画线笔的类型。

成员名称 | 说明
不应用 | 不画线。
段线 | 画段虚线。
点划线 | 画点段虚线。
双点划线 | 画双点段虚线。
虚线 | 画点虚线。
凹框线 | 画内框线。
实线 | 画实线。


GRPictureAlignment 枚举

图像对齐方式枚举

指定图像框中图像显示的对齐方式。

成员名称 | 说明
左下角 | 图像的左下角紧靠图像框的左下角显示。
右下角 | 图像的右下角紧靠图像框的右下角显示。
居中 | 图像居中显示在图像框中。
左上角 | 图像的左上角紧靠图像框的左上角显示。
右上角 | 图像的右上角紧靠图像框的右上角显示。

请参见


GRPictureSizeMode 枚举

图像缩放方式枚举

指定图像框中图像的显示缩放方式。

成员名称 | 说明
剪裁 | 图像不进行缩放，按原始尺寸显示。
完整显示 | 如果图像不能在图像框中完全显示，根据图像框的大小图像保持宽高比例伸缩至某一方向完全铺满。反之图像保持原始尺寸显示。
伸缩铺满 | 图像伸缩到完全显示到图像框中。
伸缩 | 根据图像框的大小图像保持宽高比例伸缩至某一方向完全铺满。


GRPrintGenerateStyle 枚举

打印生成方式枚举

指示打印页面的生成方式。

成员名称 | 说明
全部 | 生成报表所有数据。
套打 | 只生成报表内容数据。
表单 | 只生成报表表单数据。

说明

打印生成时，如果指定打印生成方式为只输出报表内容数据（套打）,则只输出打印类别为报表内容数据的报表元素，其它打印类别为报表表单数据的报表元素将不会输出。在只输出报表内容数据时，报表节的背景色不会填充，明细网格的边框线与行列线也不会输出。在只输出报表内容数据的打印生成方式特别适用于进行票据套打与现存格式报表的套打。

打印生成时，如果指定印生成方式为输出报表表单数据（表单）,生成方式与只输出报表内容数据（套打）反之对应。在此种方式下，明细网格的记录数据不会被应用，明细行的生成与明细记录不对应，不填充明细记录页也可以输出报表表单数据。报表表单数据一般只生成一页。此种模式一般用来制作票据与固定格式报表的印刷模版。

打印生成时，如果指定印生成方式为输出全部数据（全部）,则所有数据都会输出，这也是我们平时最多用到的方式。

使用打印页面的生成方式的地方有： 在报表接口中执行打印扩展()与打印预览()方法中可以指定打印页面的生成方式，另可以设定打印预览查看器的打印页面的生成方式（生成方式 ）属性。


GRPrintPageType 枚举

打印页面类型枚举

指定打印时输出页的类型。

成员名称 | 说明
全部选择页 | 输出选定页范围内的所有页。
偶数选择页 | 输出选定页范围内的偶数页。
奇数选择页 | 输出选定页范围内的奇数页。

请参见


GRPrintRangeType 枚举

打印范围类型枚举

指定打印时选定页范围的类型。

成员名称 | 说明
全部页 | 选定全部页。
当前页 | 选定当前页，只有在从打印御览状态中执行打印任务时才有效。
选定页 | 指定的页范围。

请参见


GRPrintType 枚举

打印类型枚举

指定报表元素的打印类别。

成员名称 | 说明
套打内容 | 表单内容数据，在套打输出内容时输出。
表单 | 表单固定数据，在套打输出内容时不输出。

说明

包括两种打印类别：报表表单数据（表单），报表内容数据（套打）。

打印生成时，如果指定打印生成方式（打印生成方式）为只输出报表内容数据（套打）,则只输出打印类别为报表内容数据的报表元素，其它打印类别为报表表单数据的报表元素将不会输出。在只输出报表内容数据时，报表节的背景色不会填充，明细网格的边框线与行列线也不会输出。在只输出报表内容数据的打印生成方式特别适用于进行票据套打与现存格式报表的套打。

打印生成时，如果指定印生成方式（打印生成方式）为输出报表表单数据（表单）,生成方式与只输出报表内容数据（套打）反之对应。在此种方式下，明细网格的记录数据不会应用到，明细行的生成与明细记录不对应，不填充明细记录页可以输出报表表单数据。报表表单数据一般只生成一页，用来制作票据与固定格式报表的印刷模版。

打印生成时，如果指定打印生成方式（打印生成方式）为输出全部数据（全部）,则所有数据都会输出，这也是我们平时最多用到的方式。

可以指定打印类别的报表元素包括部件框，明细网格标题格，明细网格内容格。


GRRepeatStyle 枚举

重复方式枚举

指定明细网格标题的重复输出方式。

成员名称 | 说明
不应用 | 明细网格标题不重复输出。
分组头 | 明细网格标题在每个分组投行之后重复输出。
页 | 明细网格标题在每页重复输出。
页栏 | 明细网格标题在每个页栏重复输出。

说明

如果为不重复输出方式，则只在明细网格打印生成的开始时输出一次标题。如果为每页重复方式或每页列重复方式,则在明细网格打印生成的开始时与产生新页或新页列时输出标题。如果为在分组头上重复方式，则在明细网格打印生成的开始时不输出报表头，而是在每个分组头输出后输出标题。


GRReportDisplayMode 枚举

报表显示模式枚举

指定报表的输出显示模式。

成员名称 | 说明
空闲 | 报表不处于任何生成显示过程中。
打印页面生成 | 报表处于打印页面生成过程中。
查询显示 | 正在查询显示器中报表处于自画过程中。


GRShapeType 枚举

图形类型枚举

指定图形部件框的具体类型。

成员名称 | 说明
圆 | 圆。
椭圆 | 椭圆。
直线 | 直线。
矩形 | 矩形。
圆角矩形 | 圆角矩形。
圆角正方形 | 圆角正方形。
正方形 | 正方形。


GRSharePrintSetupOption 枚举

共享打印参数枚举

指定各个共享全局打印参数的项目。

成员名称 | 说明
纸张型号 | 纸张类型项目，对应纸张类型与大小属性。
页面边距 | 页边距项目，对应上、下、左，右页边距属性。
纸张方向 | 纸张的打印方向项目。
纸张来源 | 纸张的进纸来源项目。
选择打印机 | 当前选定的打印机项目，对应打印机名称属性。


GRSummaryFunction 枚举

统计函数 枚举

指定统计部件框应用的统计函数。

成员名称 | 说明
平均 | 统计某个字段的平均值。
数目 | 统计明细记录的个数。
最大值 | 找出某个字段的最大值。
最小值 | 找出某个字段的最小值。
合计 | 统计某个字段的合计值。


GRSystemImage 枚举

系统图像枚举

指定报表引擎中的系统内建图像。

成员名称 | 说明
选中3D | 值为-3，3D形式的选中标志。
未选中3D | 值为-4，3D形式的非选中标志。
肯定 | 值为-5，肯定标志。
向下箭头 | 值为-7，朝下箭头标志。
向上箭头 | 值为-8，朝上箭头标志。
选中 | 值为-1，选中标志。
否定 | 值为-6，否定标志。
未选中 | 值为-2，非选中标志。

说明

Grid++Report 在报表引擎中定义了一些系统内建图像。图片框可以将其图像序号指定为某个枚举项的值来关联某个系统图像，从而在图像框中显示系统图像。另也可以调用 图像框接口的 链接系统图像() 方法来关联系统图像。


GRSystemVarType 枚举

系统变量枚举

指定系统变量部件框应用的系统变量类型。

成员名称 | 说明
当前日期时间 | 计算机的当前日期时间。
一级分组行号 | 一级分组的当前分组项的序号，从1开始计数。
二级分组行号 | 二级分组的当前分组项的序号，从1开始计数。
三级分组行号 | 三级分组的当前分组项的序号，从1开始计数。
总页数 | 总页数。
当前页号 | 当前页号。
记录号 | 明细记录的当前记录号，从1开始计数。
行号 | 明细网格的当前行号，从1开始计数。


GRTextAlign 枚举

文字对齐方式枚举

指定文字在显示区域的输出对齐方式。

成员名称 | 说明
下中 | 内容在垂直方向上底边对齐，在水平方向上居中对齐。
下左 | 内容在垂直方向上底边对齐，在水平方向上左边对齐。
下右 | 内容在垂直方向上底边对齐，在水平方向上右边对齐。
中中 | 内容在垂直方向上中间对齐，在水平方向上居中对齐。
中左 | 内容在垂直方向上中间对齐，在水平方向上左边对齐。
中右 | 内容在垂直方向上中间对齐，在水平方向上右边对齐。
上中 | 内容在垂直方向上顶部对齐，在水平方向上居中对齐。
上左 | 内容在垂直方向上顶部对齐，在水平方向上左边对齐。
上右 | 内容在垂直方向上顶部对齐，在水平方向上右边对齐。

说明

使用文字对齐的报表元素包括：各种文字显示部件，非自由格的明细网格标题格与内容格。


GRTextOrientation 枚举

文字方向枚举

指定综合文字框的各种文字行向。

成员名称 | 说明
从下至上从左至右1 | 按从下到上，从左到右方式显示文字，文字旋转。
默认 | 默认方式，按从左到右，从上到下方式显示文字。
从上至下从左至右0 | 按从上到下，从左到右方式显示文字，文字不旋转。
从上至下从右至左0 | 按从上到下，从右到左方式显示文字，文字不旋转。
从上至下从右至左1 | 按从上到下，从右到左方式显示文字，文字旋转。

请参见


GRUnit 枚举

单位枚举

指定表示报表元素大小与位置的计量单位。

成员名称 | 说明
厘米 | 以厘米为单位表示报表部件的尺寸与位置。
单位 | 以英寸为单位表示报表部件的尺寸与位置。


IGRDisplayViewer.AlwaysShowHScrollBar 属性

总是显示水平滚动条 属性

是否始终显示明细表格的水平滚动条的标志。

语法： 对象.总是显示水平滚动条 = 逻辑型
默认值:假

特征

可读写

设计器中可见


IGRDisplayViewer.AlwaysShowVScrollBar 属性

总是显示垂直滚动条 属性

是否始终显示明细网格的垂直滚动条。

语法： 对象.总是垂直水平滚动条 = 逻辑型

默认值:假

特征

可读写

设计器中可见


IGRDisplayViewer.BackgroundColor 属性

空白背景色 属性

当明细网格不能完整充满查询显示器的显示区域时，指定明细网格外围的空白区域的背景填充色。

语法： 对象.空白背景色 = 整数型

默认值

特征

可读写

设计器中可见


IGRDisplayViewer.BorderStyle 属性

边框模式 属性

指定查询显示器的边框样式。

语法： 对象.边框模式 = 整数型

特征

可读写


IGRDisplayViewer.BottomGap 属性

下边距 属性

下边留出的空白间距，以像素为单位。

语法： 对象.下边距 = 整数型

默认值

0

特征

可读写


IGRDisplayViewer.ColumnMove 属性

列可移动 属性

指定是否可以用鼠标拖放改变明细网格列的显示顺序。

语法： 对象.列可移动 = 逻辑型

默认值:真

特征

可读写

设计器中可见


IGRDisplayViewer.ColumnResize 属性

列宽可调整 属性

指定是否可以通过鼠标拖放改变明细网格列的显示宽度。

语法： 对象.列宽可调整 = 逻辑型

默认值:真

特征

可读写

设计器中可见


IGRDisplayViewer.GridTitle3D 属性

网格标题3D 属性

指定是否将明细网格的列标题显示为3D形状。

语法： 对象.列宽可调整 = 逻辑型

默认值:假

特征

可读写

设计器中可见


IGRDisplayViewer.HScrollPos 属性

垂直滚动条位置 属性

在运行时，获取与设置水平滚动条的位置。

语法： 对象.左边 = 整数型

特征

可读写

仅运行时可用


IGRDisplayViewer.LeftGap 属性

左边距 属性

左边留出的空白间距，以像素为单位。

语法： 对象.左边距 = 整数型

默认值

0

特征

可读写


IGRDisplayViewer.Resortable 属性

可重排序 属性

指定是否可以通过点击明细网格的列标题对明细记录进行重新排序。

语法： 对象.可重排序 = 逻辑型

默认值:假

特征

可读写

设计器中可见


IGRDisplayViewer.ResortCaseSensitive 属性

重排序区分大小写 属性

指定点击列标题进行排序时，对字符进行排序比较是否大小写敏感。

语法:对象.重排序区分大小写=逻辑型

默认值:假

特征

可读写

设计器中可见


IGRDisplayViewer.ResortDefaultAsc 属性

重排序按升序 属性

当点击列标题进行排序时，首先是否按升序进行排序。

语法:对象.重排序按升序=逻辑型

默认值:真

特征

可读写

设计器中可见


IGRDisplayViewer.RightGap 属性

右边距 属性

右边留出的空白间距，以像素为单位。

语法:对象.右边距=整数型

默认值

0

特征

可读写


IGRDisplayViewer.RowCount 属性

行数 属性

运行时，当前查看报表的总行数。

语法:对象.行数=整数型

特征

可读写

仅运行时可用

说明

每个记录对应的显示行为一行，每个显示的分组头算一行，每个显示的分组尾算一行，总行数为以上三种数据的合计。


IGRDisplayViewer.RowSelection 属性

整行选中 属性

指定在查询显示报表时是否整行选中内容行。如果不是，选中仅为一个格。

语法:对象.整行选中=逻辑型

默认值:真

特征

可读写

设计器中可见


IGRDisplayViewer.Running 属性

运行中 属性

指示查询显示器是否正在运行显示报表中。

语法:对象.运行中

特征

只读


IGRDisplayViewer.Searchable 属性

文字可查找 属性

指示是否提供默认的文字查找功能。

语法:对象.文字可查找=逻辑型

默认值

真

特征

可读写

设计器中可见

说明

如果本属性置为真，当查询显示器控件获得键盘输入焦点时，按下 Ctrl+F 键会弹出文字查找对话框，按下 F3 键会进行继续查找。


IGRDisplayViewer.SelColumnNo 属性

选中列号 属性

选中单元格的列序号。

语法:对象.选中列号=整数型

特征

可读写

仅运行时可用

说明

列序号从零开始计数。


IGRDisplayViewer.SelectionBackColor 属性

选中背景色 属性

查询显示时，选中格或行的背景填充色。

语法:对象.选中背景色=整数型

默认值

grclHighlight(高亮)

特征

可读写

设计器中可见


IGRDisplayViewer.SelectionFollowScroll 属性

选中跟随滚动 属性

指示选中格或行是否跟随表格的垂直滚动而滚动。

语法:对象.选中跟随滚动=逻辑型

默认值

假

特征

可读写

设计器中可见


IGRDisplayViewer.SelectionForeColor 属性

选中前景色 属性

查询显示时，选中格或行的前景色。

语法:对象.选中前景色=整数型

默认值

grclHighlightText

特征

可读写

设计器中可见


IGRDisplayViewer.SelRowNo 属性

选中行号 属性

选中单元格的行序号。

语法:对象.选中行号=整数型

特征

可读写

仅运行时可用

说明

行序号从零开始计数。


IGRDisplayViewer.ShowFooter 属性

显示报表尾 属性

是否显示报表尾的标志。

语法:对象.显示报表尾=逻辑型

默认值

真

特征

可读写


IGRDisplayViewer.ShowHeader 属性

显示报表头 属性

是否显示报表头的标志。

语法:对象.显示报表头=逻辑型

默认值

真

特征

可读写

请参见


IGRDisplayViewer.ShowPreviewLine 属性

显示页面分割线 属性

指示是否显示报表打印页面的垂直区域分隔线。

语法:对象.显示页面分割线=逻辑型

默认值

假

特征

可读写

说明

在报表查询显示中显示出页面分隔线，这样可以进行明确的列宽调整，以便得到适合的打印输出。


IGRDisplayViewer.SortColumnNo 属性

排序列号 属性

指定当前进行排序的列序号，如果没有按任何列进行排序，该属性值为-1。

语法:对象.排序列号=整数型

特征

可读写


IGRDisplayViewer.TopGap 属性

上边距 属性

上边留出的空白间距，以像素为单位。

语法:对象.上边距=整数型

默认值

0

特征

可读写


IGRDisplayViewer.VScrollPos 属性

垂直滚动条位置 属性

在运行时，获取与设置垂直滚动条的位置。

语法:对象.垂直滚动条位置=整数型

特征

可读写

仅运行时可用


IGRDisplayViewer.Report 属性

设置关联报表 方法

关联报表主对象的接口引用。

调用格式： 〈无返回值〉 对象．设置关联报表 （报表 属性值）

特征

可读写


IGRDisplayViewer.GetColumnVisible 方法

获取列的可见性 方法

取得指定列在查询显示器中的显示或隐藏状态。

调用格式： 〈逻辑型〉 对象．获取列的可见性 （文本型 列名称）

表示列是否显示，为真表示列在查询显示器中显示。

参数<1>的名称为“列名称”，类型为“文本型（text）”。


IGRDisplayViewer.GetContentCellFromPos 方法

根据位置取得内容格 方法

取得指定位置处的内容格对象的接口引用。

调用格式： 〈内容格〉 对象．根据位置取得内容格 （短整数型 X轴位置，整数型 Y轴位置）

返回值:如果在指定位置存在内容格，则返回此内容格的接口引用，否则返回NULL。

参数<1>的名称为“X轴位置”，类型为“短整数型（short）”。
参数<2>的名称为“Y轴位置”，类型为“短整数型（short）”。

说明

传入位置参数是指查询显示器的客户区位置。此方法一般在查询显示器的鼠标事件中使用，用于判断用户鼠标操作的区域，执行相应的任务去响应用户的鼠标操作。例如要求在用户双击内容格式，打开此内容格对应的当前行记录的数据录入界面。


IGRDisplayViewer.GetControlFromPos 方法

根据位置取得部件框 方法

取得指定位置处的部件框对象的接口引用。

调用格式： 〈部件框〉 对象．根据位置取得部件框 （短整数型 X轴位置，短整数型 Y轴位置）

返回值:如果在指定位置存在部件框，则返回此部件框的接口引用，否则返回NULL。

参数<1>的名称为“X轴位置”，类型为“短整数型（short）,水平方向的坐标位置”。
参数<2>的名称为“Y轴位置”，类型为“短整数型（short）,垂直方向的坐标位置。

说明

传入位置参数是指查询显示器的客户区位置。


IGRDisplayViewer.GetSectionFromPos 方法

根据位置取得报表节 方法

取得指定位置处的报表节对象的接口引用。

调用格式： 〈报表节〉 对象．根据位置取得报表节 （短整数型 X轴位置，短整数型 Y轴位置）

返回值:如果在指定位置存在报表节，则返回此报表节的接口引用，否则返回NULL。

参数<1>的名称为“X轴位置”，类型为“短整数型（short）,水平方向的坐标位置”。
参数<2>的名称为“Y轴位置”，类型为“短整数型（short）,垂直方向的坐标位置。

说明

传入位置参数是指查询显示器的客户区位置。


IGRDisplayViewer.GetTitleCellFromPos 方法

根据位置取得标题格 方法

取得指定位置处的标题格对象的接口引用。

调用格式： 〈标题格〉 对象．根据位置取得标题格 （短整数型 X轴位置，短整数型 Y轴位置）

返回值:如果在指定位置存在标题格，则返回此标题格的接口引用，否则返回NULL。

参数<1>的名称为“X轴位置”，类型为“短整数型（short）,水平方向的坐标位置”。
参数<2>的名称为“Y轴位置”，类型为“短整数型（short）,垂直方向的坐标位置。

说明

传入位置参数是指查询显示器的客户区位置。


IGRDisplayViewer.LockUpdate 方法

更新锁定 方法

锁定控件的显示更新。

调用格式： 〈无返回值〉 对象．更新锁定 （）


IGRDisplayViewer.PostColumnLayout 方法

保存当前列排列 方法

将报表列的当前显示顺序与宽度信息提交到关联报表主对象中去。

调用格式： 〈无返回值〉 对象．保存当前列排列 （）

说明

在报表查询显示时，通过鼠标拖放可以改变列的显示顺序与宽度，调用 保存当前列排列 方法可以将列在查询显示器中的显示状态保存到报表主对象中。
例如：如果在查询显示之后进行打印，列在查询显示器已经改变顺序与宽度，要求打印要反映列显示的状态，调用此方法就可以达到此目的。


IGRDisplayViewer.Refresh 方法

刷新 方法

刷新数据，报表重新生成。

调用格式： 〈无返回值〉 对象．刷新 （）

说明

调用此方法后，报表将重新生成，报表生成过程中触发的事件将再次触发。


IGRDisplayViewer.Search 方法

查找文字 方法

执行查找报表文字任务，被匹配的文字将被高亮显示。

调用格式： 〈逻辑型〉 对象．查找文字 （文本型 待查找文本，逻辑型 是否区分大小写，逻辑型 全字匹配，逻辑型 向上查找，逻辑型 从当前选中位置查找，逻辑型 是否显示查找对话框，逻辑型 显示信息）

返回值:指示查找是否成功匹配。

参数<1>的名称为“待查找文本”，类型为“文本型（text）”,指定要查找的文字。
参数<2>的名称为“是否区分大小写”，类型为“逻辑型（bool）”,指定文字匹配时是否区分大小写。
参数<3>的名称为“全字匹配”，类型为“逻辑型（bool）”,指定是否要求全字匹配。
参数<4>的名称为“向上查找”，类型为“逻辑型（bool）”,指定是否按向上的方向进行查找。

参数<5>的名称为“从当前选中位置查找”，类型为“逻辑型（bool）”,指定是否从当前选中位置进行查找，如果不是：向下查找从首行开始，向上查找从最后一行开始。
参数<6>的名称为“是否显示查找对话框”，类型为“逻辑型（bool）”,

指定在执行查找任务之前，是否显示查找对话框。

参数<7>的名称为“显示信息”，类型为“逻辑型（bool）”。


IGRDisplayViewer.SetColumnVisible 方法

设置列可见性 方法

设置指定列在查询显示器中的显示或隐藏状态。

调用格式： 〈无返回值〉 对象．设置列可见性 （文本型 列名称，逻辑型 可见性）

参数<1>的名称为“列名称”，类型为“文本型（text）”,指定操作列的名称。

参数<2>的名称为“可见性”，类型为“逻辑型（bool）”,指定是否显示列。

说明

在改变列的显示状态全部完成之后，应调用 更新显示 方法更新显示。


IGRDisplayViewer.Start 方法

启动 方法

开始报表生成与查询显示。

调用格式： 〈无返回值〉 对象．启动 （）

说明

执行此方法后，报表生成过程中的相关事件将被触发。


IGRDisplayViewer.Stop 方法

停止 方法

完成报表的查询显示输出。

调用格式： 〈无返回值〉 对象．停止 （）

说明

执行本方法后，查询显示输出所占用的资源将被释放掉。


IGRDisplayViewer.UnlockUpdate 方法

更新解锁 方法

解锁控件的显示更新。

调用格式： 〈无返回值〉 对象．更新解锁 （）


IGRDisplayViewer.UpdateView 方法

更新列视图 方法

当改变列的显示状态之后，调用本方法更新列的显示。

调用格式： 〈无返回值〉 对象．更新列视图 （）

说明

本方法不会使报表重新生成，只是根据列的显示状态更新明细网格的显示。在调用 设置列可见性 方法之后应调用本方法更新显示。


IGRDisplayViewer.UpdateControl 方法

更新部件框 方法

更新显示指定的部件框。

调用格式： 〈无返回值〉 对象．更新部件框 （部件框 待更新部件框）

参数: 待更新部件框,指定要更新显示的部件框对象的接口引用。

说明

只有当部件框在报表头与报表尾中时，才能调用本方法进行显示更新。在查询显示报表时，如果改变了部件框的数据，调用本方法反映最新的数据的显示。


IGRDisplayViewer.UpdateSelCell 方法

更新选中格 （） 方法

更新显示当前选中内容格。

调用格式： 〈无返回值〉 对象．更新选中格 （）

说明

在查询显示报表时，如果改变了当前选中内容格的数据，调用本方法反映最新的数据的显示。


IGRDisplayViewer.UpdateSelRow 方法

更新选中行 方法

更新显示当前选中内容行。

调用格式： 〈无返回值〉 对象．更新选中行 （）

说明

在查询显示报表时，如果改变了当前选中内容行的数据，调用本方法反映最新的数据的显示。


IGRDisplayViewer.Update 方法

更新显示 方法

更形显示整个查询显示器。

调用格式： 〈无返回值〉 对象．更新显示（）


IGRDisplayViewer.Click 事件

被单击事件 事件

当鼠标在查询显示器上进行了点击时触发。

语法:_查询显示器_被单击事件()


IGRDisplayViewer.ColumnLayoutChange 事件

列排列发生改变事件 事件

当列的显示宽度或顺序发生改变时触发。

语法:_查询显示器_列排列发生改变事件()


IGRDisplayViewer.ContentCellClick 事件

内容格被单击事件 事件

当鼠标点击在某个内容格上时触发。

语法:_查询显示器_内容格被单击事件(内容格)

参数:指示触发本事件的内容格对象接口引用。


IGRDisplayViewer.ContentCellDblClick 事件

内容格被双击事件 事件

当鼠标双击在某个内容格上时触发。

语法:_查询显示器_内容格被双击事件(内容格)

参数:指示触发本事件的内容格对象接口引用。


IGRDisplayViewer.ControlClick 事件

部件框被单击事件 事件

当鼠标点击在某个部件框上时触发。

语法:_查询显示器_部件框被单击事件(部件框)

参数:指示触发本事件的部件框对象接口引用。


IGRDisplayViewer.ControlDblClick 事件

部件框被双击事件 事件

当鼠标双击在某个部件框上时触发。

语法:_查询显示器_部件框被双击事件(部件框)

参数:指示触发本事件的部件框对象接口引用。


IGRDisplayViewer.DblClick 事件

被双击事件 事件

当鼠标在查询显示器上进行了双击时触发。

语法:_查询显示器_被双击事件()


IGRDisplayViewer.KeyDown 事件

按下某键 事件

当查询显示器拥有输入焦点时，某个键盘健按下时触发。

语法:_查询显示器_按下某键(Shift状态,键代码)

参数:切换状态, 指示切换键的状态。

键代码 指示按下健的虚键值。

说明

键事件按下列顺序发生：
按下某键
字符输入
放开某健


IGRDisplayViewer.KeyPress 事件

字符输入 事件

当查询显示器拥有输入焦点时，某个键盘健按下时触发。

语法:_查询显示器_字符输入(字符)

参数:字符, 指示按下健的对应字符。

说明

键事件按下列顺序发生：
按下某键
字符输入
放开某健


IGRDisplayViewer.KeyUp 事件

放开某键 事件

当查询显示器拥有输入焦点时，某个键盘健按下之后再释放时触发。

语法:_查询显示器_放开某键(Shift键状态,键代码)

参数:切换状态, 指示切换键的状态。

键代码 指示按下健的虚键值。

说明

键事件按下列顺序发生：
按下某键
字符输入
放开某健


IGRDisplayViewer.MouseDown 事件

鼠标键按下 事件

在查询显示器上鼠标按钮按下时触发。

语法:_查询显示器_鼠标键按下
 .参数 鼠标按钮, 鼠标按钮枚举
.参数 切换状态, 切换状态枚举
.参数 X轴位置, 短整数型
.参数 y轴位置, 短整数型

参数

鼠标按钮:指示操作的鼠标按钮。

Shift状态:指示切换键的状态。

X轴位置:鼠标光标的X位置，相对于查询显示器的客户区。

y轴位置:鼠标光标的Y位置，相对于查询显示器的客户区。


IGRDisplayViewer.MouseMove 事件

鼠标位置移动 事件

在查询显示器上鼠标光标移动时触发。

语法: _查询显示器_鼠标位置移动
.参数 切换状态, 切换状态枚举
.参数 x轴位置, 短整数型
.参数 y轴位置, 短整数型

参数

Shift状态:指示切换键的状态。

x轴位置:鼠标光标的X位置，相对于查询显示器的客户区。

y轴位置:鼠标光标的Y位置，相对于查询显示器的客户区。


IGRDisplayViewer.MouseUp 事件

鼠标键放开 事件

在查询显示器上鼠标按钮按下再释放时触发。

语法:_查询显示器_鼠标键放开
 .参数 鼠标按钮, 鼠标按钮枚举
.参数 切换状态, 切换状态枚举
.参数 X轴位置, 短整数型
.参数 y轴位置, 短整数型

参数

鼠标按钮:指示操作的鼠标按钮。

Shift状态:指示切换键的状态。

X轴位置:鼠标光标的X位置，相对于查询显示器的客户区。

y轴位置:鼠标光标的Y位置，相对于查询显示器的客户区。


IGRDisplayViewer.SectionClick 事件

报表节被单击事件 事件

当鼠标点击在某个节上时触发。

语法: _查询显示器_报表节被单击事件
.参数 报表节, 报表节

参数

指示触发本事件的节对象接口引用。


IGRDisplayViewer.SectionDblClick 事件

报表节被单双事件 事件

当鼠标双击在某个节上时触发。

语法: _查询显示器_报表节被双击事件
.参数 报表节, 报表节

参数

指示触发本事件的节对象接口引用。


IGRDisplayViewer.SelectionCellChange 事件

选中格改变事件 事件

当前显示的单元格发生改变时触发。

语法: _查询显示器_选中格改变事件
 .参数 旧列号, 整数型
.参数 旧行号, 整数型

参数

旧列号:指示原来选中列的序号。

旧行号:指示原来选中行的序号。


IGRDisplayViewer.TitleCellClick 事件

标题格被单击事件 事件

当鼠标点击在某个标题格上时触发。

.子程序 _查询显示器1_标题格被单击事件
.参数 标题格, 标题格

参数: 指示触发本事件的标题格对象的接口引用。


IGRDisplayViewer.TitleCellDblClick 事件

标题格被双击事件 事件

当鼠标点击在某个标题格上时触发。

.子程序 _查询显示器1_标题格被双击事件
.参数 标题格, 标题格

参数: 指示触发本事件的标题格对象的接口引用。


IGRPrintViewer.ColPages 属性

每列页数 属性

多页查看模式下，每行显示的页数。

语法:对象.每列页数=整数型

默认值

3

特征

可读写

设计器中可见


IGRPrintViewer.CurPageNo 属性

当前页号 属性

当前显示页的页号。页号从一开始计数。

语法:对象.当前页号=整数型

特征

可读写

仅运行时可用


IGRPrintViewer.GenerateStyle 属性

生成方式 属性

指定打印数据的生成方式。

语法:对象.生成方式=整数型(注:打印生成方式枚举值)

默认值:全部

特征

可读写

设计器中可见

请参见

打印生成方式枚举

指示打印页面的生成方式。

成员名称 | 说明
全部 | 生成报表所有数据。
套打 | 只生成报表内容数据。
表单 | 只生成报表表单数据。


IGRPrintViewer.PageCount 属性

页数 属性

报表的总页数。

语法:对象.页数

特征

只读

仅运行时可用


IGRPrintViewer.RowPages 属性

行页数 属性

多页查看模式下，每列显示的页数。

语法:对象.行页数=整数型

默认值

2

特征

可读写

设计器中可见


IGRPrintViewer.ShowMarginCorner 属性

显示边距角线 属性

指示是否显示页边距的拐角指示线。

语法:对象.显示边距角线=逻辑型

默认值 真

特征

可读写

设计器中可见


IGRPrintViewer.ShowRuler 属性

显示标尺 属性

是否显示标尺标志。

语法:对象.显示标尺=逻辑型

默认值 真

特征

可读写

设计器中可见


IGRPrintViewer.ShowToolbar 属性

显示工具栏 属性

是否显示工具条标志。

语法:对象.显示工具栏=逻辑型

默认值 真

特征

可读写

设计器中可见


IGRPrintViewer.ViewMode 属性

查看模式 属性

打印页面的查看模式。

语法:对象.查看模式=整数型(注:打印显示模式枚举值)

默认值

单页模式

特征

可读写

设计器中可见

打印显示模式枚举 枚举

在打印预览查看器中，指定查看模式。

成员名称 | 说明
多页模式 | 多页模式，在打印预览窗口中同时显示多页打印页面。
单页模式 | 单页模式，只在打印预览窗口中显示一页打印页面。


IGRPrintViewer.ZoomPercent 属性

显示百分比 属性

打印页面的查看显示百分比例。

语法:对象.显示百分比=整数型

默认值

100

特征

可读写

设计器中可见


IGRPrintViewer.AddToolbarControl 方法

增加工具按钮 方法

向工具栏中增加一个指定的操作界面元素。

调用格式： 〈无返回值〉 对象．增加工具按钮 （打印工具栏部件枚举 部件类型）

参数:部件类型,指定操作界面元素的类型

说明

在对工具栏中的操作界面元素调整完之后，应调用更新工具按钮 方法更新界面显示。


IGRPrintViewer.LoadFromDocumentFile 方法

加载报表文档 方法

载入指定的 Grid++Report 文档文件并在打印查看器中显示。

调用格式： 〈无返回值〉 对象．加载报表文档 （文本型 文件名）

参数:文件名,指定文件的路径与名称。


IGRPrintViewer.NextPage 方法

下一页 方法

显示下一页打印页面。

调用格式： 〈无返回值〉 对象．下一页 （）


IGRPrintViewer.Print 方法

打印 方法

打印出打印查看器生成的打印数据。

调用格式： 〈无返回值〉 对象．打印 （逻辑型 显示打印对话框）

参数:显示打印对话框, 指示是否显示打印对话框。


IGRPrintViewer.PriorPage 方法

前一页 方法

显示上一页打印页面。

调用格式： 〈无返回值〉 对象．前一页 （）


IGRPrintViewer.Refresh 方法

刷新 方法

重新生成打印数据，并更新显示。

调用格式： 〈无返回值〉 对象．刷新 （）

说明

调用此方法后，报表将重新生成，报表生成过程中触发的事件将再次触发，生成报表打印数据过程中触发的事件也将再次触发。


IGRPrintViewer.ResetToolbarContent 方法

清除全部工具按钮 方法

清除工具栏中的全部操作界面元素。

调用格式： 〈无返回值〉 对象．清除全部工具按钮 （）

说明

在对工具栏中的操作界面元素调整完之后，应调用 更新工具按钮 方法更新界面显示。


IGRPrintViewer.Start 方法

开始 方法

开始生成报表数据，生成打印数据，并将打印数据数据显示出来。

调用格式： 〈无返回值〉 对象．开始 （）

说明

执行此方法后，报表数据生成过程中的相关事件将被触发，打印数据生成过程中的相关事件将被触发。


IGRPrintViewer.Stop 方法

停止 方法

结束打印查看。

调用格式： 〈无返回值〉 对象．停止 （）

说明

执行本方法后，打印查看所占用的资源将被释放掉。


IGRPrintViewer.UpdateToolbar 方法

更新工具按钮 方法

更新工具栏的显示。

调用格式： 〈无返回值〉 对象．更新工具按钮 （）

说明

在对工具栏中的操作界面元素调整完之后，应调用本方法更新界面显示。


IGRPrintViewer.ZoomIn 方法

放大 方法

增大显示比例。

调用格式： 〈无返回值〉 对象．放大 （）

说明

注意：此方法只在单页查看模式下有效。


IGRPrintViewer.ZoomOut 方法

缩小 方法

缩小显示比例。

调用格式： 〈无返回值〉 对象．缩小 （）

说明

注意：此方法只在单页查看模式下有效。


IGRPrintViewer.ZoomToFit 方法

缩放到完整显示 方法

缩放页面显示比例到刚好在查看区域中完整显示出来。

调用格式： 〈无返回值〉 对象．缩放到完整显示 （）

说明

注意：此方法只在单页查看模式下有效。


IGRPrintViewer.ZoomToWidth 方法

缩放到宽度完整显示 方法

缩放页面显示比例到刚好使其宽度在查看区域中完整显示出来。

调用格式： 〈无返回值〉 对象．缩放到宽度完整显示 （）

说明

注意：此方法只在单页查看模式下有效。


IGRPrintViewer.ZoomToHeight 方法

缩放到高度完整显示 方法

缩放页面显示比例到刚好使其高度在查看区域中完整显示出来。

调用格式： 〈无返回值〉 对象．缩放到高度完整显示 （）

说明

注意：此方法只在单页查看模式下有效。


IGRPrintViewer.Report 属性

设置关联报表 方法

获取或设置关联报表主对象的接口引用。

调用格式： 〈无返回值〉 对象．设置关联报表 （报表 属性值）

特征

可写


获取关联报表

获取关联报表 方法

获取关联报表主对象的接口引用。

调用格式： 〈报表〉 对象．获取关联报表 （）

特征

可写

请参见


IGRPrintViewer.Click 事件

被单击事件 事件

当鼠标在打印显示器上进行了点击时触发。

语法:_打印显示器_被单击事件()


IGRPrintViewer.DblClick 事件

被双击事件 事件

当鼠标在打印显示器上进行了点击时触发。

语法:_打印显示器_被双击事件()


IGRPrintViewer.KeyDown 事件

按下某键 事件

当打印显示器拥有输入焦点时，某个键盘健按下时触发。

语法:_打印显示器_按下某键(切换状态,键代码)

参数:切换状态, 指示切换键的状态。

键代码 指示按下健的虚键值。

说明

键事件按下列顺序发生：
按下某键
字符输入
放开某健


IGRPrintViewer.KeyPress 事件

字符输入 事件

当打印显示器拥有输入焦点时，某个键盘健按下时触发。

语法:_打印显示器_字符输入(字符)

参数:字符, 指示按下健的对应字符。

说明

键事件按下列顺序发生：
按下某键
字符输入
放开某健


IGRPrintViewer.KeyUp 事件

放开某键 事件

当打印显示器拥有输入焦点时，某个键盘健按下之后再释放时触发。

语法:_打印显示器_放开某键(切换状态,键代码)

参数:切换状态, 指示切换键的状态。

键代码 指示按下健的虚键值。

说明

键事件按下列顺序发生：
按下某键
字符输入
放开某健


IGRPrintViewer.MouseDown 事件

鼠标键按下 事件

在打印显示器上鼠标按钮按下时触发。

语法:_打印显示器_鼠标键按下
 .参数 鼠标按钮, 鼠标按钮枚举
.参数 切换状态, 切换状态枚举
.参数 X轴位置, 短整数型
.参数 y轴位置, 短整数型

参数

鼠标按钮:指示操作的鼠标按钮。

Shift状态:指示切换键的状态。

X轴位置:鼠标光标的X位置，相对于查询显示器的客户区。

y轴位置:鼠标光标的Y位置，相对于查询显示器的客户区。


IGRPrintViewer.MouseUp 事件

鼠标键放开 事件

在打印显示器上鼠标按钮按下再释放时触发。

语法:_打印显示器_鼠标键放开
 .参数 鼠标按钮, 鼠标按钮枚举
.参数 切换状态 , 切换状态枚举
.参数 X轴位置, 短整数型
.参数 y轴位置, 短整数型

参数

鼠标按钮:指示操作的鼠标按钮。

Shift状态:指示切换键的状态。

X轴位置:鼠标光标的X位置，相对于查询显示器的客户区。

y轴位置:鼠标光标的Y位置，相对于查询显示器的客户区。


IGRPrintViewer.MouseMove 事件

鼠标位置移动 事件

在打印显示器上鼠标光标移动时触发。

语法: _打印显示器_鼠标位置移动
.参数 切换状态 , 切换状态枚举
.参数 x轴位置, 短整数型
.参数 y轴位置, 短整数型

参数

Shift状态:指示切换键的状态。

x轴位置:鼠标光标的X位置，相对于查询显示器的客户区。

y轴位置:鼠标光标的Y位置，相对于查询显示器的客户区。


IGRPrintViewer.StatusChange 事件

状态改变 事件

当打印查看器的状态信息改变时触发。

语法:_打印显示器_状态改变()

说明

当打印查看器的状态信息改变时触发。这里所指状态信息包括：
.当前显示页的页号
.页面查看模式
.多也查看模式下，行列显示页数
.显示比例
.标尺是否显示标志
.工具条是否显示标志


IGRPrintViewer.RulerClick 事件

标尺被单击事件 事件

当鼠标在标尺上点击时触发。

语法 _打印显示器_标尺被单击事件
.参数 是否为横向标尺, 逻辑型


IGRPrintViewer.RulerDblClick 事件

标尺被双击事件 事件

当鼠标在标尺上双击时触发。

语法 _打印显示器_标尺被双击事件
.参数 是否为横向标尺, 逻辑型


IGRPrintViewer.PageClick 事件

页被单击事件 事件

当鼠标在页面的显示区域上点击时触发。

语法:_打印显示器_页被单击事件()


IGRPrintViewer.PageDblClick 事件

页被双击事件 事件

当鼠标在页面的显示区域上双击时触发。

语法:_打印显示器_页被双击事件()


关闭按钮事件

当工具条中关闭按钮被点击时触发本事件.

语法:_打印显示器_关闭按钮事件()


GRMouseButton 枚举

鼠标按钮枚举

在鼠标事件中，指定鼠标按钮。

成员名称 | 说明
鼠标左按钮 | 鼠标左按钮。
鼠标中按钮 | 鼠标中按钮。
鼠标右按钮 | 鼠标右按钮。


GRPrintViewMode 枚举

打印显示模式枚举 枚举

在打印预览查看器中，指定查看模式。

成员名称 | 说明
多页模式 | 多页模式，在打印预览窗口中同时显示多页打印页面。
单页模式 | 单页模式，只在打印预览窗口中显示一页打印页面。


GRShiftStates 枚举

切换状态枚举 枚举

在鼠标与键盘事件中，指定事件触发时鼠标与键盘的状态。

成员名称 | 说明
Alt按下 | 指示键盘‘Alt’键按下标志。
Ctrl按下 | 指示键盘‘Ctrl’键按下标志。
鼠标双击 | 指示鼠标双击标志。
鼠标左按钮按下 | 指示鼠标左按钮按下标志。
鼠标中按钮按下 | 指示鼠标中按钮按下标志。
鼠标右按钮按下 | 指示鼠标右按钮按下标志。
Shift按下 | 指示键盘‘Shift’键按下标志。


GRViewerBorderStyle 枚举

显示器边框模式枚举

指定查询显示器与打印查看器的边框类型

成员名称 | 说明
三维边框 | 三维边框。
单行边框 | 单行边框。
无边框 | 无边框。


IGRDesigner.AsFormUI 属性

页面模式 属性

指示是否按页面模式显示报表布局窗口。

语法:对象.页面模式=逻辑型

默认值 假

特征

可读写

设计器中可见

说明

当本属性值为真时，按页面模式显示报表布局窗口；当本属性值为假时，按普通分节模式显示报表布局窗口。


IGRDesigner.AsNativeUI 属性

中文视图 属性

指示设计器是否显示为全中文界面

语法:对象.中文视图=逻辑型

默认值

真

特征

可读写


IGRDesigner.Dirty 属性

改写标志 属性

指示设计器中的数据是否已修改并未保存的标志。

语法:对象.改写标志=逻辑型

特征

只读

仅运行时可用


IGRDesigner.OnlyLayout 属性

只允许排列 属性

指示设计器只能进行改变位置大小的操作。

语法:对象.只允许排列=逻辑型

默认值

假
|
特征

可读写

说明

当将本属性设为真时，属性编辑窗口只能查看数据，而不能修改数据；在报表布局窗口中只能改变节、部件框、单元格的位置与大小；整个设计器不能新增报表元素，不能删除报表元素。


IGRDesigner.Options 属性

选项 属性

指定定制报表设计器的选项值。

语法:对象.选项=整数型

特征

可读写

设计器中可见

说明

选项值由选定控制项所对应的 设计器选项枚举 项目的值按位组合。

设计器选项枚举

表示定制报表设计器行为的选项。

成员名称 | 说明
可改变边距 | 指定是否可以调整页面边距。
可删除对象 | 指定是否可以删除对象。
可改变数据绑定参数 | 指定是否可以设置记录集的数据源连接串与查询SQL。
可弹出关联菜单 | 指定是否允许打开右键关联菜单。
可改变节高 | 指定是否可以调整节的高度。
显示网格列标尺 | 指定是否显示明细网格的列标尺。
显示网格工具栏 | 指定是否显示明细网格的工具条。
显示对象浏览器 | 指定是否显示对象浏览窗口。
显示属性编辑器 | 指定是否显示属性编辑窗口。
显示边距线 | 在报表进入页面视图时，指定是否显示边距分隔线。
显示标尺 | 指定是否显示标尺。
显示节线 | 在报表进入页面视图时，指定是否显示节分隔线。


IGRDesigner.Published 属性

公开属性类别 属性

指定要公开的属性类别组合值。

语法:对象.公开属性类别=整数型

特征

可读写

设计器中可见

说明

本属性值由选定属性类别项所对应的 属性类别枚举 项目的值按位组合。只有属于公开的属性类别的属性才会在属性编辑窗口中显示。

属性类别枚举

表示属性的类别。

成员名称 | 说明
行为 | 行为
外观 | 外观
数据 | 数据
设计 | 设计
布局 | 布局
杂项 | 杂项


IGRDesigner.ShowExplorer 属性

显示对象浏览器窗口 属性

是否显示对象浏览器窗口标志。

语法:对象.显示对象浏览器窗口=逻辑型

默认值

真

特征

可读写


IGRDesigner.ShowInspector 属性

显示属性编辑窗口 属性

是否显示属性编辑窗口标志。

语法:对象.显示属性编辑窗口=逻辑型

默认值

真

特征

可读写


IGRDesigner.WindowLayout 属性

窗口排列方式 属性

指示报表布局窗口在整个控件中的停靠位置。

语法:对象.窗口排列方式=整数型

默认值

停靠在左边

特征

可读写

设计器中可见

设计器窗口布局枚举

表示报表设计器的报表布局窗口在整个控件中的布局位置。

成员名称 | 说明
布局窗口在左边 | 停靠在左边。
布局窗口在右边 | 停靠在右边。


IGRDesigner.CancelInsertControl 方法

取消插入部件状态 方法

取消设计器插入部件框状态，使其回到平常操作状态。

调用格式： 〈无返回值〉 对象．取消插入部件状态 （）


IGRDesigner.DisableAllOptions 方法

禁止全部选项 方法

关闭所有的控制选项。

调用格式： 〈无返回值〉 对象．禁止全部选项 （）


IGRDesigner.DisableAllPublished 方法

禁止所有属性类别公开 方法

隐藏所有的属性类别。

调用格式： 〈无返回值〉 对象．禁止所有属性类别公开 （）


IGRDesigner.DoAction 方法

执行动作 方法

执行设计其的某个动作。

调用格式： 〈无返回值〉 对象．执行动作 （设计器动作枚举 动作）

参数

动作: 指定动作的类型。

说明

如果报表开发者要为用户提供运行时自定义的报表设计功能，使报表用户可以在运行时对报表进行修改设计。报表开发者需要使用一个报表设计器构件，然后提供一些外围操作界面，去通知报表设计器执行某些任务，此时就需要调用执行动作方法，去执行各种设计器动作。


IGRDesigner.EnableAllOptions 方法

开启全部选项 方法

开启所有的控制选项。

调用格式： 〈无返回值〉 对象．开启全部选项 （）


IGRDesigner.EnableAllPublished 方法

开启所有属性类别公开 方法

公开所有的属性类别。

调用格式： 〈无返回值〉 对象．开启所有属性类别公开 （）


IGRDesigner.GetOptionValue 方法

获取选项值 方法

获取指定的控制选项是否开启。

调用格式： 〈逻辑型〉 对象．获取选项值 （设计器选项枚举 选项）

返回值: 真 表示获控制选项是开启的，假 表示获控制选项是关闭的。

参数

选项:指定控制选项项目。


IGRDesigner.GetPublishedValue 方法

获取属性类别公开状态 方法

获取指定的属性类别是否为公开状态。

调用格式： 〈逻辑型〉 对象．获取属性类别公开状态 （属性类别枚举 属性类别）

返回值: 真 表示获控制选项是开启的，假 表示获控制选项是关闭的。

参数

属性类别: 指定属性类别。


IGRDesigner.IsActionEnabled 方法

获取动作使能状态 方法

判断某个动作在此时是否可以执行。

调用格式： 〈逻辑型〉 对象．获取动作使能状态 （设计器动作枚举 动作）

返回值:如果动作可以执行，则返回真，否则返回假。

参数

动作:指定某个动作。

说明

在实现自定义的报表设计器时，通过调用本方法去设定外围操作界面的使能状态。


IGRDesigner.Post 方法

提交 方法

将设计器中的当前报表模板数据提交到关联的报表主对象中去。

调用格式： 〈无返回值〉 对象．提交 （）

说明

设计器完成设计任务之后，需要将设计结果提交，调用提交方法将数据提交到报表主对象，如果还需要将数据永久保存起来，则调用报表主对象的保存到文件方法将数据保存到报表模板文件。


IGRDesigner.PrepareInsertControl 方法

进入插入部件框状态 方法

使设计器进入插入部件框状态，在参数中指定部件框的类型。

调用格式： 〈无返回值〉 对象．进入插入部件框状态 （短整数型 部件框类型）

参数

部件框类型:指定准备插入部件框的类型。

说明

设计器进入部件框状态之后，当在设计器中某个部件框容器的区域上用鼠标进行点击或拖放，一个新的部件框将插入到鼠标操作的位置，部件框容器如不能接受要插入的部件框，操作将失败。在插入部件框状态，不论进行任何操作，都将使设计器回到平常操作状态。


IGRDesigner.Reload 方法

重新载入 方法

从关联的报表主对象中重新载入模板数据。

调用格式： 〈无返回值〉 对象．重新载入 （）


IGRDesigner.SetOptionValue 方法

设置选项值 方法

设置开启或关闭指定的控制选项。

调用格式： 〈无返回值〉 对象．设置选项值 （设计器选项枚举 选项，逻辑型 值）

参数

选项:指定控制选项。

值:指定开启或关闭的标志。


IGRDesigner.SetPublishedValue 方法

设置属性类别公开状态 方法

设置公开或隐藏指定的属性类别。

调用格式： 〈无返回值〉 对象．设置属性类别公开状态 （属性类别枚举 属性类别，逻辑型 新值）

参数

属性类别:指定属性类别。

新值:是否公开标志。

属性类别枚举

表示属性的类别。

成员名称 | 说明
行为 | 行为
外观 | 外观
数据 | 数据
设计 | 设计
布局 | 布局
杂项 | 杂项


IGRDesigner.Report 属性

设置关联报表 方法

关联报表主对象的接口引用。设计器将显示关联报表主对象的数据。

调用格式： 〈无返回值〉 对象．设置关联报表 （对象 属性值）

特征

可读写


获取关联报表

获取关联报表方法

获取关联报表主对象的接口引用.

调用格式： 〈对象〉 对象．获取关联报表 （）


IGRDesigner.LayoutPanelContextMenu 事件

报表布局窗口右键菜单 事件

 当在报表布局窗口中执行打开关联弹出式菜单时触发本事件。

语法:_报表设计器_报表布局窗口右键菜单事件()


IGRDesigner.InspectorContextMenu 事件

属性编辑窗口右键菜单 事件

当在属性编辑窗口中执行打开关联弹出式菜单时触发本事件。

语法:_报表设计器1_属性编辑窗口右键菜单事件()


IGRDesigner.ExplorerContextMenu 事件

报表布局窗口右键菜单 事件

当在对象浏览窗口中执行打开关联弹出式菜单时触发本事件。

语法:_报表设计器1_报表布局窗口右键菜单事件()


GRDesignerAction 枚举

设计器动作枚举

指定执行报表设计器动作的类型。

成员名称 | 说明
自动生成列 | 根据记录集的字段定义，自动生成列的定义。如果已经处在列，已存在的列将被删除。
自动生成字段 | 根据记录集数据源取数设置自动生成取数定义。
自动调整文字框大小 | 根据文字框地显示文本自动调整框的大小，使文本刚好完整显示出来。
复制 | 复制操作。
剪切 | 剪切操作。
删除 | 删除当前选中的报表元素。
粘贴 | 粘贴操作。
重复 | 重复操作。
全选 | 全选操作，根据当前的选中对象，执行相应全部选中对象任务。
撤销 | 恢复操作。
对齐到底端 | 使选中的多个部件框底端对齐。
对齐到水平居中 | 使选中的多个部件框水平居中对齐。
对齐到左端 | 使选中的多个部件框左端对齐。
对齐到垂直居中 | 使选中的多个部件框垂直居中对齐。
对齐到右端 | 使选中的多个部件框右端对齐。
对齐到栅格 | 使选中的部件框左上角对齐到设计格点。
对齐到顶端 | 使选中的多个部件框上端对齐。
置显示顺序到前端 | 将选中部件框的 Z 顺序置于最上层。
置显示顺序到后端 | 将选中部件框的 Z 顺序置于最下层。
调整到大小相同 | 使选中的多个部件框大小相同。
调整到高度相同 | 使选中的多个部件框高度相同。
调整到宽度相同 | 使选中的多个部件框宽度相同。
调整到栅格点 | 使选中的部件框四角伸缩到最近设计格点。
减小水平间距 | 使选中的多个部件框水平间距减小。
减小垂直间距 | 使选中的多个部件框垂直间距减小。
水平间距相等 | 使选中的多个部件框水平间距相等。
垂直间距相等 | 使选中的多个部件框垂直间距相等。
水平间距增大 | 使选中的多个部件框水平间距增大。
垂直间距增大 | 使选中的多个部件框垂直间距增大。
清除水平间距 | 去除选中的多个部件框的水平间距。
清除垂直间距 | 去除选中的多个部件框的垂直间距。
增加列 | 插入列。
增加明细网格 | 插入明细网格。
增加字段 | 插入字段。
增加分组 | 插入一个分组。
增加页脚 | 插入页脚。
增加页眉 | 插入页眉。
增加参数 | 插入参数。
增加报表尾 | 插入一个报表尾。
增加报表头 | 插入一个报表头。
打开列集合对话框 | 打开列集合对话框。
打开列排列对话框 | 打开列标题布局对话框。
打开字段集合对话框 | 打开字段集合对话框。
打开分组集合对话框 | 打开分组集合对话框。
打开页面设置对话框 | 打开页面设置对话框。
打开参数集合对话框 | 打开参数集合对话框。
模拟查询显示 | 在设计器中执行模拟查询显示。
模拟打印预览 | 在设计器中执行模拟打印预览。
报表节后移 | 将当前选中报表头或报标尾的显示顺序后移。
报表节前移 | 将当前选中报表头或报标尾的显示顺序前移。
打开数据绑定对话框 | 打开记录集数据源取数设置对话框。

说明

在报表设计器接口执行动作与获取动作使能状态方法中，指定动作的类型。


GRDesignerOption 枚举

设计器选项枚举

表示定制报表设计器行为的选项。

成员名称 | 说明
可改变边距 | 指定是否可以调整页面边距。
可删除对象 | 指定是否可以删除对象。
可改变数据绑定参数 | 指定是否可以设置记录集的数据源连接串与查询SQL。
可弹出关联菜单 | 指定是否允许打开右键关联菜单。
可改变节高 | 指定是否可以调整节的高度。
显示网格列标尺 | 指定是否显示明细网格的列标尺。
显示网格工具栏 | 指定是否显示明细网格的工具条。
显示对象浏览器 | 指定是否显示对象浏览窗口。
显示属性编辑器 | 指定是否显示属性编辑窗口。
显示边距线 | 在报表进入页面视图时，指定是否显示边距分隔线。
显示标尺 | 指定是否显示标尺。
显示节线 | 在报表进入页面视图时，指定是否显示节分隔线。


GRDesignerWindowLayout 枚举

设计器窗口布局枚举

表示报表设计器的报表布局窗口在整个控件中的布局位置。

成员名称 | 说明
布局窗口在左边 | 停靠在左边。
布局窗口在右边 | 停靠在右边。


GRPropertyCategory 枚举

属性类别枚举

表示属性的类别。

成员名称 | 说明
行为 | 行为
外观 | 外观
数据 | 数据
设计 | 设计
布局 | 布局
杂项 | 杂项


IGRExportOption 概述

导出基选项 接口

数据导出选项的基类。

有关此接口所有成员的列表，本类以下子类拥有本类全部方法:


IGRExportOption.ExportType 属性

导出类型 属性

获取本导出文件选项对象的具体类型。

语法:对象.导出类型=整数型(注:导出类型枚举值)

特征

只读

参见

导出类型枚举

指定数据导出的类型。

成员名称 | 说明
导出CSV | 导出CSV格式文件。
导出Html | 导出Html超文本文件。
导出PDF | 导出PDF格式文件。
导出TXT | 导出文本文件。
导出XLS | 导出Excel文件。


IGRExportOption.FileName 属性

文件名 属性

指定导出文件的完整路径与文件名称。

语法:对象.文件名=文本型

特征

可读写


IGRExportOption.AsE2CSVOption 属性

获取为CSV选项 方法

获取将本对象转换为导出CSV文件选项对象的接口引用。

调用格式： 〈导出CSV选项〉 对象．获取为CSV选项 （）

特征

只读

说明

将本对象转换为导出CSV文件选项对象，只有当本对象确实是一个导出CSV文件选项对象时,才能成功取得对象的接口引用。


IGRExportOption.AsE2HTMOption 属性

获取为HTM选项 方法

获取将本对象转换为导出Htm文件选项对象的接口引用。

调用格式： 〈导出HTM选项〉 对象．获取为HTM选项 （）

特征

只读

说明

将本对象转换为导出Htm文件选项对象，只有当本对象确实是一个导出Htm文件选项对象时,才能成功取得对象的接口引用。


IGRExportOption.AsE2PDFOption 属性

获取为PDF选项 方法

获取将本对象转换为导出PDF文件选项对象的接口引用。

调用格式： 〈导出PDF选项〉 对象．获取为PDF选项 （）

特征

只读

说明

将本对象转换为导出PDF文件选项对象，只有当本对象确实是一个导出PDF文件选项对象时,才能成功取得对象的接口引用。


IGRExportOption.AsE2TXTOption 属性

获取为TXT选项 方法

获取将本对象转换为导出文本文件选项对象的接口引用。

调用格式： 〈导出TXT选项〉 对象．获取为TXT选项 （）

特征

只读

说明

将本对象转换为导出文本文件选项对象，只有当本对象确实是一个导出文本文件选项对象时,才能成功取得对象的接口引用。


IGRExportOption.AsE2XLSOption 属性

获取为XLS选项 方法

获取将本对象转换为导出Excel文件选项对象的接口引用。

调用格式： 〈导出XLS选项〉 对象．获取为XLS选项 （）

特征

只读

说明

将本对象转换为导出Excel文件选项对象，只有当本对象确实是一个导出Excel文件选项对象时,才能成功取得对象的接口引用。


IGRExportOption.ShowOptionDlg 方法

显示选项对话框 方法

显示导出选项设置对话框，可以在打开的对话框中设定各个选项值。

调用格式： 〈逻辑型〉 对象．显示选项对话框 （）

返回值:如果在关闭对话框时选择了确定按钮，返回真值，反之则返回假值。

请参见

IGRExportOption 接口 | IGRExportOption 成员


IGRE2CSVOption.OnlyExportDetailGrid 属性

只导出明细网格 属性

指定是否只导出明细网格中的数据。

语法:对象.只导出明细网格=逻辑型

默认值

假

特征

可读写


IGRE2CSVOption.ExportPageHeaderFooter 属性

导出页眉页脚 属性

指定是否导出页眉与页脚，只有在产生页间分隔时此属性才有效。

语法:对象.导出页眉页脚=逻辑型

默认值

假

特征

可读写


IGRE2CSVOption.ExportPageBreak 属性

导出页分隔 属性

指定在导出数据时是否产生页之间的分隔。

语法:对象.导出页分隔=逻辑型

默认值

假

特征

可读写


IGRE2CSVOption.SupressEmptyLines 属性

压缩空行 属性

指定是否压缩空白行，即不产生空白行。

语法:对象.压缩空行=逻辑型

默认值

真

特征

可读写


IGRE2CSVOption.DelimiterChar 属性

分隔字符 属性

指定CSV分隔字符。

语法:对象.分隔字符=逻辑型

默认值 ,

特征

可读写


IGRE2IMGOption.ImageType 属性

图像类型 属性

指定导出的图像格式。

语法:对象.图像类型=整数型(注:导出图像类型枚举值 )

特征

可读写

设计器中可见

请参见

导出图像类型枚举

指定在导出图像文件时可用的各种图像格式。

成员名称 | 说明
BMP | Bitmap 位图图像格式。
GIF | GIF 图像格式。
JPEG | JPEG 图像格式。
PNG | PNG 图像格式。
tTIFF | TIFF 图像格式。


IGRE2TXTOption.UsingTabChar 属性

用TAB字符属性

指定是否用tab符号进行对齐处理。

语法:对象.用TAB字符=逻辑型

默认值

真

特征

可读写

说明

一个tab符号相当于8个空格字符占据的位置，用tab符号进行对齐处理可以减少导出文件的大小。


IGRE2TXTOption.UsingCNGraphChar 属性

用中文制表符 属性

指定是否用中文制表符代替明细网格的行列线。

语法:对象.用中文制表符=逻辑型

默认值

假

特征

可读写


IGRE2TXTOption.WriteDetailGridLine 属性

输出表格线 属性

指定是否输出明细网格的行列线，行列线用文字字符代替。

语法:对象.输出表格线=逻辑型

默认值

假

特征

可读写


IGRE2XLSOption.MinRowHeight 属性

最小行高 属性

指定导出产生行的最小高度，以字符为计量单位，用报表缺省字体的字符平均宽度进行转换。

语法:对象.最小行高=整数型

默认值

2

特征

可读写


IGRE2XLSOption.MinColumnWidth 属性

最小列宽 属性

指定导出产生的列的最小宽度，以字符为计量单位，用报表缺省字体的字符平均宽度进行转换。

语法:对象.最小列宽=整数型

默认值

2

特征

可读写


GRExportImageType 枚举

导出图像类型枚举

指定在导出图像文件时可用的各种图像格式。

成员名称 | 说明
BMP | Bitmap 位图图像格式。
GIF | GIF 图像格式。
JPEG | JPEG 图像格式。
PNG | PNG 图像格式。
tTIFF | TIFF 图像格式。


GRExportType 枚举

导出类型枚举

指定数据导出的类型。

成员名称 | 说明
导出CSV | 导出CSV格式文件。
导出Html | 导出Html超文本文件。
导出PDF | 导出PDF格式文件。
导出TXT | 导出文本文件。
导出XLS | 导出Excel文件。


集合对象概述

集合对象就是管理一组相同类型子对象的类。子对象有一个以字符表示的唯一名称标识，名称不区分字母的大小写。子对象在整个集合中的排列顺序称为子对象的顺序号，第一个子对象的顺序号为 1，依次递增每个子对象的顺序号。一般用字对象的名称或顺序号操作子对象。集合对象对象一般具有类似的属性与方法。

集合对象通常具有的属性：

名称 | 数据类型 | 说明
Count | LONG | 只读，指示拥有子对象的个数。
_NewEnum | IUnknown * | 只读，返回Visual Basic需要的枚举器，Visual Basic在执行 For_Each 语句时需要，开发者不用关心此属性。
Item | IGR%Object% * | 只读，根据子对象的顺序号或名称得到子对象的接口指针，在读取时要传入一个 VARIANT 类型的参数，指定子对象的顺序号或名称，子对象的顺序号从 1 开始。IGR%Object% 是泛指子对象的接口类型，不同的集合对象具有不同的子对象接口类型。

集合对象通常具有的方法：

名称 | 说明
Add | 增加一个子对象并返回新增子对象的接口指针，如果子对象有各种具体类型，则此方法有一个类型参数，通过此参数指定子对象的类型。
IndexByName | 根据子对象的名称取得其顺序号，如果不存在与名称匹配的子对象，则返回值为 -1。子对象的名称不区分字母的大小写。
Remove | 根据子对象的顺序号或名称将子对象移除掉，在输入参数种指定要移除子对象的顺序号或名称。子对象的名称不区分字母的大小写。
RemoveAll | 清除全部子对象。

注意：有的集合对象不允许集合对象直接删除子对象，则不提供 Remove 与 RemoveAll 方法。

Grid++Report包括的集合对象：

名称 | 接口类型 | 说明
报表节集合 | IGRSections | 指定报表主对象(IGridppReport)直接拥有的节，这里指页眉，页脚，报表头，报表尾。在增加报表节时需要指定类型参数，并只能是以上四种节类型之一。
部件框集合 | IGRControls | 指定部件框容器拥有的部件框。增加部件框需要指定部件框的具体类型。
参数集合 | IGRParameters | 指定报表主对象(IGridppReport)拥有的参数。
列集合 | IGRColumns | 指定明细网格(IGRDetailGrid)拥有的列。
字段集合 | IGRFields | 指定记录集(IGRRecordset)拥有的字段。增加字段需要指定字段的具体类型。
分组集合 | IGRGroups | 指定明细网格(IGRDetailGrid)拥有的分组。
内容格集合 | IGRColumnContentCells | 在内容行(IGRColumnContent)对象中指定拥有的内容格，内容格伴随列的新增而新增，伴随列的删除而删除，所以此集合对象不提供Add，Remove，RomoveAll方法。
标题格集合 | IGRColumnTitleCells | 在标题行(IGRColumnTitle)对象中指定拥有的标题格，与列对应的标题格伴随列的新增而新增，伴随列的删除而删除，所以此集合对象不提供 Add，Remove，RomoveAll 方法，而为增加和移除组标题格提供 AddGroup，RemoveGroup 方法。


术语

RTF文本框

用来显示RTF格式文本的部件框，RTF格式文本数据可以直接保存在报表模板文件中，也可以在运行时从磁盘文件、二进制字段和内存中载入。

报表布局窗口

报表布局窗口是报表设计器　ActiveX　控件的一个子窗口。用来显示报表定义中的可显示元素，并可以对显示的元素进行各种设计操作，如移动位置、缩放大小、各种对齐操作、改变顺序、插入新报表元素、删除报表元素等。报表布局窗口提供了可视化设计报表的功能，整个报表的输出布局可以方便的实现。报表布局窗口是整个设计器的核心组成部分。

报表节

整个报表的输出显示由多种类型的占据整个水平输出区域宽度的矩形带状区域组成，以上各种类型显示区域统称为报表节。Grid++Report的报表节类型包括：页眉、页脚、报表头、报表尾、标题行，内容行、分组头、分组尾。

报表节集合

定义一组报表节的对象，此集合对象被报表主对象直接拥有。报表节集合只包含四种类型的报表节：页眉、页脚、报表头、报表尾。其它类型的报表节不被报表主对象直接拥有，所以它们不会出现在报表节集合中。

报表开发者

在本文档中指使用 Grid++Report 开发报表的程序员。报表开发者开发的报表将提供给报表的最终使用者运行。

报表模板

定义报表布局、外观、结构、行为的数据。报表模板数据存储在以报表主对象为最上层对象的组件对象模型中。可以从报表模板文件载入报表模板到报表主对象，也可以根据报表组件对象模型的接口定义以编程的方式定义报表模板。可以将报表模板保存到报表模板文件达到持久保存的目的。

报表模板文件

保存报表模板数据的文件。在设计器应用程序中设计的模板数据保存到模板文件，在运行报表之前将报表模板数据从报表模板文件载入到报表主对象中。

报表设计器

一个　ActiveX　控件，对报表模板数据进行设计。报表设计器主要由报表布局窗口、属性编辑窗口、对象浏览窗口组成。如果要为报表最终用户提供运行时可以可视化修改报表的功能，就要使用报表设计器，提供一些外围操作界面元素（按钮，编辑框，菜单等）与报表设计器进行交互处理。

报表头

一种类型的报表节，被报表主对象直接拥有。在查询显示器中显示在窗口上端，如有明细网格，显示在明细网之上；打印生成时在报表开始位置显示一次，可以定义在每页重复使其多次输出显示。一个报表可以定义多个报表头，在一般情况下我们只需定义一个报表头。在报表头中一般定义报表的标题、报表标识信息、徽标图像及其它只需在报表开始时显示一次的信息。

报表尾

一种类型的报表节，被报表主对象直接拥有。在查询显示器中显示在窗口下端，如有明细网格，显示在明细网之下；打印生成时在报表结束位置显示一次，可以定义在每页重复使其多次输出显示。一个报表可以定义多个报表尾，在一般情况下我们只需定义一个报表尾。在报表尾中一般定义报表的统计信息及其它只需在报表结束时显示一次的信息。

报表运行时

是指报表处于数据生成、打印页面生成与查询显示器中显示报表数据的状态。很多报表对象的属性与方法只有当报表处于运行时状态才能使用。 以下几种情况报表一定是处于运行时状态： （1）响应报表主对象的事件函数时。 （2）报表在查询显示器中显示时。

报表主对象

是一个 COM 自动化（COM Automation）对象，是 Grid++Report 组件对象模型的最外层对象。报表主对象是所有其它报元素对象的直接或间接拥有者，直接拥有的报表元素对象有：明细网格、报表节集合、参数集合、打印机对象。另也包括报表有关的公共信息，如设计行为属性、计量单位、整个报表的缺省字体等。

报表最终用户

在本文档中指运行报表开发者开发的报表的用户。

标题格

每当增加一个明细网格的列之后，都会在标题行添加一个对应的显示单元格；当我们需要定义多层标题时，具有下级标题的标题也要在标题行添加一个对应的显示单元格，这两种形式的单元格称为标题格。一般在明细网格的标题格中定义列的标题文字。如果把标题格设为自由格，则标题格成为部件框容器，可以向标题格添加部件框。

标题格集合

定义一组标题格的对象，此集合对象被标题行直接拥有。

标题行

定义明细网格的标题区域。标题行一般显示在明细网格的最上端，通常只在明细网格开始时显示一次。标题行拥有所有标题格，标题行显示区域被一个个标题格所划分。

部件框

部件框是对报表中各种可显示的基本单元的统称，部件框在其父容器中占据一个矩形区域，部件框的内容就输出在此矩形区域中，部件框包括背景填充方式与背景色、边框输出模式、以及具体类型的部件框的输出前景色。Grid++Report　包括如下具体类型的部件框：静态框、字段框、统计框、系统变量框、图形框。

部件框集合

定义一组部件框的集合，各种部件框容器对象都拥有一个部件框集合对象。

部件框容器

各种拥有部件框的报表元素的统称。在报表设计器中，可以向部件框容器中插入各种部件框。页眉(PageHeader)、页脚(PageFoote)、报表头(ReportHeader)、报表尾(ReportFooter)、分组头(GroupHeader)、分组尾(GroupFooter)都是部件框容器，标题格(ColumnTitleCell)与内容格(ColumnContentCell)定义成自由格时也是部件框容器。

参数

定义可以存储各种类型数据的对象，报表运行时可以改变存储的值。参数可以关联到静态部件框，当静态部件框显示时，将输出参数的显示文本。参数可以用来实现自定义数据统计功能，在　ProcessReocrd，GroupBegin，GroupEnd　事件中执行统计计算，将计算结果存储到参数，在分组头与分组尾定义静态部件框并与存储统计数据的参数对象关联。

参数集合

定义一组参数的集合，参数集合被报表主对象直接拥有。

查询显示器

是一个　ActiveX　控件。在使用时要关联一个报表主对象。开始运行时向报表主对象发出生成数据请求，然后本构件显示报表主对象生成的数据，本对象为最终用户提供了完善的查询显示数据的功能。报表开发者通过对本对象交互事件的响应，为最终用户提供可交互的操作。例如通过对汇总报表的明细网格内容格的双击事件的响应，打开对应的明细报表，达到从汇总报表到明细报表的穿透查询。

打印查看器

是一个 ActiveX 控件。在使用时要关联一个报表主对象。开始运行时向报表主对象发出生成数据请求，并生成打印页面，然后本构件显示生成的打印页面，并且提供其它相应的页面操作与打印操作。报表开发者可以通过提供外部操作界面来执行控件接口的方法与属性，为报表最终用户提供报表打印预览功能。

单元格

标题格与内容格的统称。当属性　FreeCell　为真时，单元格称为自由格，单元格是部件框容器；当属性　FreeCell 为假时，单元格称为非自由格，单元格不是部件框容器。

对象浏览窗口

对象浏览窗口是报表设计器的一个子窗口。以树形结构显示整个报表中的所有对象，可以通过选中树节点来选中对应对象，在报表布局窗口中不显示的报表对象一般在此窗口中进行选中。

非自由格

当标题格与内容格的属性　FreeCell　为假时，称为非自由格。此时标题格或与内容格不是部件框容器。如果具体类型是内容格，关联一个字段，运行时输出字段的显示文本；如果具体类型是标题格，具有一个显示文本属性，运行时输出显示文本。

分组

定义分组规则，对所有的记录数据进行归类，并将归类统计数据显示在分组头或分组尾。当属性　PageGroup　为真，在打印生成页面时，每个页产生一个分组项；当属性　PageGroup　为假，如果属性　ByFields　关联字段，将相同字段值的记录归类为一个分组项，通常记录的顺序应按分组字段进行排序，如果属性　ByFields　没有定义，表示全部记录形成一个分组项。在报表主对象的　ProcessRecord　事件中每执行　IGRDetailGrid　接口的　StartNewGroup　方法，将生成指定分组的一个分组项。

分组集合

定义一组分组的集合，被明细网格直接拥有。

分组节

分组头与分组尾的统称。

分组头

一个报表可以定义一个分组或多个嵌套分组，每个分组对应一个分组头与一个分组尾。分组头显示在每个分组开始时，一般在分组头上定义定义分组的标识信息，分组初始值及其它只需在分组开始时显示一次的信息。

分组尾

一个报表可以定义一个分组或多个嵌套分组，每个分组对应一个分组头与一个分组尾。分组尾显示在每个分组结束时，一般在分组尾上定义定义分组的统计信息及其它只需在分组开始时显示一次的信息。

分组项

在报表运行时，记录按照每个分组的定义产生的一个个归类称为分组项。

集合对象

各种集合定义的统称。在组件对象模型中，一个父对象如果拥有多个某种类型的子对象，就需要定义子对象的集合对象，父对象直接拥有集合对象，由集合对象管理子对象群。各种集合对象一般具有类似的属性与方法。

集合属性对话框

报表设计器中各种集合对象的属性查看与编辑通用窗口。在窗口左边的列表框列出所有的子对象名称，右边的属性编辑窗口显示选中子对象的属性。另外提供增加与移除子对象、改变子对象顺序的按钮等操作界面。

记录集

存储与操作所有记录的对象，拥有一组子段。

静态框

用来显示静态文本的部件框，一般在设计时设定要显示的文本，在输出显示时根据输出格式信息将显示文本画出来。静态框可以关联某个参数对象，在这种情况下，在输出显示时部件框的显示文本为参数对象的显示文本，当一个部件框在输出时要显示多次，而其关联的参数对象的值是变化的，则此同一静态部件框在不同位置输出的显示文本是变化的。

均分页

在打印生成时，将纸张纵向均匀分割，每个等分的区域作为一个独立的输出页面看待，此种页面称为均分页。

列

定义明细网格输出时在水平方向按列划分的定义。每个列有显示宽度属性。每个列对应一个标题格，显示在标题行上，一个内容格，显示在内容行上。一般一个显示的字段对应定义一个列；列本身在输出时不能显示出来，而是通过标题格与内容格的显示来体现列的输出。

明细网格

明细网格就是处理报表明细数据生成的定义，一般的报表都需要一个明细网格，明细网格一般生成在报表头之后及报表尾之前，明细网格构成了一个报表的主体，报表的主要信息输出在明细网格中，明细网格的显示由几种报表节组成：标题行、内容行、分组头、分组尾。

内容格

每当增加一个明细网格的列之后，都会在内容行添加一个对应的显示单元格，此种显示单元格称为内容格。一般每个内容格关联一个字段，用来显示字段的内容。如果把内容格设为自由格，则内容格成为部件框容器，可以向内容格添加部件框。

内容格集合

定义一组内容格的集合，被内容行直接拥有。

内容行

内容行显示在明细网格标题之后，按照明细网格的数据集记录，内容行按照记录的顺序每个记录生成一次，如果定义有分组，在每个分组项开始与结束时，要插入分组头与分组尾。内容行拥有所有内容格，内容行显示区域被一个个内容格所划分。

全程分组

当分组既不是按页分组归类的，且没有定义分组子段，此时的分组称为全程分组。所有的明细记录只产生一个全程分组项。

统计框

用来显示统计数据的部件框，在设计时设定某种统计函数，除计数（Count）函数，其余统计函数都需要关联一个字段对象。在统计框中可以定义统计值的输出格式。统计框一般使用在分组头、分组尾中。有时为了统计全部记录的统计数据，可以将统计框使用在报表尾或报表头中。

图表

用来显示多种类型图表(Chart)的部件框。图表数据既可以在设计时提供，也可以在报表运行时实时提供动态变化数据。在内容格与分组头尾中的图表还可以在报表中多次输出并可以为每次输出提供不一样的数据。

图像集合

图像集合定义在报表主对象中，在图像集合中一般定义需要在报表中多次显示的图像。图像集合中的图像通过序号来标识，图像框通过图像序号(ImageIndex)属性或数据字段(DataField) 属性指定要应用的图像集合中的图像。图像序号属性的值如果不为零，图像框将显示对应的图像集合中的图像。如果关联了数据字段，且数据字段的类型不为二进制，将根据字段的整型值匹配图像集合中的图像并显示它。

图像框

用来显示多种格式图像的部件框，图像数据可以直接保存在报表模板文件中，也可以在运行时从磁盘文件、二进制字段和内存中载入。

图形框

用来显示各种图形的部件框，在设计时设定某种图形类别，并设定该种图形的一些参数信息。图形框一般用来对报表进行一些修饰。

文本框

各种显示文本的部件框的统称，包括：静态框、字段框、统计框、系统变量框。

系统变量框

用来显示系统变量值的部件框，在设计时设定某种系统变量，在系统变量框中可以定义值的输出格式。系统变量框一可以使用在任何部件框容器中，例如页号、页总数一般使用在页眉与页脚中。

线段

专门输出线段的部件框。

页分组

当分组的属性　PageGroup　为真，这样的分组称为页分组。在打印生成页面时，每个页产生一个分组项。

页脚

页脚在打印生成时，输出在每页的下边距之下；在屏幕查询显示时，页脚被忽略掉，即屏幕查询显示不使用页脚。一个报表只能定义一个页脚。在页脚中一般定义页号、总页数、文档名称、打印时间及其它需要显示在输出纸张页脚区域的信息。

页列

当明细网格的　PageColumnCount>1　时，在打印生成时，整个输出宽度按　PageColumnCount　进行均分，每个均分区域称为页列。

页眉

页眉在打印生成时，输出在每页的上边距之上；在屏幕查询显示时，页眉被忽略掉，即屏幕查询显示不使用页眉。一个报表只能定义一个页眉。在页眉中一般定义页号、总页数、文档名称、打印时间及其它需要显示在输出纸张页眉区域的信息。

占列式分组头

当分组头的 OccupyColumn 属性为真时，在输出显示时，报表头不是独立占据一个水平宽度区域，而是在 OccupiedColumns 属性指定列的显示区域中与内容行一起显示。OccupiedColumns 属性指定列自身的输出显示被忽略掉。

属性编辑窗口

属性编辑窗口是报表设计器的一个子窗口。用来查看与修改选中报表对象的属性。

子报表

专门用来在当前报表中输出另外一个报表的内容的部件框。在报表运行之前，必须为子报表关联报表对象。子报表只能使用在报表头节与报表尾节。子报表关联的报表对象在运行时其本身的页眉与页脚不会输出，而是输出当前报表的页眉与页脚，这样可以保持所有子报表都输出一致的页眉与页脚。

字段

定义数据集中的各种数据项。数据类型包括：文本、布尔、日期时间、整数、浮点数、二进制、货币。

字段集合

定义一组字段的集合，被记录集直接拥有。

字段框

用来显示字段内容的部件框，在设计时关联一个字段对象，在输出显示时根据输出格式信息将字段对象在当前记录的显示文本画出来。字段框一般使用在明细网格的自由内容格、分组头、分组尾中。

自由格

当标题格与内容格的属性 FreeCell 为真时，称为自由格。此时标题格或与内容格是部件框容器。格本身在显示时只填充背景，然后再输出拥有的全部子部件框。

综合文字框

综合文字框可以显示静态文本，关联动态数据域，动态数据域包括：字段、参数、文字部件框、统计函数与系统变量。综合文字框可以定义四则运算表达式，在运行时表达式被替换为运算结果。综合文字框是 Grid++Report 中最常用的部件框，它除了可以实现其它文字框的功能外，还可以组合静态文字与动态数据域，在运行时输出动态变化的文本，另外数据域还可以使用在四则运算表达式中，在运行时输出运算结果。


New Page 1

在类库参考文档中，对属性按特征进行归类，当属性具有某个特征时，在文档中将特征列出。 以下是各个特征的说明：

特征名称 | 说明
设计器中可见 | 指示属性在报表设计器中可见，可修改。当属性的拥有对象选中时，属性在属性编辑窗口种列出。
仅运行时可用 | 指示属性仅在报表处于运行时状态时才能使用。
仅用于打印 | 指示属性值仅与报表打印生成时的行为有关，即此属性只影响打印生成结果。
仅用于查询 | 指示属性值仅与报表在查询显示器中的行为有关，即此属性只影响查询显示器输出报表的结果。
仅用于设计 | 指示属性值仅用于在报表设计器中设计报表，定义设计器设计的行为，而与报表生成输出没有关系。


IGridppReport成员

IGridppReport 概述

公共属性

AlignToGrid | 当在设计器中设计报表模板时，是否将部件框的边框对齐到设计栅格点。
BackColor | 报表对象的缺省背景色。
BackImage | 指定报表在设计器中进入页面视图时显示的背景图。
BackImageFile | 指定报表在设计器中进入页面视图时显示的背景图文件的路径与名称。
ContinuePrint | 指定是否采用连续打印，即打即停的方式打印输出报表。
DesignBottomMargin | 指定设计报表时所定义的页面下边距。
DesignLeftMargin | 指定设计报表时所定义的页面左边距。
DesignPaperLength | 指定设计报表时所定义的页面长度，仅自定义纸张设置此属性有效。
DesignPaperName | 指定设计报表时所定义的纸张名称。
DesignPaperOrientation | 指定设计报表时所定义的纸张打印方向。
DesignPaperSize | 指定设计报表时所定义的纸张大小代号。
DesignPaperWidth | 指定设计报表时所定义的页面宽度，仅自定义纸张设置此属性有效。
DesignRightMargin | 指定设计报表时所定义的页面右边距。
DesignTopMargin | 指定设计报表时所定义的页面上边距。
DetailGrid | 获取明细网格对象的接口引用。
DisplayMode | 指示报表的输出显示状态。
Font | 获取报表对象的缺省字体对象的引用。
GridColsPerUnit | 在设计器中，水平方向上每个计量单位显示的设计栅格点个数。
GridRowsPerUnit | 在设计器中，垂直方向上每个计量单位显示的设计栅格点个数。
ImageList | 获取报表对象中图像集合对象的接口引用。
PageDivideCount | 打印输出时，纸张在垂直方向上的均分个数。
PageDivideLine | 打印输出时，是否显示纸张在垂直方向均分的分隔线。
PageDivideSpacing | 打印输出时，纸张在垂直方向均分时的分隔间距。
PageFooter | 获取页脚对象的接口引用。
PageHeader | 获取页眉对象的接口引用。
Parameters | 获取参数集合对象的接口引用。
PrintAsDesignPaper | 指定是否按设计时的页面设置生成打印页面。
Printer | 获取打印机对象的接口引用。
ReportFooter | 根据名称或序号取得某个报表尾对象的接口引用。
ReportHeader | 根据名称或序号取得某个报表头对象的接口引用。
SharePrintSetupObject | 获取当前应用程序的共享全局打印设置对象的接口引用。
SharePrintSetupOptions | 指定共享全局打印设置参数的选项。
ShowGrid | 获取或设置是否在设计器中显示设计栅格点的标志。
ShowMoneyDigit | 指定在报表中显示金额线或金额位标签时显示的位数。
ShowMoneyLineColor | 指定金额位分隔线的颜色。
ShowMoneySepLineColor | 指定元与角位之间的分隔线的颜色。
ShowMoneyWidth | 指定在报表中显示金额线或金额位标签时显示全部位的宽度。
Title | 指定报表文档的标题文字。
Unit | 用来表示报表元素位置与大小的计量单位。
Version | 指示Grid++Report的当前运行版本。
Watermark | 指定报表在生成打印页面时在每页中显示的水印背景图像。
WatermarkAlignment | 指定水印图在页面中显示时的位置对齐方式。
WatermarkSizeMode | 指定水印图在页面中显示时使用的缩放方式。

公共方法

About | 显示Grid++Report关于对话框。
AddParameter | 增加一个参数定义。
BeginLoopPrint | 准备开始循环打印。
Clear | 清除所有的报表模板定义数据，使报表主对象成为一张空白报表。
ColumnByName | 根据名称找到对应列对象的接口引用。
ControlByName | 从报表主对象包括的所有部件框中根据部件框名称找到对应部件框对象的接口引用。
DeleteDetailGrid | 删除整个明细网格的定义，报表主对象将不具有明细网格。
DeletePageFooter | 删除页脚的定义，报表主对象将不具有页脚。
DeletePageHeader | 删除页眉的定义，报表主对象将不具有页眉。
DeleteReportFooter | 根据报表尾的名称或序号删除一个报表尾。
DeleteReportHeader | 根据报表头的名称或序号删除一个报表头。
EndLoopPrint | 结束循环打印。
Export | 执行数据导出。
ExportDirect | 直接进行数据导出。
FieldByName | 根据字段名称得到匹配字段对象的接口引用。
ForceNewPage | 在报表生成过程中，结束当前页，开始一个新页面。
GenerateDocumentFile | 生成报表的 Grid++Report 文档文件到指定的文件。
InsertDetailGrid | 向报表主对象插入明细网格，使报表主对象具有明细网格。
InsertPageFooter | 增加页脚定义。
InsertPageHeader | 增加页眉定义。
InsertReportFooter | 增加一个报表尾。
InsertReportHeader | 增加一个报表头。
LoadBackImageFromFile | 从指定的图像文件中载入报表设计页面背景图。
LoadBackImageFromMemory | 从内存数据中载入报表设计页面背景图。
LoadFromFile | 从报表模板文件中载入报表模板定义。
LoadFromMemory | 从内存中载入报表模板数据。
LoadFromStr | 从字符串中载入报表模板数据。
LoadFromVariant |
LoadWatermarkFromFile | 从指定的图像文件中载入水印背景图。
LoadWatermarkFromMemory | 从内存数据中载入报表水印背景图。
LoopPrint | 在循环打印过程中，执行一次打印生成过程。
ParameterByName | 根据名称找到对应参数对象的接口引用。
PixelsToUnit | 将屏幕像素值转换为报表当前使用的计量单位值。
PrepareExport | 准备进行数据导出，指定要导出的文件类型。
Print | 执行打印报表。
PrintEx | 打印报表,按指定方式生成生成打印数据。
PrintPreview | 在Grid++Report提供的缺省打印预览窗口中预览报表。
PrintPreviewEx | 在Grid++Report提供的缺省打印预览窗口中预览报表，可以指定打印数据的生成方式。
Register | 用Grid++Report的产品序列号进行注册。
SaveToFile | 将报表模板数据保存到报表模板文件中去。
SaveToMemory | 保存报表模板数据保存至内存缓冲区。
SaveToStr | 保存报表模板数据保存至字符串。
SaveToVariant | 保存报表模板数据保存至内存缓冲区。
SharePrintSetupDisableAllOptions | 指定禁用全部的共享打印设置参数。
SharePrintSetupEnableAllOptions | 指定应用全部的共享打印设置参数。
SharePrintSetupGetOptionEnabled | 获取是否应用某个共享全局打印参数项的使能状态。
SharePrintSetupSetOptionEnabled | 设定是否应用某个共享全局打印参数项的标志。
SystemVarValue | 在报表运行时，取得本报表某个指定系统参数的当前值。
UnprepareExport | 数据导出完成之后，进行一些内部释放任务。

事件

BeforePostRecord | 在向报表中填入记录数据的过程中，每当提交一条记录之前触发本事件。
BeforeSort | 当要对记录集中的记录进行重新排序之前触发本事件。
FetchRecord | 在报表生成时，报表主对象请求数据时触发。
FieldGetDisplayText | 当字段对象准备生成其显示文本时触发。
GroupBegin | 在生成报表数据时，开始一个分组触发。
GroupEnd | 在生成报表数据时，结束一个分组触发。
Initialize | 在报表生成开始时触发。
PageEnd | 在完成一个打印页面生成时触发本事件。
PageProcessRecord | 当报表在生成打印数据时，会再次按顺序遍历每一条记录，每当遍历一条记录时触发本事件。
PageStart | 在开始生成一个打印页面时触发本事件。
ProcessBegin | 当报表准备对填入的数据进行分析处理之前触发本事件。
ProcessEnd | 当报表对填入的数据进行分析处理完成之后触发本事件。
ProcessRecord | 当报表生成时，会按顺序遍历每一条记录，每当遍历一条记录时触发本事件。
SectionFormat | 当报表节在输出之前触发。包括查询显示预打印生成显示。

请参见

IGridppReport 接口


IGRSection成员

IGRSection 概述

公共属性

BackColor | 报表节的背景填充色。
CanGrow | 指示节高度在运行时是否可以伸展的标志。
CanShrink | 指示节高度在运行时是否可以收缩的标志。
Controls | 获取拥有的部件框集合对象的接口引用。
Font | 报表节的缺省字体。
Height | 报表节的高度。
Name | 报表节的名称标识。
Parent | 父对象的IUnknown接口引用。
SectionType | 指示报表节的具体类型。
Visible | 是否显示报表节的标志。

请参见

IGRSection 接口


IGRPageHeader成员

IGRPageHeader 概述

公共属性

BackColor(从 IGRSection 继承) | 报表节的背景填充色。
CanGrow(从 IGRSection 继承) | 指示节高度在运行时是否可以伸展的标志。
CanShrink(从 IGRSection 继承) | 指示节高度在运行时是否可以收缩的标志。
Controls(从 IGRSection 继承) | 获取拥有的部件框集合对象的接口引用。
Font(从 IGRSection 继承) | 报表节的缺省字体。
Height(从 IGRSection 继承) | 报表节的高度。
Name(从 IGRSection 继承) | 报表节的名称标识。
Parent(从 IGRSection 继承) | 父对象的IUnknown接口引用。
SectionType(从 IGRSection 继承) | 指示报表节的具体类型。
Visible(从 IGRSection 继承) | 是否显示报表节的标志。

请参见

IGRPageHeader 接口 | IGRPageFooter 接口 | IGRReportFooter 接口 | IGRReportHeader 接口


IGRPageFooter成员

IGRPageFooter 概述

公共属性

BackColor(从 IGRSection 继承) | 报表节的背景填充色。
CanGrow(从 IGRSection 继承) | 指示节高度在运行时是否可以伸展的标志。
CanShrink(从 IGRSection 继承) | 指示节高度在运行时是否可以收缩的标志。
Controls(从 IGRSection 继承) | 获取拥有的部件框集合对象的接口引用。
Font(从 IGRSection 继承) | 报表节的缺省字体。
Height(从 IGRSection 继承) | 报表节的高度。
Name(从 IGRSection 继承) | 报表节的名称标识。
Parent(从 IGRSection 继承) | 父对象的IUnknown接口引用。
SectionType(从 IGRSection 继承) | 指示报表节的具体类型。
Visible(从 IGRSection 继承) | 是否显示报表节的标志。

请参见

IGRPageFooter 接口 | IGRPageHeader 接口 | IGRReportFooter 接口 | IGRReportHeader 接口


IGRReportHeader 概述

IGRReportHeader 接口

表示报表的报表头。报表头一般显示在报表的最前面。

有关此接口所有成员的列表，请参阅 IGRReportHeader 成员。

IDispatch
IGRSection
IGRReportHeader

说明

报表头在打印生成时，如果不选择每页重复输出，则只在报表的开始生成时输出一次；在屏幕查询显示时，显示在明细网格之上。一个报表可以定义多个报表头，在一般情况下我们只需定义一个报表头就可以了。在报表头中一般定义报表的标题，报表标识信息，徽标图像及其它只需在报表开始时显示一次的信息。

请参见

IGRReportHeader 成员 | IGRReportFooter 接口 | IGRPageFooter 接口 | IGRPageHeader 接口


IGRReportHeader成员

IGRReportHeader 概述

公共属性

BackColor(从 IGRSection 继承) | 报表节的背景填充色。
CanGrow(从 IGRSection 继承) | 指示节高度在运行时是否可以伸展的标志。
CanShrink(从 IGRSection 继承) | 指示节高度在运行时是否可以收缩的标志。
Controls(从 IGRSection 继承) | 获取拥有的部件框集合对象的接口引用。
Font(从 IGRSection 继承) | 报表节的缺省字体。
Height(从 IGRSection 继承) | 报表节的高度。
KeepTogether | 是否保持本节输出显示在同一页标志。
Name(从 IGRSection 继承) | 报表节的名称标识。
NewPage | 指定新页的产生方式。
Parent(从 IGRSection 继承) | 父对象的IUnknown接口引用。
RepeatOnPage | 是否在每页中重复输出显示标志。
SectionType(从 IGRSection 继承) | 指示报表节的具体类型。
Visible(从 IGRSection 继承) | 是否显示报表节的标志。

请参见

IGRReportHeader 接口 | IGRReportFooter 接口 | IGRPageFooter 接口 | IGRPageHeader 接口


IGRReportFooter成员

IGRReportFooter 概述

公共属性

BackColor(从 IGRSection 继承) | 报表节的背景填充色。
CanGrow(从 IGRSection 继承) | 指示节高度在运行时是否可以伸展的标志。
CanShrink(从 IGRSection 继承) | 指示节高度在运行时是否可以收缩的标志。
Controls(从 IGRSection 继承) | 获取拥有的部件框集合对象的接口引用。
Font(从 IGRSection 继承) | 报表节的缺省字体。
Height(从 IGRSection 继承) | 报表节的高度。
KeepTogether | 是否保持本节输出显示在同一页标志。
Name(从 IGRSection 继承) | 报表节的名称标识。
NewPage | 指定新页的产生方式。
Parent(从 IGRSection 继承) | 父对象的IUnknown接口引用。
PrintAtBottom | 是否将本节输出在页面底部标志。
RepeatOnPage | 打印输出时，是否在每页中重复显示的标志。
SectionType(从 IGRSection 继承) | 指示报表节的具体类型。
Visible(从 IGRSection 继承) | 是否显示报表节的标志。

请参见

IGRReportFooter 接口 | IGRReportHeader 接口 | IGRPageFooter 接口 | IGRPageHeader 接口


IGRDetailGrid成员

IGRDetailGrid 概述

公共属性

AlwaysShowHScrollBar | 查询显示时，是否始终显示水平滚动条的标志。
AlwaysShowVScrollBar | 查询显示时，是否始终显示垂直滚动条的标志。
AppendBlankRow | 打印输出时，是否在页的剩余区域补充显示空白内容行的标志。
BackColor | 指定明细网格的标题行、内容行、分组头与分组尾的默认背景色。
BackgroundColor | 查询显示时，网格外围的空白区域的背景填充色。
BorderColor | 边框线颜色。
BorderStyles | 指定网格边框线的输出方式。
BorderWidth | 边框线宽度。
CenterView | 当明细网格的列总宽度小于显示区域宽度时，指定是否水平居中显示明细网格。
ColLineWidth | 网格列线的宽度，以屏幕像素为计量单位。
ColumnContent | 明细网格拥有的内容行的接口引用。
ColumnMove | 查询显示时，指定是否可以用鼠标拖放改变列的显示顺序。
ColumnResize | 查询显示时，指定是否可以通过鼠标拖放改变列的显示宽度。
Columns | 获取网格拥有的列集合对象的接口引用。
ColumnTitle | 获取明细网格拥有的标题行对象的接口引用。
FixCols | 查询显示时，指定锁定的列数，左边被锁定的列始终不进行水平滚动。
Font | 获取明细网格拥有的子对象的缺省字体对象的接口引用。
Groups | 获取网格拥有的分组集合对象的接口引用。
LineColor | 指定行列分隔线的颜色。
NewPage | 打印生成时，指定强制换新页的方式。
PageColumnCount | 在水平方向上均分打印输出区域的个数，也就是报表栏数。
PageColumnDirection | 在输出多栏报表时，数据行生成到输出位置的方向。
PageColumnSpacing | 指定多栏报表的栏间距，以报表的计量单位表示。
PrintAdaptMethod | 打印输出时，根据输出页面的情况，指定列的输出策略。
PrintAdaptRepeat | 当打印策略为‘另起新页’或‘另起新页并重复固定列’时，报表头与报表尾是否在新页中再次输出。
Recordset | 获取网格拥有的记录集对象的接口引用。
RowLineWidth | 网格行线的宽度，以屏幕像素为计量单位。
RowSelection | 指定在查询显示报表时是否整行选中内容行。
SelectionBackColor | 查询显示时，选中格或行的背景填充色。
SelectionForeColor | 查询显示时，选中格或行的前景色。
ShowColLine | 指定是否显示网格列分隔线。
ShowRowLine | 指定是否显示网格行分隔线。

公共方法

AddColumn | 增加一个新列。
AddGroupTitle | 增加一个新组标题格。
ClearColumns | 删除所有的列。
ClearGroupTitles | 删除全部组标题格。
ColumnMoveToEnd | 将列地显示顺序移动到最后。
FindGroupTitleCell | 根据名称找到组标题格对象的接口引用。
StartNewGroup | 在报表生成时，开始生成一个新的分组项。

请参见

IGRDetailGrid 接口


IGRSections成员

IGRSections 概述

公共属性

_NewEnum | 返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。
Count | 指示拥有列的个数。
Item | 根据列的顺序号或名称得到列的接口引用。

公共方法

Add | 增加一个子对象并返回新增子对象的接口引用，如果子对象具有具体类型，则此方法有一个类型参数，通过此参数指定子对象的类型。
IndexByName | 根据子对象的名称取得其顺序号，如果不存在与名称匹配的子对象，则返回值为-1。子对象的名称不区分字母的大小写。
Remove | 根据子对象的顺序号或名称将子对象移除掉，在输入参数种指定要移除子对象的顺序号或名称。
RemoveAll | 清除全部子对象。

请参见

IGRSections 接口 | IGRSection 接口


IGRControls成员

IGRControls 概述

公共属性

_NewEnum | 返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。
Count | 指示拥有部件框的个数。
Item | 根据部件框的顺序号或名称得到部件框的接口引用。

公共方法

Add | 根据部件框的类型参数增加一个部件框并返回新增部件框的接口引用。
IndexByName | 根据部件框的名称取得其顺序号，如果不存在与名称匹配的部件框，则返回-1。部件框的名称不区分字母的大小写。
Remove | 根据部件框的顺序号或名称将部件框移除，在输入参数种指定要移除部件框的顺序号或名称。
RemoveAll | 清除全部部件框。
SetItemOrder | 改变指定部件框的顺序。

请参见

IGRControls 接口 | IGRControl 接口


IGRControl成员

IGRControl 概述

公共属性

AlignColumn | 指定部件框水平位置对齐到明细网格列的名称。
AlignColumnSide | 部件框对齐到明细网格列的方式。
Anchor | 指定部件框的哪些边缘锚定到其容器边缘。
AsChart | 将本部件框转换为图表部件框的接口引用。
AsFieldBox | 将本部件框转换为字段框的接口引用。
AsLine | 将本部件框转换为线段的接口引用。
AsMemoBox | 转换本部件框为综合文本框的接口引用。
AsPictureBox | 将本部件框转换为图像框的接口引用。
AsRichTextBox | 将本部件框转换为RTF文本框的接口引用。
AsShapeBox | 将本部件框转换为图形框的接口引用。
AsStaticBox | 将本部件框转换为静态框的接口引用。
AsSubReport | 转换本部件框为子报表的接口引用。
AsSummaryBox | 将本部件框转换为统计框的接口引用。
AsSystemVarBox | 将本部件框转换为系统变量框的接口引用。
AsTextBox | 转换本部件框为文字框基类的接口引用。
BackColor | 部件框的背景色。
BackStyle | 部件框显示时背景的填充方式。
BorderColor | 边框线的显示颜色。
BorderStyles | 边框线的显示方式。
BorderWidth | 边框线的宽度。
Center | 指定水平与垂直方向的居中对齐方式。
ControlType | 获取本部件框的具体类型。
Cursor | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
Dock | 指定部件框停靠到父容器的哪一个边缘。
Font | 输出文字时使用的字体。
ForeColor | 部件框输出内容的前景色。
Height | 部件框的显示高度。
Left | 部件框的左端显示位置。
Name | 部件框的名称标识。
Parent | 父容器对象的 IUnknown 接口引用。
PrintType | 部件框的打印输出方式。
Tag | 部件框的标识值。
Top | 部件框的顶端显示位置。
Visible | 是否显示部件框的标志。
Width | 部件框的显示宽度。

公共方法

BringToFront | 将部件框带到 Z 顺序的前面。
LoadCursor | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
SendToBack | 将部件框发送到 Z 顺序的后面。
SetBounds | 设置部件框在其父容器中的边界位置。

请参见

IGRControl 接口


IGRTextBox成员

IGRTextBox 概述

公共属性

AlignColumn(从 IGRControl 继承) | 指定部件框水平位置对齐到明细网格列的名称。
AlignColumnSide(从 IGRControl 继承) | 部件框对齐到明细网格列的方式。
Anchor(从 IGRControl 继承) | 指定部件框的哪些边缘锚定到其容器边缘。
AsChart(从 IGRControl 继承) | 将本部件框转换为图表部件框的接口引用。
AsFieldBox(从 IGRControl 继承) | 将本部件框转换为字段框的接口引用。
AsLine(从 IGRControl 继承) | 将本部件框转换为线段的接口引用。
AsMemoBox(从 IGRControl 继承) | 转换本部件框为综合文本框的接口引用。
AsPictureBox(从 IGRControl 继承) | 将本部件框转换为图像框的接口引用。
AsRichTextBox(从 IGRControl 继承) | 将本部件框转换为RTF文本框的接口引用。
AsShapeBox(从 IGRControl 继承) | 将本部件框转换为图形框的接口引用。
AsStaticBox(从 IGRControl 继承) | 将本部件框转换为静态框的接口引用。
AsSubReport(从 IGRControl 继承) | 转换本部件框为子报表的接口引用。
AsSummaryBox(从 IGRControl 继承) | 将本部件框转换为统计框的接口引用。
AsSystemVarBox(从 IGRControl 继承) | 将本部件框转换为系统变量框的接口引用。
AsTextBox(从 IGRControl 继承) | 转换本部件框为文字框基类的接口引用。
BackColor(从 IGRControl 继承) | 部件框的背景色。
BackStyle(从 IGRControl 继承) | 部件框显示时背景的填充方式。
BorderColor(从 IGRControl 继承) | 边框线的显示颜色。
BorderStyles(从 IGRControl 继承) | 边框线的显示方式。
BorderWidth(从 IGRControl 继承) | 边框线的宽度。
CanGrow | 指示部件框高度在运行时是否可以伸展的标志。
CanShrink | 指示部件框高度在运行时是否可以收缩的标志。
Center(从 IGRControl 继承) | 指定水平与垂直方向的居中对齐方式。
ControlType(从 IGRControl 继承) | 获取本部件框的具体类型。
Cursor(从 IGRControl 继承) | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
DisplayText | 运行时文字框的显示文本。
Dock(从 IGRControl 继承) | 指定部件框停靠到父容器的哪一个边缘。
EndEllipsis | 是否用省略号(...)表示超出显示区域的文本。只有当文本不是多行显示时此属性才有意义。
Font(从 IGRControl 继承) | 输出文字时使用的字体。
ForeColor(从 IGRControl 继承) | 部件框输出内容的前景色。
Height(从 IGRControl 继承) | 部件框的显示高度。
Left(从 IGRControl 继承) | 部件框的左端显示位置。
Name(从 IGRControl 继承) | 部件框的名称标识。
Parent(从 IGRControl 继承) | 父容器对象的 IUnknown 接口引用。
PrintType(从 IGRControl 继承) | 部件框的打印输出方式。
ShowMoneyLabel | 指定是否在此文字框中显示金额标签。
ShowMoneyLine | 指定是否显示成金额线格式。
Tag(从 IGRControl 继承) | 部件框的标识值。
TextAlign | 文字的输出对齐方式。
Top(从 IGRControl 继承) | 部件框的顶端显示位置。
Visible(从 IGRControl 继承) | 是否显示部件框的标志。
Width(从 IGRControl 继承) | 部件框的显示宽度。
WordWrap | 是否多行显示文本标志。

公共方法

BringToFront(从 IGRControl 继承) | 将部件框带到 Z 顺序的前面。
LoadCursor(从 IGRControl 继承) | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
SendToBack(从 IGRControl 继承) | 将部件框发送到 Z 顺序的后面。
SetBounds(从 IGRControl 继承) | 设置部件框在其父容器中的边界位置。

请参见

IGRTextBox 接口


IGRStaticBox成员

IGRStaticBox 概述

公共属性

AlignColumn(从 IGRControl 继承) | 指定部件框水平位置对齐到明细网格列的名称。
AlignColumnSide(从 IGRControl 继承) | 部件框对齐到明细网格列的方式。
Anchor(从 IGRControl 继承) | 指定部件框的哪些边缘锚定到其容器边缘。
AsChart(从 IGRControl 继承) | 将本部件框转换为图表部件框的接口引用。
AsFieldBox(从 IGRControl 继承) | 将本部件框转换为字段框的接口引用。
AsLine(从 IGRControl 继承) | 将本部件框转换为线段的接口引用。
AsMemoBox(从 IGRControl 继承) | 转换本部件框为综合文本框的接口引用。
AsPictureBox(从 IGRControl 继承) | 将本部件框转换为图像框的接口引用。
AsRichTextBox(从 IGRControl 继承) | 将本部件框转换为RTF文本框的接口引用。
AsShapeBox(从 IGRControl 继承) | 将本部件框转换为图形框的接口引用。
AsStaticBox(从 IGRControl 继承) | 将本部件框转换为静态框的接口引用。
AsSubReport(从 IGRControl 继承) | 转换本部件框为子报表的接口引用。
AsSummaryBox(从 IGRControl 继承) | 将本部件框转换为统计框的接口引用。
AsSystemVarBox(从 IGRControl 继承) | 将本部件框转换为系统变量框的接口引用。
AsTextBox(从 IGRControl 继承) | 转换本部件框为文字框基类的接口引用。
BackColor(从 IGRControl 继承) | 部件框的背景色。
BackStyle(从 IGRControl 继承) | 部件框显示时背景的填充方式。
BorderColor(从 IGRControl 继承) | 边框线的显示颜色。
BorderStyles(从 IGRControl 继承) | 边框线的显示方式。
BorderWidth(从 IGRControl 继承) | 边框线的宽度。
CanGrow(从 IGRTextBox 继承) | 指示部件框高度在运行时是否可以伸展的标志。
CanShrink(从 IGRTextBox 继承) | 指示部件框高度在运行时是否可以收缩的标志。
Center(从 IGRControl 继承) | 指定水平与垂直方向的居中对齐方式。
ControlType(从 IGRControl 继承) | 获取本部件框的具体类型。
Cursor(从 IGRControl 继承) | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
DisplayText(从 IGRTextBox 继承) | 运行时文字框的显示文本。
Dock(从 IGRControl 继承) | 指定部件框停靠到父容器的哪一个边缘。
EndEllipsis(从 IGRTextBox 继承) | 是否用省略号(...)表示超出显示区域的文本。只有当文本不是多行显示时此属性才有意义。
Font(从 IGRControl 继承) | 输出文字时使用的字体。
ForeColor(从 IGRControl 继承) | 部件框输出内容的前景色。
Height(从 IGRControl 继承) | 部件框的显示高度。
Left(从 IGRControl 继承) | 部件框的左端显示位置。
Name(从 IGRControl 继承) | 部件框的名称标识。
Parameter | 指定关联参数对象的名称。
Parent(从 IGRControl 继承) | 父容器对象的 IUnknown 接口引用。
PrintType(从 IGRControl 继承) | 部件框的打印输出方式。
ShowMoneyLabel(从 IGRTextBox 继承) | 指定是否在此文字框中显示金额标签。
ShowMoneyLine(从 IGRTextBox 继承) | 指定是否显示成金额线格式。
Tag(从 IGRControl 继承) | 部件框的标识值。
Text | 显示文本。
TextAlign(从 IGRTextBox 继承) | 文字的输出对齐方式。
Top(从 IGRControl 继承) | 部件框的顶端显示位置。
Visible(从 IGRControl 继承) | 是否显示部件框的标志。
Width(从 IGRControl 继承) | 部件框的显示宽度。
WordWrap(从 IGRTextBox 继承) | 是否多行显示文本标志。

公共方法

BringToFront(从 IGRControl 继承) | 将部件框带到 Z 顺序的前面。
LoadCursor(从 IGRControl 继承) | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
SendToBack(从 IGRControl 继承) | 将部件框发送到 Z 顺序的后面。
SetBounds(从 IGRControl 继承) | 设置部件框在其父容器中的边界位置。

请参见

IGRStaticBox 接口 | IGRParameter 接口


IGRFieldBox成员

IGRFieldBox 概述

公共属性

AlignColumn(从 IGRControl 继承) | 指定部件框水平位置对齐到明细网格列的名称。
AlignColumnSide(从 IGRControl 继承) | 部件框对齐到明细网格列的方式。
Anchor(从 IGRControl 继承) | 指定部件框的哪些边缘锚定到其容器边缘。
AsChart(从 IGRControl 继承) | 将本部件框转换为图表部件框的接口引用。
AsFieldBox(从 IGRControl 继承) | 将本部件框转换为字段框的接口引用。
AsLine(从 IGRControl 继承) | 将本部件框转换为线段的接口引用。
AsMemoBox(从 IGRControl 继承) | 转换本部件框为综合文本框的接口引用。
AsPictureBox(从 IGRControl 继承) | 将本部件框转换为图像框的接口引用。
AsRichTextBox(从 IGRControl 继承) | 将本部件框转换为RTF文本框的接口引用。
AsShapeBox(从 IGRControl 继承) | 将本部件框转换为图形框的接口引用。
AsStaticBox(从 IGRControl 继承) | 将本部件框转换为静态框的接口引用。
AsSubReport(从 IGRControl 继承) | 转换本部件框为子报表的接口引用。
AsSummaryBox(从 IGRControl 继承) | 将本部件框转换为统计框的接口引用。
AsSystemVarBox(从 IGRControl 继承) | 将本部件框转换为系统变量框的接口引用。
AsTextBox(从 IGRControl 继承) | 转换本部件框为文字框基类的接口引用。
BackColor(从 IGRControl 继承) | 部件框的背景色。
BackStyle(从 IGRControl 继承) | 部件框显示时背景的填充方式。
BorderColor(从 IGRControl 继承) | 边框线的显示颜色。
BorderStyles(从 IGRControl 继承) | 边框线的显示方式。
BorderWidth(从 IGRControl 继承) | 边框线的宽度。
CanGrow(从 IGRTextBox 继承) | 指示部件框高度在运行时是否可以伸展的标志。
CanShrink(从 IGRTextBox 继承) | 指示部件框高度在运行时是否可以收缩的标志。
Center(从 IGRControl 继承) | 指定水平与垂直方向的居中对齐方式。
ControlType(从 IGRControl 继承) | 获取本部件框的具体类型。
Cursor(从 IGRControl 继承) | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
DataField | 获取或设置关联字段对象的名称。
DisplayText(从 IGRTextBox 继承) | 运行时文字框的显示文本。
Dock(从 IGRControl 继承) | 指定部件框停靠到父容器的哪一个边缘。
EndEllipsis(从 IGRTextBox 继承) | 是否用省略号(...)表示超出显示区域的文本。只有当文本不是多行显示时此属性才有意义。
Font(从 IGRControl 继承) | 输出文字时使用的字体。
ForeColor(从 IGRControl 继承) | 部件框输出内容的前景色。
Height(从 IGRControl 继承) | 部件框的显示高度。
Left(从 IGRControl 继承) | 部件框的左端显示位置。
Name(从 IGRControl 继承) | 部件框的名称标识。
Parent(从 IGRControl 继承) | 父容器对象的 IUnknown 接口引用。
PrintType(从 IGRControl 继承) | 部件框的打印输出方式。
ShowMoneyLabel(从 IGRTextBox 继承) | 指定是否在此文字框中显示金额标签。
ShowMoneyLine(从 IGRTextBox 继承) | 指定是否显示成金额线格式。
Tag(从 IGRControl 继承) | 部件框的标识值。
TextAlign(从 IGRTextBox 继承) | 文字的输出对齐方式。
Top(从 IGRControl 继承) | 部件框的顶端显示位置。
Visible(从 IGRControl 继承) | 是否显示部件框的标志。
Width(从 IGRControl 继承) | 部件框的显示宽度。
WordWrap(从 IGRTextBox 继承) | 是否多行显示文本标志。

公共方法

BringToFront(从 IGRControl 继承) | 将部件框带到 Z 顺序的前面。
LoadCursor(从 IGRControl 继承) | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
SendToBack(从 IGRControl 继承) | 将部件框发送到 Z 顺序的后面。
SetBounds(从 IGRControl 继承) | 设置部件框在其父容器中的边界位置。

请参见

IGRFieldBox 接口 | IGRField 接口


IGRSummaryBox成员

IGRSummaryBox 概述

公共属性

AlignColumn(从 IGRControl 继承) | 指定部件框水平位置对齐到明细网格列的名称。
AlignColumnSide(从 IGRControl 继承) | 部件框对齐到明细网格列的方式。
Anchor(从 IGRControl 继承) | 指定部件框的哪些边缘锚定到其容器边缘。
AsChart(从 IGRControl 继承) | 将本部件框转换为图表部件框的接口引用。
AsFieldBox(从 IGRControl 继承) | 将本部件框转换为字段框的接口引用。
AsLine(从 IGRControl 继承) | 将本部件框转换为线段的接口引用。
AsMemoBox(从 IGRControl 继承) | 转换本部件框为综合文本框的接口引用。
AsPictureBox(从 IGRControl 继承) | 将本部件框转换为图像框的接口引用。
AsRichTextBox(从 IGRControl 继承) | 将本部件框转换为RTF文本框的接口引用。
AsShapeBox(从 IGRControl 继承) | 将本部件框转换为图形框的接口引用。
AsStaticBox(从 IGRControl 继承) | 将本部件框转换为静态框的接口引用。
AsSubReport(从 IGRControl 继承) | 转换本部件框为子报表的接口引用。
AsSummaryBox(从 IGRControl 继承) | 将本部件框转换为统计框的接口引用。
AsSystemVarBox(从 IGRControl 继承) | 将本部件框转换为系统变量框的接口引用。
AsTextBox(从 IGRControl 继承) | 转换本部件框为文字框基类的接口引用。
BackColor(从 IGRControl 继承) | 部件框的背景色。
BackStyle(从 IGRControl 继承) | 部件框显示时背景的填充方式。
BorderColor(从 IGRControl 继承) | 边框线的显示颜色。
BorderStyles(从 IGRControl 继承) | 边框线的显示方式。
BorderWidth(从 IGRControl 继承) | 边框线的宽度。
CanGrow(从 IGRTextBox 继承) | 指示部件框高度在运行时是否可以伸展的标志。
CanShrink(从 IGRTextBox 继承) | 指示部件框高度在运行时是否可以收缩的标志。
Center(从 IGRControl 继承) | 指定水平与垂直方向的居中对齐方式。
ControlType(从 IGRControl 继承) | 获取本部件框的具体类型。
Cursor(从 IGRControl 继承) | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
DataField | 关联的数据字段对象名称。
DisplayText(从 IGRTextBox 继承) | 运行时文字框的显示文本。
Dock(从 IGRControl 继承) | 指定部件框停靠到父容器的哪一个边缘。
EndEllipsis(从 IGRTextBox 继承) | 是否用省略号(...)表示超出显示区域的文本。只有当文本不是多行显示时此属性才有意义。
Font(从 IGRControl 继承) | 输出文字时使用的字体。
ForeColor(从 IGRControl 继承) | 部件框输出内容的前景色。
Format | 统计值生成显示文字所应用的格式串。
Height(从 IGRControl 继承) | 部件框的显示高度。
Left(从 IGRControl 继承) | 部件框的左端显示位置。
Name(从 IGRControl 继承) | 部件框的名称标识。
Parent(从 IGRControl 继承) | 父容器对象的 IUnknown 接口引用。
PrintType(从 IGRControl 继承) | 部件框的打印输出方式。
ShowMoneyLabel(从 IGRTextBox 继承) | 指定是否在此文字框中显示金额标签。
ShowMoneyLine(从 IGRTextBox 继承) | 指定是否显示成金额线格式。
SummaryFun | 指定应用的统计函数。
Tag(从 IGRControl 继承) | 部件框的标识值。
TextAlign(从 IGRTextBox 继承) | 文字的输出对齐方式。
Top(从 IGRControl 继承) | 部件框的顶端显示位置。
Value | 再生成过程中，统计部件框的当前统计值。
Visible(从 IGRControl 继承) | 是否显示部件框的标志。
Width(从 IGRControl 继承) | 部件框的显示宽度。
WordWrap(从 IGRTextBox 继承) | 是否多行显示文本标志。

公共方法

BringToFront(从 IGRControl 继承) | 将部件框带到 Z 顺序的前面。
LoadCursor(从 IGRControl 继承) | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
SendToBack(从 IGRControl 继承) | 将部件框发送到 Z 顺序的后面。
SetBounds(从 IGRControl 继承) | 设置部件框在其父容器中的边界位置。

请参见

IGRSummaryBox 接口 | IGRField 接口


IGRSystemVarBox成员

IGRSystemVarBox 概述

公共属性

AlignColumn(从 IGRControl 继承) | 指定部件框水平位置对齐到明细网格列的名称。
AlignColumnSide(从 IGRControl 继承) | 部件框对齐到明细网格列的方式。
Anchor(从 IGRControl 继承) | 指定部件框的哪些边缘锚定到其容器边缘。
AsChart(从 IGRControl 继承) | 将本部件框转换为图表部件框的接口引用。
AsFieldBox(从 IGRControl 继承) | 将本部件框转换为字段框的接口引用。
AsLine(从 IGRControl 继承) | 将本部件框转换为线段的接口引用。
AsMemoBox(从 IGRControl 继承) | 转换本部件框为综合文本框的接口引用。
AsPictureBox(从 IGRControl 继承) | 将本部件框转换为图像框的接口引用。
AsRichTextBox(从 IGRControl 继承) | 将本部件框转换为RTF文本框的接口引用。
AsShapeBox(从 IGRControl 继承) | 将本部件框转换为图形框的接口引用。
AsStaticBox(从 IGRControl 继承) | 将本部件框转换为静态框的接口引用。
AsSubReport(从 IGRControl 继承) | 转换本部件框为子报表的接口引用。
AsSummaryBox(从 IGRControl 继承) | 将本部件框转换为统计框的接口引用。
AsSystemVarBox(从 IGRControl 继承) | 将本部件框转换为系统变量框的接口引用。
AsTextBox(从 IGRControl 继承) | 转换本部件框为文字框基类的接口引用。
BackColor(从 IGRControl 继承) | 部件框的背景色。
BackStyle(从 IGRControl 继承) | 部件框显示时背景的填充方式。
BorderColor(从 IGRControl 继承) | 边框线的显示颜色。
BorderStyles(从 IGRControl 继承) | 边框线的显示方式。
BorderWidth(从 IGRControl 继承) | 边框线的宽度。
CanGrow(从 IGRTextBox 继承) | 指示部件框高度在运行时是否可以伸展的标志。
CanShrink(从 IGRTextBox 继承) | 指示部件框高度在运行时是否可以收缩的标志。
Center(从 IGRControl 继承) | 指定水平与垂直方向的居中对齐方式。
ControlType(从 IGRControl 继承) | 获取本部件框的具体类型。
Cursor(从 IGRControl 继承) | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
DisplayText(从 IGRTextBox 继承) | 运行时文字框的显示文本。
Dock(从 IGRControl 继承) | 指定部件框停靠到父容器的哪一个边缘。
EndEllipsis(从 IGRTextBox 继承) | 是否用省略号(...)表示超出显示区域的文本。只有当文本不是多行显示时此属性才有意义。
Font(从 IGRControl 继承) | 输出文字时使用的字体。
ForeColor(从 IGRControl 继承) | 部件框输出内容的前景色。
Format | 系统变量值生成显示文字所应用的格式串。
Height(从 IGRControl 继承) | 部件框的显示高度。
Left(从 IGRControl 继承) | 部件框的左端显示位置。
Name(从 IGRControl 继承) | 部件框的名称标识。
Parent(从 IGRControl 继承) | 父容器对象的 IUnknown 接口引用。
PrintType(从 IGRControl 继承) | 部件框的打印输出方式。
ShowMoneyLabel(从 IGRTextBox 继承) | 指定是否在此文字框中显示金额标签。
ShowMoneyLine(从 IGRTextBox 继承) | 指定是否显示成金额线格式。
SystemVar | 指定应用的系统变量类型。
Tag(从 IGRControl 继承) | 部件框的标识值。
TextAlign(从 IGRTextBox 继承) | 文字的输出对齐方式。
Top(从 IGRControl 继承) | 部件框的顶端显示位置。
Visible(从 IGRControl 继承) | 是否显示部件框的标志。
Width(从 IGRControl 继承) | 部件框的显示宽度。
WordWrap(从 IGRTextBox 继承) | 是否多行显示文本标志。

公共方法

BringToFront(从 IGRControl 继承) | 将部件框带到 Z 顺序的前面。
LoadCursor(从 IGRControl 继承) | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
SendToBack(从 IGRControl 继承) | 将部件框发送到 Z 顺序的后面。
SetBounds(从 IGRControl 继承) | 设置部件框在其父容器中的边界位置。

请参见

IGRSystemVarBox 接口


IGRShapeBox成员

IGRShapeBox 概述

公共属性

AlignColumn(从 IGRControl 继承) | 指定部件框水平位置对齐到明细网格列的名称。
AlignColumnSide(从 IGRControl 继承) | 部件框对齐到明细网格列的方式。
Anchor(从 IGRControl 继承) | 指定部件框的哪些边缘锚定到其容器边缘。
AsChart(从 IGRControl 继承) | 将本部件框转换为图表部件框的接口引用。
AsFieldBox(从 IGRControl 继承) | 将本部件框转换为字段框的接口引用。
AsLine(从 IGRControl 继承) | 将本部件框转换为线段的接口引用。
AsMemoBox(从 IGRControl 继承) | 转换本部件框为综合文本框的接口引用。
AsPictureBox(从 IGRControl 继承) | 将本部件框转换为图像框的接口引用。
AsRichTextBox(从 IGRControl 继承) | 将本部件框转换为RTF文本框的接口引用。
AsShapeBox(从 IGRControl 继承) | 将本部件框转换为图形框的接口引用。
AsStaticBox(从 IGRControl 继承) | 将本部件框转换为静态框的接口引用。
AsSubReport(从 IGRControl 继承) | 转换本部件框为子报表的接口引用。
AsSummaryBox(从 IGRControl 继承) | 将本部件框转换为统计框的接口引用。
AsSystemVarBox(从 IGRControl 继承) | 将本部件框转换为系统变量框的接口引用。
AsTextBox(从 IGRControl 继承) | 转换本部件框为文字框基类的接口引用。
BackColor(从 IGRControl 继承) | 部件框的背景色。
BackStyle(从 IGRControl 继承) | 部件框显示时背景的填充方式。
BorderColor(从 IGRControl 继承) | 边框线的显示颜色。
BorderStyles(从 IGRControl 继承) | 边框线的显示方式。
BorderWidth(从 IGRControl 继承) | 边框线的宽度。
Center(从 IGRControl 继承) | 指定水平与垂直方向的居中对齐方式。
ControlType(从 IGRControl 继承) | 获取本部件框的具体类型。
CornerDx | 圆角矩形框的圆角椭圆宽度。
CornerDy | 圆角矩形框的圆角椭圆高度。
Cursor(从 IGRControl 继承) | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
Dock(从 IGRControl 继承) | 指定部件框停靠到父容器的哪一个边缘。
FillColor | 封闭图形对象的内部填充色。
FillStyle | 封闭图形对象的内部填充方式。
Font(从 IGRControl 继承) | 输出文字时使用的字体。
ForeColor(从 IGRControl 继承) | 部件框输出内容的前景色。
Height(从 IGRControl 继承) | 部件框的显示高度。
Left(从 IGRControl 继承) | 部件框的左端显示位置。
Name(从 IGRControl 继承) | 部件框的名称标识。
Parent(从 IGRControl 继承) | 父容器对象的 IUnknown 接口引用。
PenColor | 画图形线条的颜色。
PenStyle | 指定画线条的画笔类型。
PenWidth | 指定画线条的画笔的宽度。
PrintType(从 IGRControl 继承) | 部件框的打印输出方式。
ShapeType | 指定图形的类型。
Tag(从 IGRControl 继承) | 部件框的标识值。
Top(从 IGRControl 继承) | 部件框的顶端显示位置。
Visible(从 IGRControl 继承) | 是否显示部件框的标志。
Width(从 IGRControl 继承) | 部件框的显示宽度。

公共方法

BringToFront(从 IGRControl 继承) | 将部件框带到 Z 顺序的前面。
LoadCursor(从 IGRControl 继承) | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
SendToBack(从 IGRControl 继承) | 将部件框发送到 Z 顺序的后面。
SetBounds(从 IGRControl 继承) | 设置部件框在其父容器中的边界位置。

请参见

IGRShapeBox 接口


IGRRecordset成员

IGRRecordset 概述

公共属性

ConnectionString | 与数据源连接的参数文字串
Editable | 指定记录集在报表运行时是否为可编辑。
Fields | 拥有的字段集合对象的接口引用。
QuerySQL | 从数据源中取数的SQL语句。
RecordCount | 指示记录集中的记录条数。
RecordNo | 指示当前记录的记录号，记录号从1开始。
SkipQuery | 指示在生成报表时，是否忽略从数据源取数的属性设置。
SortAsc | 指定是否按升序排列记录。
SortCaseSensitive | 当排序字段为字符型时，指定排序比较是否为大小写字符敏感。
SortFields | 指定在报表生成时对记录进行排序的依据字段。

公共方法

AddField | 增加一个字段。
Append | 添加一条形记录。
Bof | 判断记录集的游标是否位于第一条记录之前。
Cancel | 取消当前记录的可编辑状态，并还原记录的原来数据。
Edit | 使当前记录进入可编辑状态，从而可以改变字段的值。
Empty | 请空记录集中的全部记录。
Eof | 判断记录集的游标是否位于最后一条记录之后。
First | 使第一条记录成为当前记录。
Last | 使最后一条记录成为当前记录。
MoveBy | 将游标向前或向后移动指定个数的记录。
MoveTo | 将记录集的当前记录设为指定记录号的记录。
Next | 使当前记录的下一条记录成为当前记录。
Post | 提交新增记录。
Prior | 使当前记录的上一条记录成为当前记录。
RemoveAllFields | 删除所有的字段定义。
Resort | 对记录集中的记录进行重新排序。

请参见

IGRRecordset 接口


IGRFields成员

IGRFields 概述

公共属性

_NewEnum | 返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。
Count | 指示拥有字段的个数。
Item | 根据字段的顺序号或名称得到字段的接口引用。

公共方法

Add | 根据字段类型参数增加一个字段并返回新增字段的接口引用。
IndexByName | 根据字段的名称取得其顺序号，如果不存在与名称匹配的字段，则返回-1。字段的名称不区分字母的大小写。
Remove | 根据字段的顺序号或名称将字段移除，在输入参数种指定要移除字段的顺序号或名称。
RemoveAll | 清除全部字段。

请参见

IGRFields 接口 | IGRField 接口


IGRField成员

IGRField 概述

公共属性

AsBoolean | 获取或设置字段的用布尔类型表示的值。
AsCurrency | 获取或设置字段的用货币类型表示的值。
AsDateTime | 获取或设置字段的用日期时间类型表示的值。
AsFloat | 获取或设置字段的用浮点数类型表示的值。
AsInteger | 获取或设置字段的用整数类型表示的值。
AsString | 获取或设置字段的用字符串类型表示的值。
DataBuffer | 获取存储二进制字段值的数据缓冲区内存地址指针。
DataSize | 获取存储二进制字段值的数据缓冲区的大小，以字节为计量单位。
DisplayText | 获取或设置部件框的输出显示文本。
FieldType | 获取或设置字段的数据类型。
Format | 获取或设置将字段值转换为显示文本时所应用的格式文字串。
IsNull | 获取字段值是否为空的标志。
Length | 获取或设置字符类型字段的字符长度，为 0 表示不定长类型字符类型字段。
Name | 获取或设置字段的名称标识。
Value | 获取或设置字段在运行时的值。

公共方法

Clear | 将字段的值设为空。
LoadFromFile | 运行时从文件中载入二进制字段的值。
LoadFromMemory | 运行时从内存数据缓冲区中载入二进制字段的值。

请参见

IGRField 接口


IGRColumnSection成员

IGRColumnSection 概述

公共属性

BackColor(从 IGRSection 继承) | 报表节的背景填充色。
CanGrow(从 IGRSection 继承) | 指示节高度在运行时是否可以伸展的标志。
CanShrink(从 IGRSection 继承) | 指示节高度在运行时是否可以收缩的标志。
Controls(从 IGRSection 继承) | 获取拥有的部件框集合对象的接口引用。
DetailGrid | 获取拥有本节的明细网格的接口引用。
Font(从 IGRSection 继承) | 报表节的缺省字体。
Height(从 IGRSection 继承) | 报表节的高度。
KeepTogether | 指定是否保持整个行打印生成在同一页。
Name(从 IGRSection 继承) | 报表节的名称标识。
Parent(从 IGRSection 继承) | 父对象的IUnknown接口引用。
SectionType(从 IGRSection 继承) | 指示报表节的具体类型。
Visible(从 IGRSection 继承) | 是否显示报表节的标志。

请参见

IGRColumnSection 接口


IGRColumnContent成员

IGRColumnContent 概述

公共属性

AdjustRowHeight | 指定在每页输出固定行数时，是否自动调整行的高度。
AlternatingBackColor | 指定间隔输出内容行的交替背景色。
BackColor(从 IGRSection 继承) | 报表节的背景填充色。
CanGrow(从 IGRSection 继承) | 指示节高度在运行时是否可以伸展的标志。
CanShrink(从 IGRSection 继承) | 指示节高度在运行时是否可以收缩的标志。
ContentCells | 获取拥有的内容格集合对象的接口引用。
Controls(从 IGRSection 继承) | 获取拥有的部件框集合对象的接口引用。
Cursor | 指定在查询显示报表时，在本内容行上显示的鼠标光标。
DetailGrid(从 IGRColumnSection 继承) | 获取拥有本节的明细网格的接口引用。
Font(从 IGRSection 继承) | 报表节的缺省字体。
Height(从 IGRSection 继承) | 报表节的高度。
KeepTogether(从 IGRColumnSection 继承) | 指定是否保持整个行打印生成在同一页。
Name(从 IGRSection 继承) | 报表节的名称标识。
Parent(从 IGRSection 继承) | 父对象的IUnknown接口引用。
RowsPerPage | 打印生成时，指定在一页中显示的行数。
SectionType(从 IGRSection 继承) | 指示报表节的具体类型。
Visible(从 IGRSection 继承) | 是否显示报表节的标志。

公共方法

LoadCursor 从光标文件中载入要在内容行上显示的鼠标光标。

请参见

IGRColumnContent 接口


IGRColumnTitle成员

IGRColumnTitle 概述

公共属性

BackColor(从 IGRSection 继承) | 报表节的背景填充色。
CanGrow(从 IGRSection 继承) | 指示节高度在运行时是否可以伸展的标志。
CanShrink(从 IGRSection 继承) | 指示节高度在运行时是否可以收缩的标志。
Controls(从 IGRSection 继承) | 获取拥有的部件框集合对象的接口引用。
DetailGrid(从 IGRColumnSection 继承) | 获取拥有本节的明细网格的接口引用。
Font(从 IGRSection 继承) | 报表节的缺省字体。
Height(从 IGRSection 继承) | 报表节的高度。
KeepTogether(从 IGRColumnSection 继承) | 指定是否保持整个行打印生成在同一页。
Name(从 IGRSection 继承) | 报表节的名称标识。
Parent(从 IGRSection 继承) | 父对象的IUnknown接口引用。
RepeatStyle | 在打印生成时，指定明细网格标题的重复输出方式。
SectionType(从 IGRSection 继承) | 指示报表节的具体类型。
TitleCells | 获取拥有的标题格集合对象的接口引用。
Visible(从 IGRSection 继承) | 是否显示报表节的标志。

请参见

IGRColumnTitle 接口


IGRColumnCell成员

IGRColumnCell 概述

公共属性

BackColor | 指定单元格的背景色。
Column | 本单元格对应的列的接口引用。
Controls | 本单元格所拥有的部件框集合对象的接口引用。
EndEllipsis | 指定是否用省略号表示超出单元格范围的文字。
Font | 指定输出文字时应用的字体对象的接口引用。
ForeColor | 指定单元格的输出文本的文字颜色。
FreeCell | 指定本单元格是否为自由格。
Name | 指定单元格的名称标识。
PrintType | 指定单元格的打印生成类别。
ShowMoneyLabel | 指定是否在此单元格中显示金额标签。
ShowMoneyLine | 指定是否在此单元格中将值显示成金额线格式。
TextAlign | 指定显示文本的文字对齐方式。
WordWrap | 指定文字是否折行输出的标志。

请参见

IGRColumnCell 接口


IGRColumnContentCell成员

IGRColumnContentCell 概述

公共属性

BackColor(从 IGRColumnCell 继承) | 指定单元格的背景色。
CanGrow | 指定内容格在运行时是否可以伸展高度。
CanShrink | 指定内容格在运行时是否可以收缩高度。
Column(从 IGRColumnCell 继承) | 本单元格对应的列的接口引用。
Controls(从 IGRColumnCell 继承) | 本单元格所拥有的部件框集合对象的接口引用。
Cursor | 指定在查询显示报表时，在本内容格上显示的鼠标光标。
DataField | 指定本内容格关联的记录集字段的名称，在运行时将显示关联字段的显示文字。
EndEllipsis(从 IGRColumnCell 继承) | 指定是否用省略号表示超出单元格范围的文字。
Font(从 IGRColumnCell 继承) | 指定输出文字时应用的字体对象的接口引用。
ForeColor(从 IGRColumnCell 继承) | 指定单元格的输出文本的文字颜色。
FreeCell(从 IGRColumnCell 继承) | 指定本单元格是否为自由格。
Name(从 IGRColumnCell 继承) | 指定单元格的名称标识。
Parent | 获取拥有本内容格的内容行的接口引用。
PrintType(从 IGRColumnCell 继承) | 指定单元格的打印生成类别。
ShowMoneyLabel(从 IGRColumnCell 继承) | 指定是否在此单元格中显示金额标签。
ShowMoneyLine(从 IGRColumnCell 继承) | 指定是否在此单元格中将值显示成金额线格式。
TextAlign(从 IGRColumnCell 继承) | 指定显示文本的文字对齐方式。
WordWrap(从 IGRColumnCell 继承) | 指定文字是否折行输出的标志。

公共方法

LoadCursor 从光标文件中载入要在本内容格上显示的鼠标光标。

请参见

IGRColumnContentCell 接口


IGRColumnTitleCell成员

IGRColumnTitleCell 概述

公共属性

BackColor(从 IGRColumnCell 继承) | 指定单元格的背景色。
Column(从 IGRColumnCell 继承) | 本单元格对应的列的接口引用。
Controls(从 IGRColumnCell 继承) | 本单元格所拥有的部件框集合对象的接口引用。
EndEllipsis(从 IGRColumnCell 继承) | 指定是否用省略号表示超出单元格范围的文字。
Font(从 IGRColumnCell 继承) | 指定输出文字时应用的字体对象的接口引用。
ForeColor(从 IGRColumnCell 继承) | 指定单元格的输出文本的文字颜色。
FreeCell(从 IGRColumnCell 继承) | 指定本单元格是否为自由格。
GroupTitle | 指定本标题格是否为组标题格。
Name(从 IGRColumnCell 继承) | 指定单元格的名称标识。
Parent | 获取拥有本标题格的标题行对象的接口引用。
PrintType(从 IGRColumnCell 继承) | 指定单元格的打印生成类别。
ShowMoneyLabel(从 IGRColumnCell 继承) | 指定是否在此单元格中显示金额标签。
ShowMoneyLine(从 IGRColumnCell 继承) | 指定是否在此单元格中将值显示成金额线格式。
SubTitles | 获取本标题格拥有的直接下级标题格集合对象的接口引用。
Text | 指定标题格的显示文本。
TextAlign(从 IGRColumnCell 继承) | 指定显示文本的文字对齐方式。
Visible | 指定是否显示本标题格。
WordWrap(从 IGRColumnCell 继承) | 指定文字是否折行输出的标志。

公共方法

AddSubGroupTitle | 在此组标题格中增加一个下级组标题格。
EncloseColumn | 将一个列对应的标题格包含到此组标题格中，新包含进来的列标题格在显示顺序上处于本组的最后。

请参见

IGRColumnTitleCell 接口


IGRColumnContentCells成员

IGRColumnContentCells 概述

公共属性

_NewEnum | 返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。
Count | 指示拥有内容格的个数。
Item | 根据内容格的顺序号或名称得到内容格的接口引用。

公共方法

IndexByName 根据内容格的名称取得其顺序号，如果不存在与名称匹配的内容格，则返回值为-1。内容格的名称不区分字母的大小写。

请参见

IGRColumnContentCells 接口 | IGRColumnContentCell 接口


IGRColumnTitleCells成员

IGRColumnTitleCells 概述

公共属性

_NewEnum | 返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。
Count | 指示拥有标题格的个数。
Item | 根据标题格的顺序号或名称得到标题格的接口引用。

公共方法

AddGroup | 增加一个组标题格。
IndexByName | 根据标题格的名称取得其顺序号，如果不存在与名称匹配的标题格，则返回-1。标题格的名称不区分字母大小写。
RemoveGroup | 根据组标题格的顺序号或名称移除一个组标题格。

请参见

IGRColumnTitleCells 接口 | IGRColumnTitleCell 接口


IGRColumns成员

IGRColumns 概述

公共属性

_NewEnum | 返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。
Count | 指示拥有列的个数。
Item | 根据列的顺序号或名称得到列的接口引用。

公共方法

Add | 增加一个列并返回新增列的接口引用。
IndexByName | 根据列的名称取得其顺序号，如果不存在与名称匹配的列，则返回值为-1。列的名称不区分字母的大小写。
Remove | 根据列的顺序号或名称将列移除。
RemoveAll | 清除全部列。

请参见

IGRColumns 接口 | IGRColumn 接口


IGRColumn成员

IGRColumn 概述

公共属性

ContentCell | 本列对应的内容格的接口引用。
Name | 列的名称标识，必须保证每个列的名称唯一。
Parent | 拥有列的明细网格的接口引用。
TitleCell | 本列对应的标题格的接口引用。
Visible | 指定列在输出时是否可见。
Width | 列的显示宽度。

请参见

IGRColumn 接口


IGRGroups成员

IGRGroups 概述

公共属性

_NewEnum | 返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。
Count | 指示拥有分组的个数。
Item | 根据分组的顺序号或名称得到列分组接口引用。

公共方法

Add | 增加一个分组并返回新增分组的接口引用。
IndexByName | 根据分组的名称取得其顺序号，如果不存在与名称匹配的分组，则返回-1。分组的名称不区分字母的大小写。
Remove | 根据分组的顺序号或名称将分组移除，在输入参数种指定要移除分组的顺序号或名称。
RemoveAll | 清除全部分组。

请参见

IGRGroups 接口 | IGRGroup 接口


IGRGroup成员

IGRGroup 概述

公共属性

_DataSet | Used by internal。
ByFields | 获取或设置分组依据字段的名称。
Footer | 获取本分组拥有的分组尾对象的接口引用。
Header | 获取本分组拥有的分组头对象的接口引用。
Name | 获取或设置分组的名称标识。
PageGroup | 获取或设置本分组是否为页分组的标志。
Parent | 获取父对象引用，亦即明细网格的接口引用。

请参见

IGRGroup 接口


IGRGroupSection成员

IGRGroupSection 概述

公共属性

BackColor(从 IGRSection 继承) | 报表节的背景填充色。
CanGrow(从 IGRSection 继承) | 指示节高度在运行时是否可以伸展的标志。
CanShrink(从 IGRSection 继承) | 指示节高度在运行时是否可以收缩的标志。
Controls(从 IGRSection 继承) | 获取拥有的部件框集合对象的接口引用。
Font(从 IGRSection 继承) | 报表节的缺省字体。
Group | 获取拥有本分组节的分组对象的接口引用。
Height(从 IGRSection 继承) | 报表节的高度。
KeepTogether | 获取或设置是否保持本分组节输出显示在相同页的标志。
Name(从 IGRSection 继承) | 报表节的名称标识。
NewPage | 获取或设置换新页的产生方式。
Parent(从 IGRSection 继承) | 父对象的IUnknown接口引用。
PrintGridBorder | 获取或设置是否打印本分组节对应位置的明细网格边框。
SectionType(从 IGRSection 继承) | 指示报表节的具体类型。
Visible(从 IGRSection 继承) | 是否显示报表节的标志。

请参见

IGRGroupSection 接口


IGRGroupHeader成员

IGRGroupHeader 概述

公共属性

BackColor(从 IGRSection 继承) | 报表节的背景填充色。
CanGrow(从 IGRSection 继承) | 指示节高度在运行时是否可以伸展的标志。
CanShrink(从 IGRSection 继承) | 指示节高度在运行时是否可以收缩的标志。
Controls(从 IGRSection 继承) | 获取拥有的部件框集合对象的接口引用。
Font(从 IGRSection 继承) | 报表节的缺省字体。
Group(从 IGRGroupSection 继承) | 获取拥有本分组节的分组对象的接口引用。
GroupKeepTogether | 打印输出时，指定本分组项的分组头与其它行保持同页的方式。
Height(从 IGRSection 继承) | 报表节的高度。
IncludeFooter | 为占列式分组头时，获取或设置分组尾是否被包含在占列分组中的标志。
KeepTogether(从 IGRGroupSection 继承) | 获取或设置是否保持本分组节输出显示在相同页的标志。
Name(从 IGRSection 继承) | 报表节的名称标识。
NewPage(从 IGRGroupSection 继承) | 获取或设置换新页的产生方式。
NewPageColumn | 指定强制换新页栏的方式。
OccupiedColumns | 为占列式分组头时，指定占据列的名称。
OccupyColumn | 获取或设置是否为占列式分组头的标志。
Parent(从 IGRSection 继承) | 父对象的IUnknown接口引用。
PrintGridBorder(从 IGRGroupSection 继承) | 获取或设置是否打印本分组节对应位置的明细网格边框。
RepeatOnPage | 指定是否在新页中重复显示当前分组项的分组头。
SameAsColumn | 为占列式分组头时，获取或设置是否采用占据列的内容格定义进行显示的标志。
SectionType(从 IGRSection 继承) | 指示报表节的具体类型。
VAlign | 为占列式分组头时，获取或设置显示位置在垂直方向上的对齐方式。
Visible(从 IGRSection 继承) | 是否显示报表节的标志。

请参见

IGRGroupHeader 接口 | IGRGroupFooter 接口


IGRGroupFooter成员

IGRGroupFooter 概述

公共属性

BackColor(从 IGRSection 继承) | 报表节的背景填充色。
CanGrow(从 IGRSection 继承) | 指示节高度在运行时是否可以伸展的标志。
CanShrink(从 IGRSection 继承) | 指示节高度在运行时是否可以收缩的标志。
Controls(从 IGRSection 继承) | 获取拥有的部件框集合对象的接口引用。
Font(从 IGRSection 继承) | 报表节的缺省字体。
Group(从 IGRGroupSection 继承) | 获取拥有本分组节的分组对象的接口引用。
Height(从 IGRSection 继承) | 报表节的高度。
KeepTogether(从 IGRGroupSection 继承) | 获取或设置是否保持本分组节输出显示在相同页的标志。
Name(从 IGRSection 继承) | 报表节的名称标识。
NewPage(从 IGRGroupSection 继承) | 获取或设置换新页的产生方式。
Parent(从 IGRSection 继承) | 父对象的IUnknown接口引用。
PrintAtBottom | 打印输出时，指定是否将本节显示在页面底部。
PrintGridBorder(从 IGRGroupSection 继承) | 获取或设置是否打印本分组节对应位置的明细网格边框。
SectionType(从 IGRSection 继承) | 指示报表节的具体类型。
Visible(从 IGRSection 继承) | 是否显示报表节的标志。

请参见

IGRGroupFooter 接口 | IGRGroupHeader 接口


IGRPrinter成员

IGRPrinter 概述

公共属性

BottomMargin | 页面的下边距。
Collate | 指示打印文档是否逐份打印。
Copies | 获取或设置要打印的文档份数。
LeftMargin | 页面的左边距。
PageCount | 指示当前打印文档的总页数。
PaperLength | 获取或设置打印纸张的长度。
PaperName | 打印纸张的名称。
PaperOrientation | 打印纸张的方向。
PaperSize | 表示打印纸张的大小。
PaperSource | 指定打印机的纸张来源。
PaperWidth | 获取或设置打印纸张的宽度。
PrinterName | 在运行时，获取或设置使用打印机的名称。
PrintPageType | 指定从选定的页范围中输出的页类型。
PrintRangeType | 指定打印输出选定的页范围。
RightMargin | 页面的右边距。
SelectionPrintPages | 用文本指定的页范围，仅当PrintRangeType为grprtSelectionPages时才有效。
TopMargin | 页面的上边距。

公共方法

PageSetupDialog | 显示页面设置对话框。
PrintDialog | 显示打印对话框。
PrinterSetupDialog | 显示打印机设置对话框

请参见

IGRPrinter 接口


IGRColumn.ContentCell 属性

本列对应的内容格的接口引用。

IGRColumnContentCell *ContentCell

特征

只读

请参见

IGRColumn 接口 | IGRColumn 成员 | IGRColumnContentCell 接口 | IGRColumn.TitleCell 属性 | 属性特征说明


IGRColumn.TitleCell 属性

本列对应的标题格的接口引用。

IGRColumnTitleCell *TitleCell

特征

只读

请参见

IGRColumn 接口 | IGRColumn 成员 | IGRColumnTitleCell 接口 | IGRColumn.ContentCell 属性 | 属性特征说明


IGRColumns._NewEnum 属性

返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。

IUnknown *_NewEnum

特征

只读

请参见

IGRColumns 接口 | IGRColumns 成员 | 属性特征说明


IGRColumnTitleCell.Parent 属性

获取拥有本标题格的标题行对象的接口引用。

IGRColumnTitle *Parent

特征

只读

请参见

IGRColumnTitleCell 接口 | IGRColumnTitleCell 成员 | IGRColumnTitle 接口 | 属性特征说明


IGRColumnTitleCell.SubTitles 属性

获取本标题格拥有的直接下级标题格集合对象的接口引用。

IGRColumnTitleCells *SubTitles

特征

只读

请参见

IGRColumnTitleCell 接口 | IGRColumnTitleCell 成员 | IGRColumnTitleCells 接口 | IGRColumnTitleCell.GroupTitle 属性 | 属性特征说明


IGRColumnContentCells._NewEnum 属性

返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。

IUnknown *_NewEnum

特征

只读

请参见

IGRColumnContentCells 接口 | IGRColumnContentCells 成员 | 属性特征说明


IGRColumnTitleCells._NewEnum 属性

返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。

IUnknown *_NewEnum

特征

只读

请参见

IGRColumnTitleCells 接口 | IGRColumnTitleCells 成员 | 属性特征说明


IGRControl.Parent 属性

父容器对象的 IUnknown 接口引用。

IUnknown *Parent

特征

只读

请参见

IGRControl 接口 | IGRControl 成员 | 属性特征说明


IGRTextBox.EndEllipsis 属性

是否用省略号(...)表示超出显示区域的文本。只有当文本不是多行显示时此属性才有意义。

VARIANT_BOOL EndEllipsis

默认值

FALSE

特征

可读写

设计器中可见

请参见

IGRTextBox 接口 | IGRTextBox 成员 | IGRTextBox.TextAlign 属性 | IGRTextBox.WordWrap 属性 | 属性特征说明


IGRControls._NewEnum 属性

返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。

IUnknown *_NewEnum

特征

只读

请参见

IGRControls 接口 | IGRControls 成员 | 属性特征说明


IGRReportHeader.KeepTogether 属性

是否保持本节输出显示在同一页标志。

VARIANT_BOOL KeepTogether

默认值

TRUE

特征

可读写

设计器中可见

仅用于打印

请参见

IGRReportHeader 接口 | IGRReportHeader 成员 | 属性特征说明


IGRReportHeader.NewPage 属性

指定新页的产生方式。

GRNewPageStyle NewPage

默认值

drnpsNone

特征

可读写

设计器中可见

仅用于打印

请参见

IGRReportHeader 接口 | IGRReportHeader 成员 | GRNewPageStyle 枚举 | 属性特征说明


IGRGroup.Parent 属性

获取父对象引用，亦即明细网格的接口引用。

IGRDetailGrid *Parent

特征

可读写

请参见

IGRGroup 接口 | IGRGroup 成员 | IGRDetailGrid 接口 | 属性特征说明


IGRGroups._NewEnum 属性

返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。

IUnknown *_NewEnum

特征

只读

请参见

IGRGroups 接口 | IGRGroups 成员 | 属性特征说明


IGRFields._NewEnum 属性

返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。

IUnknown *_NewEnum

特征

只读

请参见

IGRFields 接口 | IGRFields 成员 | 属性特征说明


IGRReportFooter.RepeatOnPage 属性

打印输出时，是否在每页中重复显示的标志。

VARIANT_BOOL RepeatOnPage

默认值

FALSE

特征

可读写

设计器中可见

仅用于打印

请参见

IGRReportFooter 接口 | IGRReportFooter 成员 | 属性特征说明


IGRReportHeader.RepeatOnPage 属性

是否在每页中重复输出显示标志。

VARIANT_BOOL RepeatOnPage

默认值

FALSE

特征

可读写

设计器中可见

仅用于打印

请参见

IGRReportHeader 接口 | IGRReportHeader 成员 | 属性特征说明


IGRSystemVarBox.Format 属性

系统变量值生成显示文字所应用的格式串。

BSTR Format

特征

可读写

设计器中可见

请参见

IGRSystemVarBox 接口 | IGRSystemVarBox 成员 | 属性特征说明


IGRStaticBox.Parameter 属性

指定关联参数对象的名称。

BSTR Parameter

特征

可读写

设计器中可见

请参见

IGRStaticBox 接口 | IGRStaticBox 成员 | IGRParameter 接口 | 属性特征说明


IGRParameter成员

IGRParameter 概述

公共属性

AsBoolean | 获取或设置布尔值，只有当为布尔类型参数时才能成功使用此属性。
AsDateTime | 获取或设置日期时间值，只有当为日期时间类型参数时才能成功使用此属性。
AsFloat | 获取或设置浮点数值，只有当为浮点数类型参数时才能成功使用此属性。
AsInteger | 获取或设置整数值，只有当为整数类型参数时才能成功使用此属性。
AsString | 获取或设置文本值，只有当为文本类型参数时才能成功使用此属性。
DataType | 指示参数的数据类型。
DisplayText | 参数的输出显示文本。
Format | 整数、浮点数、日期时间类型的参数生成输出显示文本的格式串。
IsNull | 参数的值是否为空标志。
Name | 参数的名称标识。
Value | 参数的值。

请参见

IGRParameter 接口 | IGRStaticBox 接口


IGridppReport.Clear 方法

清除所有的报表模板定义数据，使报表主对象成为一张空白报表。

void Clear(void);

说明

如果要用完全编程的方式定义报表模板数据，在定义数据之前，有必要调用此方法将已存在的旧数据全部清除掉。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.LoadFromFile 方法


IGRDesigner 概述

IGRDesigner 接口

表示报表设计器。

有关此接口所有成员的列表，请参阅 IGRDesigner 成员。

IDispatch
IGRDesigner

说明

报表设计器是一个ActiveX控件。报表设计器提供设计报表模板的操作界面，并提供属性与方法与设计器进行交互处理。设计器界面主要有布局窗口，属性编辑窗口，对象浏览窗口三部分组成，在布局窗口中可以对可显示的报表元素进行位置与大小的设计；在属性编辑窗口中可以查看与修改当前选中的报表元素对象的属性数据；在对象浏览窗口中以树形结构的方式将所有的报表元素对象列出，不可显示的报表元素对象可以在此窗口中选中。

报表开发者可以利用报表设计器构件定义自己的报表设计器，通过提供外围操作界面与设计器构件进行交互，从而为报表用户提供自定义的报表设计器，使用户在运行时可以对报表进行修改。

请参见

IGRDesigner 成员 | IGridppReport 接口


IGRDesigner成员

IGRDesigner 概述

公共属性

AsFormUI | 指示是否按页面模式显示报表布局窗口。
AsNativeUI | 指示设计器是否显示为全中文界面
Dirty | 指示设计器中的数据是否已修改并未保存的标志。
OnlyLayout | 指示设计器只能进行改变位置大小的操作。
Options | 指定定制报表设计器的选项值。
Published | 指定要公开的属性类别组合值。
Report | 关联报表主对象的接口引用。设计器将显示关联报表主对象的数据。
ShowExplorer | 是否显示对象浏览器窗口标志。
ShowInspector | 是否显示属性编辑窗口标志。
WindowLayout | 指示报表布局窗口在整个控件中的停靠位置。

公共方法

CancelInsertControl | 取消设计器插入部件框状态，使其回到平常操作状态。
DisableAllOptions | 关闭所有的控制选项。
DisableAllPublished | 隐藏所有的属性类别。
DoAction | 执行设计其的某个动作。
EnableAllOptions | 开启所有的控制选项。
EnableAllPublished | 公开所有的属性类别。
GetOptionValue | 获取指定的控制选项是否开启。
GetPublishedValue | 获取指定的属性类别是否为公开状态。
IsActionEnabled | 判断某个动作在此时是否可以执行。
Post | 将设计器中的当前报表模板数据提交到关联的报表主对象中去。
PrepareInsertControl | 使设计器进入插入部件框状态，在参数中指定部件框的类型。
Reload | 从关联的报表主对象中重新载入模板数据。
SetOptionValue | 设置开启或关闭指定的控制选项。
SetPublishedValue | 设置公开或隐藏指定的属性类别。

事件

ExplorerContextMenu | 当在对象浏览窗口中执行打开关联弹出式菜单时触发本事件。
InspectorContextMenu | 当在属性编辑窗口中执行打开关联弹出式菜单时触发本事件。
LayoutPanelContextMenu | 当在报表布局窗口中执行打开关联弹出式菜单时触发本事件。

请参见

IGRDesigner 接口 | IGridppReport 接口


IGRDisplayViewer 概述

IGRDisplayViewer 接口

表示报表查询显示器。

有关此接口所有成员的列表，请参阅 IGRDisplayViewer 成员。

IDispatch
IGRDisplayViewer

说明

是报表查询显示器的ActiveX Control对象的接口定义。在使用时要关联一个报表主对象。开始运行时向报表主对象发出生成数据请求，然后本构件显示报表主对象生成的数据，本对象为最终用户提供了完善的查看显示数据的操作。报表开发人员通过对本对象交互事件的响应，为最终用户提供可交互的互操作。例如通过对汇总报表的明细网格内容格的双击事件的响应，打开对应的明细报表，达到从汇总报表向明细报表的穿透查询。

请参见

IGRDisplayViewer 成员 | IGridppReport 接口


IGRDisplayViewer成员

IGRDisplayViewer 概述

公共属性

BorderStyle | 指定查询显示器的边框样式。
BottomGap | 下边留出的空白间距，以像素为单位。
GridTitle3D | 指定是否将明细网格的列标题显示为3D形状。
HScrollPos | 在运行时，获取与设置水平滚动条的位置。
LeftGap | 左边留出的空白间距，以像素为单位。
Report | 关联报表主对象的接口引用。
Resortable | 指定是否可以通过点击明细网格的列标题对明细记录进行重新排序。
ResortCaseSensitive | 指定点击列标题进行排序时，对字符进行排序比较是否大小写敏感。
ResortDefaultAsc | 当点击列标题进行排序时，首先是否按升序进行排序。
RightGap | 右边留出的空白间距，以像素为单位。
RowCount | 运行时，当前查看报表的总行数。
SelColumnNo | 选中单元格的列序号。
SelRowNo | 选中单元格的行序号。
ShowFooter | 是否显示报表尾的标志。
ShowHeader | 是否显示报表头的标志。
SortColumnNo | 指定当前进行排序的列序号，如果没有按任何列进行排序，该属性值为-1。
TopGap | 上边留出的空白间距，以像素为单位。
VScrollPos | 在运行时，获取与设置垂直滚动条的位置。

公共方法

GetColumnVisible | 取得指定列在查询显示器中的显示或隐藏状态。
GetContentCellFromPos | 取得指定位置处的内容格对象的接口引用。
GetControlFromPos | 取得指定位置处的部件框对象的接口引用。
GetSectionFromPos | 取得指定位置处的报表节对象的接口引用。
GetTitleCellFromPos | 取得指定位置处的标题格对象的接口引用。
PostColumnLayout | 将报表列的当前显示顺序与宽度信息提交到关联报表主对象中去。
Refresh | 刷新数据，报表重新生成。
SetColumnVisible | 设置指定列在查询显示器中的显示或隐藏状态。
Start | 开始报表生成与查询显示。
Stop | 完成报表的查询显示输出。
Update | 更形显示整个查询显示器。
UpdateControl | 更新显示指定的部件框。
UpdateSelCell | 更新显示当前选中内容格。
UpdateSelRow | 更新显示当前选中内容行。
UpdateView | 当改变列的显示状态之后，调用本方法更新列的显示。

事件

Click | 当鼠标在查询显示器上进行了点击时触发。
ColumnLayoutChange | 当列的显示宽度或顺序发生改变时触发。
ContentCellClick | 当鼠标点击在某个内容格上时触发。
ContentCellDblClick | 当鼠标双击在某个内容格上时触发。
ControlClick | 当鼠标点击在某个部件框上时触发。
ControlDblClick | 当鼠标双击在某个部件框上时触发。
DblClick | 当鼠标在查询显示器上进行了双击时触发。
KeyDown | 当查询显示器拥有输入焦点时，某个键盘健按下时触发。
KeyPress | 当查询显示器拥有输入焦点时，某个键盘健按下时触发。
KeyUp | 当查询显示器拥有输入焦点时，某个键盘健按下之后再释放时触发。
MouseDown | 在查询显示器上鼠标按钮按下时触发。
MouseMove | 在查询显示器上鼠标光标移动时触发。
MouseUp | 在查询显示器上鼠标按钮按下再释放时触发。
SectionClick | 当鼠标点击在某个节上时触发。
SectionDblClick | 当鼠标双击在某个节上时触发。
SelectionCellChange | 当前显示的单元格发生改变时触发。
TitleCellClick | 当鼠标点击在某个标题格上时触发。
TitleCellDblClick | 当鼠标双击在某个标题格上时触发。

请参见

IGRDisplayViewer 接口 | IGridppReport 接口


IGRParameters成员

IGRParameters 概述

公共属性

_NewEnum | 返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。
Count | 指示拥有参数的个数。
Item | 根据参数的顺序号或名称得到参数的接口引用。

公共方法

Add | 增加一个参数并返回新增参数的接口引用。
IndexByName | 根据参数的名称取得其顺序号，如果不存在与名称匹配的参数，则返回-1。参数的名称不区分字母的大小写。
Remove | 根据参数的顺序号或名称将参数移除，在输入参数种指定要移除参数的顺序号或名称。
RemoveAll | 清除全部参数。

请参见

IGRParameters 接口 | IGRParameter 接口


IGRPrintViewer 概述

IGRPrintViewer 接口

表示报表打印预览查看器。

有关此接口所有成员的列表，请参阅 IGRPrintViewer 成员。

IDispatch
IGRPrintViewer

请参见

IGRPrintViewer 成员


IGRPrintViewer成员

IGRPrintViewer 概述

公共属性

ColPages | 多页查看模式下，每行显示的页数。
CurPageNo | 当前显示页的页号。页号从一开始计数。
GenerateStyle | 指定打印数据的生成方式。
PageCount | 报表的总页数。
Report | 获取或设置关联报表主对象的接口引用。
RowPages | 多页查看模式下，每列显示的页数。
ShowRuler | 是否显示标尺标志。
ShowToolbar | 是否显示工具条标志。
ViewMode | 打印页面的查看模式。
ZoomPercent | 打印页面的查看显示百分比例。

公共方法

AddToolbarControl | 向工具栏中增加一个指定的操作界面元素。
LoadFromDocumentFile | 载入指定的 Grid++Report 文档文件并在打印查看器中显示。
NextPage | 显示下一页打印页面。
Print | 打印出打印查看器生成的打印数据。
PriorPage | 显示上一页打印页面。
Refresh | 重新生成打印数据，并更新显示。
ResetToolbarContent | 清除工具栏中的全部操作界面元素。
Start | 开始生成报表数据，生成打印数据，并将打印数据数据显示出来。
Stop | 结束打印查看。
UpdateToolbar | 更新工具栏的显示。
ZoomIn | 增大显示比例。
ZoomOut | 缩小显示比例。
ZoomToFit | 缩放页面显示比例到刚好在查看区域中完整显示出来。
ZoomToHeight | 缩放页面显示比例到刚好使其高度在查看区域中完整显示出来。
ZoomToWidth | 缩放页面显示比例到刚好使其宽度在查看区域中完整显示出来。

事件

Click | 当鼠标在打印查看器上点击时触发。
DblClick | 当鼠标在打印查看器上双击时触发。
KeyDown | 当打印查看器拥有输入焦点时，某个键盘健按下时触发。
KeyPress | 当打印查看器拥有输入焦点时，某个键盘健按下时触发。
KeyUp | 当打印查看器拥有输入焦点时，某个键盘健按下再释放时触发。
MouseDown | 在打印查看器上鼠标按钮按下时触发。
MouseMove | 在打印查看器上鼠标移动时触发。
MouseUp | 在打印查看器上鼠标按钮按下之后再释放时触发。
PageClick | 当鼠标在页面的显示区域上点击时触发。
PageDblClick | 当鼠标在页面的显示区域上双击时触发。
RulerClick | 当鼠标在标尺上点击时触发。
RulerDblClick | 当鼠标在标尺上双击时触发。
StatusChange | 当打印查看器的状态信息改变时触发。

请参见

IGRPrintViewer 接口


IGRParameters._NewEnum 属性

返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。

IUnknown *_NewEnum

特征

只读

请参见

IGRParameters 接口 | IGRParameters 成员 | 属性特征说明


IGRSections._NewEnum 属性

返回VB需要的枚举器，VB在执行For_Each语句时需要，非VB开发者不用关心此属性。

IUnknown *_NewEnum

特征

只读

请参见

IGRSections 接口 | IGRSections 成员 | 属性特征说明


IGRFont成员

IGRFont 概述

公共属性

Bold | 该值指示此字体对象是否为粗体。
Charset | 该值指定此字体对象使用的 GDI 字符集。
Italic | 指示此字体对象是否为斜体。
Name | 此字体对象的字体名称。
OleFont | 指定字体对象拥有的OLE字体对象的接口引用。
Point | 指示此字体对象的字体大小尺寸，一般此值等同字体在字体对话框中显示的大小值。
Strikethrough | 该值指示此字体对象是否指定通过该字体的横线。
Underline | 该值指示此字体对象是否有下划线。
UsingOleFont | 指定拥有此字体的报表对象在显示文本时所应用的OLE字体的接口引用。
Weight | 该值用数字指示此字体对象的字体粗细，比 Bold 属性更具灵活性。

请参见

IGRFont 接口 | IGridppReport 接口 | IGRDetailGrid 接口 | IGRSection 接口 | IGRColumnCell 接口 | IGRControl 接口


IGRPictureBox成员

IGRPictureBox 概述

公共属性

AlignColumn(从 IGRControl 继承) | 指定部件框水平位置对齐到明细网格列的名称。
AlignColumnSide(从 IGRControl 继承) | 部件框对齐到明细网格列的方式。
Alignment | 指定图像在图像框中的显示对齐方式。
Anchor(从 IGRControl 继承) | 指定部件框的哪些边缘锚定到其容器边缘。
AsChart(从 IGRControl 继承) | 将本部件框转换为图表部件框的接口引用。
AsFieldBox(从 IGRControl 继承) | 将本部件框转换为字段框的接口引用。
AsLine(从 IGRControl 继承) | 将本部件框转换为线段的接口引用。
AsMemoBox(从 IGRControl 继承) | 转换本部件框为综合文本框的接口引用。
AsPictureBox(从 IGRControl 继承) | 将本部件框转换为图像框的接口引用。
AsRichTextBox(从 IGRControl 继承) | 将本部件框转换为RTF文本框的接口引用。
AsShapeBox(从 IGRControl 继承) | 将本部件框转换为图形框的接口引用。
AsStaticBox(从 IGRControl 继承) | 将本部件框转换为静态框的接口引用。
AsSubReport(从 IGRControl 继承) | 转换本部件框为子报表的接口引用。
AsSummaryBox(从 IGRControl 继承) | 将本部件框转换为统计框的接口引用。
AsSystemVarBox(从 IGRControl 继承) | 将本部件框转换为系统变量框的接口引用。
AsTextBox(从 IGRControl 继承) | 转换本部件框为文字框基类的接口引用。
BackColor(从 IGRControl 继承) | 部件框的背景色。
BackStyle(从 IGRControl 继承) | 部件框显示时背景的填充方式。
BorderColor(从 IGRControl 继承) | 边框线的显示颜色。
BorderStyles(从 IGRControl 继承) | 边框线的显示方式。
BorderWidth(从 IGRControl 继承) | 边框线的宽度。
Center(从 IGRControl 继承) | 指定水平与垂直方向的居中对齐方式。
ControlType(从 IGRControl 继承) | 获取本部件框的具体类型。
Cursor(从 IGRControl 继承) | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
DataField | 关联字段对象的名称。
Dock(从 IGRControl 继承) | 指定部件框停靠到父容器的哪一个边缘。
Font(从 IGRControl 继承) | 输出文字时使用的字体。
ForeColor(从 IGRControl 继承) | 部件框输出内容的前景色。
Height(从 IGRControl 继承) | 部件框的显示高度。
ImageIndex | 指定图像框关联图像集合中某个图像的序号。
Left(从 IGRControl 继承) | 部件框的左端显示位置。
Name(从 IGRControl 继承) | 部件框的名称标识。
Parent(从 IGRControl 继承) | 父容器对象的 IUnknown 接口引用。
Picture | 获取或设置图像数据的Ole接口引用。
PrintType(从 IGRControl 继承) | 部件框的打印输出方式。
SizeMode | 指定图像在图像框中显示时的伸缩方式。
Tag(从 IGRControl 继承) | 部件框的标识值。
Top(从 IGRControl 继承) | 部件框的顶端显示位置。
Visible(从 IGRControl 继承) | 是否显示部件框的标志。
Width(从 IGRControl 继承) | 部件框的显示宽度。

公共方法

AttachSystemImage | 关联一个系统图像到本图像框,从而在本图像框中显示一个系统图像。
BringToFront(从 IGRControl 继承) | 将部件框带到 Z 顺序的前面。
LoadCursor(从 IGRControl 继承) | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
LoadFromFile | 运行时从磁盘文件中载入图像文件。
LoadFromMemory | 运行时从内存中载入图像数据。
SendToBack(从 IGRControl 继承) | 将部件框发送到 Z 顺序的后面。
SetBounds(从 IGRControl 继承) | 设置部件框在其父容器中的边界位置。

请参见

IGRPictureBox 接口 | IGRImageList 接口 | GRSystemImage 枚举


IGRRichTextBox成员

IGRRichTextBox 概述

公共属性

AlignColumn(从 IGRControl 继承) | 指定部件框水平位置对齐到明细网格列的名称。
AlignColumnSide(从 IGRControl 继承) | 部件框对齐到明细网格列的方式。
Anchor(从 IGRControl 继承) | 指定部件框的哪些边缘锚定到其容器边缘。
AsChart(从 IGRControl 继承) | 将本部件框转换为图表部件框的接口引用。
AsFieldBox(从 IGRControl 继承) | 将本部件框转换为字段框的接口引用。
AsLine(从 IGRControl 继承) | 将本部件框转换为线段的接口引用。
AsMemoBox(从 IGRControl 继承) | 转换本部件框为综合文本框的接口引用。
AsPictureBox(从 IGRControl 继承) | 将本部件框转换为图像框的接口引用。
AsRichTextBox(从 IGRControl 继承) | 将本部件框转换为RTF文本框的接口引用。
AsShapeBox(从 IGRControl 继承) | 将本部件框转换为图形框的接口引用。
AsStaticBox(从 IGRControl 继承) | 将本部件框转换为静态框的接口引用。
AsSubReport(从 IGRControl 继承) | 转换本部件框为子报表的接口引用。
AsSummaryBox(从 IGRControl 继承) | 将本部件框转换为统计框的接口引用。
AsSystemVarBox(从 IGRControl 继承) | 将本部件框转换为系统变量框的接口引用。
AsTextBox(从 IGRControl 继承) | 转换本部件框为文字框基类的接口引用。
BackColor(从 IGRControl 继承) | 部件框的背景色。
BackStyle(从 IGRControl 继承) | 部件框显示时背景的填充方式。
BorderColor(从 IGRControl 继承) | 边框线的显示颜色。
BorderStyles(从 IGRControl 继承) | 边框线的显示方式。
BorderWidth(从 IGRControl 继承) | 边框线的宽度。
CanGrow | 指示部件框高度在运行时是否可以伸展标志。
CanShrink | 指示部件框的高度在运行时是否可以收缩标志。
Center(从 IGRControl 继承) | 指定水平与垂直方向的居中对齐方式。
ControlType(从 IGRControl 继承) | 获取本部件框的具体类型。
Cursor(从 IGRControl 继承) | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
DataField | 关联字段对象的名称。
Dock(从 IGRControl 继承) | 指定部件框停靠到父容器的哪一个边缘。
Font(从 IGRControl 继承) | 输出文字时使用的字体。
ForeColor(从 IGRControl 继承) | 部件框输出内容的前景色。
Height(从 IGRControl 继承) | 部件框的显示高度。
Left(从 IGRControl 继承) | 部件框的左端显示位置。
Name(从 IGRControl 继承) | 部件框的名称标识。
Parent(从 IGRControl 继承) | 父容器对象的 IUnknown 接口引用。
PrintType(从 IGRControl 继承) | 部件框的打印输出方式。
RTF | 表示拥有RTF文本的数据。
Tag(从 IGRControl 继承) | 部件框的标识值。
Top(从 IGRControl 继承) | 部件框的顶端显示位置。
Visible(从 IGRControl 继承) | 是否显示部件框的标志。
Width(从 IGRControl 继承) | 部件框的显示宽度。

公共方法

BringToFront(从 IGRControl 继承) | 将部件框带到 Z 顺序的前面。
LoadCursor(从 IGRControl 继承) | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
LoadFromFile | 运行时从磁盘文件中载入RTF格式文件。
LoadFromMemory | 运行时从内存中载入RTF格式文本数据。
SendToBack(从 IGRControl 继承) | 将部件框发送到 Z 顺序的后面。
SetBounds(从 IGRControl 继承) | 设置部件框在其父容器中的边界位置。

请参见

IGRRichTextBox 接口


IGRPictureBox.Picture 属性

获取或设置图像数据的Ole接口引用。

IPicture Picture

特征

可读写

设计器中可见

仅运行时可用

请参见

IGRPictureBox 接口 | IGRPictureBox 成员 | 属性特征说明


IGRRichTextBox.CanGrow 属性

指示部件框高度在运行时是否可以伸展标志。

VARIANT_BOOL CanGrow

默认值

FALSE

特征

可读写

设计器中可见

说明

如果本属性为真，报表运行时部件框的设计时高度不足以完整显示出拥有的RTF文本，则部件框的高足自动伸展到刚好能完整显示出拥有的RTF文本。

请参见

IGRRichTextBox 接口 | IGRRichTextBox 成员 | IGRRichTextBox.CanShrink 属性 | 属性特征说明


IGRRichTextBox.CanShrink 属性

指示部件框的高度在运行时是否可以收缩标志。

VARIANT_BOOL CanShrink

默认值

FALSE

特征

可读写

设计器中可见

说明

如果本属性为真，报表运行时部件框的设计时高度大于完整显示出拥有的RTF文本所需要的高度，则部件框的高度自动收缩到刚好能完整显示出拥有的RTF文本。

请参见

IGRRichTextBox 接口 | IGRRichTextBox 成员 | IGRRichTextBox.CanGrow 属性 | 属性特征说明


IGRRichTextBox.LoadFromFile 方法

运行时从磁盘文件中载入RTF格式文件。

void LoadFromFile(BSTR PathFile);

参数

BSTR PathFile

载入RTF文件的路径与文件名。

说明

载入RTF文件的时机:
1. 如果RTF文本框位于报表头、报表尾、页眉与页脚中，应在报表主对象的 Initialize 事件响应函数中执行载入文件。
2. 如果RTF文本框位于明细网格的内容格中，应在报表主对象的 ProcessRecord 事件响应函数中执行载入文件。
3. 如果RTF文本框位于明细网格的分组头或分组尾中，应在报表主对象的 GroupBegin 或 GroupEnd 事件响应函数中执行载入文件。

请参见

IGRRichTextBox 接口 | IGRRichTextBox 成员 | IGRRichTextBox.LoadFromMemory 方法


IGridppReport.LoadFromMemory 方法

从内存中载入报表模板数据。

VARIANT_BOOL LoadFromMemory(CHAR *pData, ULONG ByteCount);

返回值

VARIANT_BOOL

指示载入报表模板数据是否成功。

参数

CHAR *pData

数据地址指针

ULONG ByteCount

数据字节大小

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.SaveToMemory 方法 | IGridppReport.Clear 方法 | IGridppReport.LoadFromFile 方法 | IGridppReport.LoadFromStr 方法 | IGridppReport.LoadFromVariant 方法


IGridppReport.SaveToMemory 方法

保存报表模板数据保存至内存缓冲区。

VARIANT_BOOL SaveToMemory(CHAR **ppData, ULONG *pByteCount);

返回值

VARIANT_BOOL

指示保存报表模板数据是否成功。

参数

CHAR **ppData

保存数据地址的参数指针。

ULONG *pByteCount

保存数据直接大小的参数指针。

说明

方法调用者在成功调用本方法之后，应调用 Windows API 函数 CoTaskMemFree 释放内存空间。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.LoadFromMemory 方法 | IGridppReport.SaveToFile 方法 | IGridppReport.SaveToStr 方法 | IGridppReport.SaveToVariant 方法


IGRTextBox.CanGrow 属性

指示部件框高度在运行时是否可以伸展的标志。

VARIANT_BOOL CanGrow

默认值

FALSE

特征

可读写

设计器中可见

说明

如果本属性为真，报表运行时部件框的设计时高度不足以完整显示出拥有的文本，则部件框的高足自动伸展到刚好能完整显示出拥有的文本。

请参见

IGRTextBox 接口 | IGRTextBox 成员 | 属性特征说明


IGRTextBox.CanShrink 属性

指示部件框高度在运行时是否可以收缩的标志。

VARIANT_BOOL CanShrink

默认值

FALSE

特征

可读写

设计器中可见

说明

如果本属性为真，报表运行时部件框的设计时高度大于完整显示出拥有的文本所需要的高度，则部件框的高度自动收缩到刚好能完整显示出拥有的文本。

请参见

IGRTextBox 接口 | IGRTextBox 成员 | 属性特征说明


IGridppReport.DeleteReportHeader 方法

根据报表头的名称或序号删除一个报表头。

void DeleteReportHeader(VARIANT Index);

参数

VARIANT Index

指示报表头的名称或序号。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.ReportHeader 属性 | IGridppReport.InsertReportHeader 方法


IGridppReport.DeleteReportFooter 方法

根据报表尾的名称或序号删除一个报表尾。

void DeleteReportFooter(VARIANT Index);

参数

VARIANT Index

指示报表尾的名称或序号。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.ReportFooter 属性 | IGridppReport.InsertReportFooter 方法


IGRPictureBox.LoadFromMemory 方法

运行时从内存中载入图像数据。

void LoadFromMemory(BYTE *pBuffer, LONG BytesCount);

参数

BYTE *pBuffer

图像数据缓冲区内存地址。

LONG BytesCount

图像数据缓冲区的字节数。

请参见

IGRPictureBox 接口 | IGRPictureBox 成员 | IGRPictureBox.LoadFromFile 方法


IGRRichTextBox.LoadFromMemory 方法

运行时从内存中载入RTF格式文本数据。

void LoadFromMemory(BYTE *pBuffer, ULONG BytesCount);

参数

BYTE *pBuffer

RTF数据缓冲区内存地址。

ULONG BytesCount

RTF数据缓冲区的字节数。

请参见

IGRRichTextBox 接口 | IGRRichTextBox 成员 | IGRRichTextBox.LoadFromFile 方法


IGRExportOption成员

IGRExportOption 概述

公共属性

AsE2CSVOption | 获取将本对象转换为导出CSV文件选项对象的接口引用。
AsE2HTMOption | 获取将本对象转换为导出Htm文件选项对象的接口引用。
AsE2PDFOption | 获取将本对象转换为导出PDF文件选项对象的接口引用。
AsE2TXTOption | 获取将本对象转换为导出文本文件选项对象的接口引用。
AsE2XLSOption | 获取将本对象转换为导出Excel文件选项对象的接口引用。
ExportType | 获取本导出文件选项对象的具体类型。
FileName | 指定导出文件的完整路径与文件名称。

公共方法

ShowOptionDlg 显示导出选项设置对话框，可以在打开的对话框中设定各个选项值。

请参见

IGRExportOption 接口 | IGRE2CSVOption 接口 | IGRE2HTMOption 接口 | IGRE2TXTOption 接口 | IGRE2XLSOption 接口


IGRE2XLSOption 概述

IGRE2XLSOption 接口

表示导出Excel文件的选项。

有关此接口所有成员的列表，请参阅 IGRE2XLSOption 成员。

IDispatch
IGRExportOption
IGRE2XLSOption

请参见

IGRE2XLSOption 成员


IGRE2XLSOption成员

IGRE2XLSOption 概述

公共属性

AsE2CSVOption(从 IGRExportOption 继承) | 获取将本对象转换为导出CSV文件选项对象的接口引用。
AsE2HTMOption(从 IGRExportOption 继承) | 获取将本对象转换为导出Htm文件选项对象的接口引用。
AsE2PDFOption(从 IGRExportOption 继承) | 获取将本对象转换为导出PDF文件选项对象的接口引用。
AsE2TXTOption(从 IGRExportOption 继承) | 获取将本对象转换为导出文本文件选项对象的接口引用。
AsE2XLSOption(从 IGRExportOption 继承) | 获取将本对象转换为导出Excel文件选项对象的接口引用。
ExportPageBreak | 指定在导出数据时是否产生页之间的分隔。
ExportPageHeaderFooter | 指定是否导出页眉与页脚，只有在产生页间分隔时此属性才有效。
ExportType(从 IGRExportOption 继承) | 获取本导出文件选项对象的具体类型。
FileName(从 IGRExportOption 继承) | 指定导出文件的完整路径与文件名称。
MinColumnWidth | 指定导出产生的列的最小宽度，以字符为计量单位，用报表缺省字体的字符平均宽度进行转换。
MinRowHeight | 指定导出产生行的最小高度，以字符为计量单位，用报表缺省字体的字符平均宽度进行转换。
OnlyExportDetailGrid | 指定是否只导出明细网格中的数据。
SupressEmptyLines | 指定是否压缩空白行，即不产生空白行。

公共方法

ShowOptionDlg(从 IGRExportOption 继承) 显示导出选项设置对话框，可以在打开的对话框中设定各个选项值。

请参见

IGRE2XLSOption 接口


IGRE2HTMOption 概述

IGRE2HTMOption 接口

表示导出Html超文本文件的选项。

有关此接口所有成员的列表，请参阅 IGRE2HTMOption 成员。

IDispatch
IGRExportOption
IGRE2HTMOption

请参见

IGRE2HTMOption 成员


IGRE2HTMOption成员

IGRE2HTMOption 概述

公共属性

AsE2CSVOption(从 IGRExportOption 继承) | 获取将本对象转换为导出CSV文件选项对象的接口引用。
AsE2HTMOption(从 IGRExportOption 继承) | 获取将本对象转换为导出Htm文件选项对象的接口引用。
AsE2PDFOption(从 IGRExportOption 继承) | 获取将本对象转换为导出PDF文件选项对象的接口引用。
AsE2TXTOption(从 IGRExportOption 继承) | 获取将本对象转换为导出文本文件选项对象的接口引用。
AsE2XLSOption(从 IGRExportOption 继承) | 获取将本对象转换为导出Excel文件选项对象的接口引用。
ExportPageBreak | 指定在导出数据时是否产生页之间的分隔。
ExportPageHeaderFooter | 指定是否导出页眉与页脚，只有在产生页间分隔时此属性才有效。
ExportType(从 IGRExportOption 继承) | 获取本导出文件选项对象的具体类型。
FileName(从 IGRExportOption 继承) | 指定导出文件的完整路径与文件名称。
OnlyExportDetailGrid | 指定是否只导出明细网格中的数据。
SupressEmptyLines | 指定是否压缩空白行，即不产生空白行。

公共方法

ShowOptionDlg(从 IGRExportOption 继承) 显示导出选项设置对话框，可以在打开的对话框中设定各个选项值。

请参见

IGRE2HTMOption 接口


IGRE2TXTOption 概述

IGRE2TXTOption 接口

表示导出文本文件的选项。

有关此接口所有成员的列表，请参阅 IGRE2TXTOption 成员。

IDispatch
IGRExportOption
IGRE2TXTOption

请参见

IGRE2TXTOption 成员


IGRE2TXTOption成员

IGRE2TXTOption 概述

公共属性

AsE2CSVOption(从 IGRExportOption 继承) | 获取将本对象转换为导出CSV文件选项对象的接口引用。
AsE2HTMOption(从 IGRExportOption 继承) | 获取将本对象转换为导出Htm文件选项对象的接口引用。
AsE2PDFOption(从 IGRExportOption 继承) | 获取将本对象转换为导出PDF文件选项对象的接口引用。
AsE2TXTOption(从 IGRExportOption 继承) | 获取将本对象转换为导出文本文件选项对象的接口引用。
AsE2XLSOption(从 IGRExportOption 继承) | 获取将本对象转换为导出Excel文件选项对象的接口引用。
ExportPageBreak | 指定在导出数据时是否产生页之间的分隔。
ExportPageHeaderFooter | 指定是否导出页眉与页脚，只有在产生页间分隔时此属性才有效。
ExportType(从 IGRExportOption 继承) | 获取本导出文件选项对象的具体类型。
FileName(从 IGRExportOption 继承) | 指定导出文件的完整路径与文件名称。
OnlyExportDetailGrid | 指定是否只导出明细网格中的数据。
SupressEmptyLines | 指定是否压缩空白行，即不产生空白行。
UsingCNGraphChar | 指定是否用中文制表符代替明细网格的行列线。
UsingTabChar | 指定是否用tab符号进行对齐处理。
WriteDetailGridLine | 指定是否输出明细网格的行列线，行列线用文字字符代替。

公共方法

ShowOptionDlg(从 IGRExportOption 继承) 显示导出选项设置对话框，可以在打开的对话框中设定各个选项值。

请参见

IGRE2TXTOption 接口


IGRE2CSVOption 概述

IGRE2CSVOption 接口

表示导出CSV格式文件的选项。

有关此接口所有成员的列表，请参阅 IGRE2CSVOption 成员。

IDispatch
IGRExportOption
IGRE2CSVOption

请参见

IGRE2CSVOption 成员


IGRE2CSVOption成员

IGRE2CSVOption 概述

公共属性

AsE2CSVOption(从 IGRExportOption 继承) | 获取将本对象转换为导出CSV文件选项对象的接口引用。
AsE2HTMOption(从 IGRExportOption 继承) | 获取将本对象转换为导出Htm文件选项对象的接口引用。
AsE2PDFOption(从 IGRExportOption 继承) | 获取将本对象转换为导出PDF文件选项对象的接口引用。
AsE2TXTOption(从 IGRExportOption 继承) | 获取将本对象转换为导出文本文件选项对象的接口引用。
AsE2XLSOption(从 IGRExportOption 继承) | 获取将本对象转换为导出Excel文件选项对象的接口引用。
DelimiterChar | 指定CSV分隔字符。
ExportPageBreak | 指定在导出数据时是否产生页之间的分隔。
ExportPageHeaderFooter | 指定是否导出页眉与页脚，只有在产生页间分隔时此属性才有效。
ExportType(从 IGRExportOption 继承) | 获取本导出文件选项对象的具体类型。
FileName(从 IGRExportOption 继承) | 指定导出文件的完整路径与文件名称。
OnlyExportDetailGrid | 指定是否只导出明细网格中的数据。
SupressEmptyLines | 指定是否压缩空白行，即不产生空白行。

公共方法

ShowOptionDlg(从 IGRExportOption 继承) 显示导出选项设置对话框，可以在打开的对话框中设定各个选项值。

请参见

IGRE2CSVOption 接口


IGRE2XLSOption.ExportPageBreak 属性

指定在导出数据时是否产生页之间的分隔。

VARIANT_BOOL ExportPageBreak

默认值

FALSE

特征

可读写

请参见

IGRE2XLSOption 接口 | IGRE2XLSOption 成员 | 属性特征说明


IGRE2TXTOption.ExportPageBreak 属性

指定在导出数据时是否产生页之间的分隔。

VARIANT_BOOL ExportPageBreak

默认值

FALSE

特征

可读写

请参见

IGRE2TXTOption 接口 | IGRE2TXTOption 成员 | 属性特征说明


IGRE2HTMOption.ExportPageBreak 属性

指定在导出数据时是否产生页之间的分隔。

VARIANT_BOOL ExportPageBreak

默认值

FALSE

特征

可读写

请参见

IGRE2HTMOption 接口 | IGRE2HTMOption 成员 | 属性特征说明


IGRE2XLSOption.ExportPageHeaderFooter 属性

指定是否导出页眉与页脚，只有在产生页间分隔时此属性才有效。

VARIANT_BOOL ExportPageHeaderFooter

默认值

FALSE

特征

可读写

请参见

IGRE2XLSOption 接口 | IGRE2XLSOption 成员 | 属性特征说明


IGRE2TXTOption.ExportPageHeaderFooter 属性

指定是否导出页眉与页脚，只有在产生页间分隔时此属性才有效。

VARIANT_BOOL ExportPageHeaderFooter

默认值

FALSE

特征

可读写

请参见

IGRE2TXTOption 接口 | IGRE2TXTOption 成员 | 属性特征说明


IGRE2HTMOption.ExportPageHeaderFooter 属性

指定是否导出页眉与页脚，只有在产生页间分隔时此属性才有效。

VARIANT_BOOL ExportPageHeaderFooter

默认值

FALSE

特征

可读写

请参见

IGRE2HTMOption 接口 | IGRE2HTMOption 成员 | 属性特征说明


IGRE2HTMOption.OnlyExportDetailGrid 属性

指定是否只导出明细网格中的数据。

VARIANT_BOOL OnlyExportDetailGrid

默认值

FALSE

特征

可读写

请参见

IGRE2HTMOption 接口 | IGRE2HTMOption 成员 | 属性特征说明


IGRE2TXTOption.OnlyExportDetailGrid 属性

指定是否只导出明细网格中的数据。

VARIANT_BOOL OnlyExportDetailGrid

默认值

FALSE

特征

可读写

请参见

IGRE2TXTOption 接口 | IGRE2TXTOption 成员 | 属性特征说明


IGRE2XLSOption.OnlyExportDetailGrid 属性

指定是否只导出明细网格中的数据。

VARIANT_BOOL OnlyExportDetailGrid

默认值

FALSE

特征

可读写

请参见

IGRE2XLSOption 接口 | IGRE2XLSOption 成员 | 属性特征说明


IGRE2HTMOption.SupressEmptyLines 属性

指定是否压缩空白行，即不产生空白行。

VARIANT_BOOL SupressEmptyLines

默认值

TRUE

特征

可读写

请参见

IGRE2HTMOption 接口 | IGRE2HTMOption 成员 | 属性特征说明


IGRE2TXTOption.SupressEmptyLines 属性

指定是否压缩空白行，即不产生空白行。

VARIANT_BOOL SupressEmptyLines

默认值

TRUE

特征

可读写

请参见

IGRE2TXTOption 接口 | IGRE2TXTOption 成员 | 属性特征说明


IGRE2XLSOption.SupressEmptyLines 属性

指定是否压缩空白行，即不产生空白行。

VARIANT_BOOL SupressEmptyLines

默认值

TRUE

特征

可读写

请参见

IGRE2XLSOption 接口 | IGRE2XLSOption 成员 | 属性特征说明


IGRField.Value 属性

获取或设置字段在运行时的值。

VARIANT Value

特征

可读写

仅运行时可用

请参见

IGRField 接口 | IGRField 成员 | 属性特征说明


GRToolControlType 枚举

指定打印查看器控件中工具栏上的按钮、编辑框与组合框的类型

成员名称 | 说明
grtctCurPageNo | 指定当前显示页编辑框
grtctExport | 指定数据导出按钮
grtctMultiPage | 指定多页查看模式按钮
grtctNextPage | 指定后一页按钮
grtctPageSetup | 指定页面设置按钮
grtctPrint | 指定打印按钮
grtctPrinterSetup | 指定打印机设置按钮
grtctPriorPage | 指定前一页按钮
grtctSaveDocument | 指定保存为 Grid++Report 文档文件按钮
grtctSep | 指定分隔空隙
grtctSinglePage | 指定单页查看模式按钮
grtctZoomIn | 指定放大显示比例按钮
grtctZoomOut | 指定缩小显示比例按钮
grtctZoomPercent | 指定显示百分比下拉列表组合框

请参见


IGRSubReport成员

IGRSubReport 概述

公共属性

AlignColumn(从 IGRControl 继承) | 指定部件框水平位置对齐到明细网格列的名称。
AlignColumnSide(从 IGRControl 继承) | 部件框对齐到明细网格列的方式。
Anchor(从 IGRControl 继承) | 指定部件框的哪些边缘锚定到其容器边缘。
AsChart(从 IGRControl 继承) | 将本部件框转换为图表部件框的接口引用。
AsFieldBox(从 IGRControl 继承) | 将本部件框转换为字段框的接口引用。
AsLine(从 IGRControl 继承) | 将本部件框转换为线段的接口引用。
AsMemoBox(从 IGRControl 继承) | 转换本部件框为综合文本框的接口引用。
AsPictureBox(从 IGRControl 继承) | 将本部件框转换为图像框的接口引用。
AsRichTextBox(从 IGRControl 继承) | 将本部件框转换为RTF文本框的接口引用。
AsShapeBox(从 IGRControl 继承) | 将本部件框转换为图形框的接口引用。
AsStaticBox(从 IGRControl 继承) | 将本部件框转换为静态框的接口引用。
AsSubReport(从 IGRControl 继承) | 转换本部件框为子报表的接口引用。
AsSummaryBox(从 IGRControl 继承) | 将本部件框转换为统计框的接口引用。
AsSystemVarBox(从 IGRControl 继承) | 将本部件框转换为系统变量框的接口引用。
AsTextBox(从 IGRControl 继承) | 转换本部件框为文字框基类的接口引用。
BackColor(从 IGRControl 继承) | 部件框的背景色。
BackStyle(从 IGRControl 继承) | 部件框显示时背景的填充方式。
BorderColor(从 IGRControl 继承) | 边框线的显示颜色。
BorderStyles(从 IGRControl 继承) | 边框线的显示方式。
BorderWidth(从 IGRControl 继承) | 边框线的宽度。
CanGrow | 指示子报表的高度在运行时是否可以伸展的标志。
CanShrink | 指示子报表的高度在运行时是否可以收缩的标志。
Center(从 IGRControl 继承) | 指定水平与垂直方向的居中对齐方式。
ControlType(从 IGRControl 继承) | 获取本部件框的具体类型。
Cursor(从 IGRControl 继承) | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
Dock(从 IGRControl 继承) | 指定部件框停靠到父容器的哪一个边缘。
Font(从 IGRControl 继承) | 输出文字时使用的字体。
ForeColor(从 IGRControl 继承) | 部件框输出内容的前景色。
Height(从 IGRControl 继承) | 部件框的显示高度。
Left(从 IGRControl 继承) | 部件框的左端显示位置。
Name(从 IGRControl 继承) | 部件框的名称标识。
Parent(从 IGRControl 继承) | 父容器对象的 IUnknown 接口引用。
PrintType(从 IGRControl 继承) | 部件框的打印输出方式。
Report | 关联的报表对象。
Tag(从 IGRControl 继承) | 部件框的标识值。
Top(从 IGRControl 继承) | 部件框的顶端显示位置。
Visible(从 IGRControl 继承) | 是否显示部件框的标志。
Width(从 IGRControl 继承) | 部件框的显示宽度。

公共方法

BringToFront(从 IGRControl 继承) | 将部件框带到 Z 顺序的前面。
LoadCursor(从 IGRControl 继承) | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
SendToBack(从 IGRControl 继承) | 将部件框发送到 Z 顺序的后面。
SetBounds(从 IGRControl 继承) | 设置部件框在其父容器中的边界位置。

请参见

IGRSubReport 接口


IGRSubReport.CanGrow 属性

指示子报表的高度在运行时是否可以伸展的标志。

VARIANT_BOOL CanGrow

默认值

TRUE

特征

可读写

设计器中可见

请参见

IGRSubReport 接口 | IGRSubReport 成员 | 属性特征说明


IGRSubReport.CanShrink 属性

指示子报表的高度在运行时是否可以收缩的标志。

VARIANT_BOOL CanShrink

默认值

FALSE

特征

可读写

设计器中可见

请参见

IGRSubReport 接口 | IGRSubReport 成员 | 属性特征说明


IGRLine成员

IGRLine 概述

公共属性

AlignColumn(从 IGRControl 继承) | 指定部件框水平位置对齐到明细网格列的名称。
AlignColumnSide(从 IGRControl 继承) | 部件框对齐到明细网格列的方式。
Anchor(从 IGRControl 继承) | 指定部件框的哪些边缘锚定到其容器边缘。
AsChart(从 IGRControl 继承) | 将本部件框转换为图表部件框的接口引用。
AsFieldBox(从 IGRControl 继承) | 将本部件框转换为字段框的接口引用。
AsLine(从 IGRControl 继承) | 将本部件框转换为线段的接口引用。
AsMemoBox(从 IGRControl 继承) | 转换本部件框为综合文本框的接口引用。
AsPictureBox(从 IGRControl 继承) | 将本部件框转换为图像框的接口引用。
AsRichTextBox(从 IGRControl 继承) | 将本部件框转换为RTF文本框的接口引用。
AsShapeBox(从 IGRControl 继承) | 将本部件框转换为图形框的接口引用。
AsStaticBox(从 IGRControl 继承) | 将本部件框转换为静态框的接口引用。
AsSubReport(从 IGRControl 继承) | 转换本部件框为子报表的接口引用。
AsSummaryBox(从 IGRControl 继承) | 将本部件框转换为统计框的接口引用。
AsSystemVarBox(从 IGRControl 继承) | 将本部件框转换为系统变量框的接口引用。
AsTextBox(从 IGRControl 继承) | 转换本部件框为文字框基类的接口引用。
BackColor(从 IGRControl 继承) | 部件框的背景色。
BackStyle(从 IGRControl 继承) | 部件框显示时背景的填充方式。
BorderColor(从 IGRControl 继承) | 边框线的显示颜色。
BorderStyles(从 IGRControl 继承) | 边框线的显示方式。
BorderWidth(从 IGRControl 继承) | 边框线的宽度。
Center(从 IGRControl 继承) | 指定水平与垂直方向的居中对齐方式。
ControlType(从 IGRControl 继承) | 获取本部件框的具体类型。
Cursor(从 IGRControl 继承) | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
Dock(从 IGRControl 继承) | 指定部件框停靠到父容器的哪一个边缘。
Font(从 IGRControl 继承) | 输出文字时使用的字体。
ForeColor(从 IGRControl 继承) | 部件框输出内容的前景色。
Height(从 IGRControl 继承) | 部件框的显示高度。
Left(从 IGRControl 继承) | 部件框的左端显示位置。
Name(从 IGRControl 继承) | 部件框的名称标识。
Parent(从 IGRControl 继承) | 父容器对象的 IUnknown 接口引用。
PenColor | 画线段的颜色
PenStyle | 指定画线条的画笔类型
PenWidth | 指定画线条的画笔的宽度。
PrintType(从 IGRControl 继承) | 部件框的打印输出方式。
Tag(从 IGRControl 继承) | 部件框的标识值。
Top(从 IGRControl 继承) | 部件框的顶端显示位置。
Visible(从 IGRControl 继承) | 是否显示部件框的标志。
Width(从 IGRControl 继承) | 部件框的显示宽度。
X1 | 线段的起点X坐标位置。
X2 | 线段的终点X坐标位置。
Y1 | 线段的起点Y坐标位置。
Y2 | 线段的终点Y坐标位置。

公共方法

BringToFront(从 IGRControl 继承) | 将部件框带到 Z 顺序的前面。
LoadCursor(从 IGRControl 继承) | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
SendToBack(从 IGRControl 继承) | 将部件框发送到 Z 顺序的后面。
SetBounds(从 IGRControl 继承) | 设置部件框在其父容器中的边界位置。

请参见

IGRLine 接口


IGRMemoBox成员

IGRMemoBox 概述

公共属性

AlignColumn(从 IGRControl 继承) | 指定部件框水平位置对齐到明细网格列的名称。
AlignColumnSide(从 IGRControl 继承) | 部件框对齐到明细网格列的方式。
Anchor(从 IGRControl 继承) | 指定部件框的哪些边缘锚定到其容器边缘。
AsChart(从 IGRControl 继承) | 将本部件框转换为图表部件框的接口引用。
AsFieldBox(从 IGRControl 继承) | 将本部件框转换为字段框的接口引用。
AsLine(从 IGRControl 继承) | 将本部件框转换为线段的接口引用。
AsMemoBox(从 IGRControl 继承) | 转换本部件框为综合文本框的接口引用。
AsPictureBox(从 IGRControl 继承) | 将本部件框转换为图像框的接口引用。
AsRichTextBox(从 IGRControl 继承) | 将本部件框转换为RTF文本框的接口引用。
AsShapeBox(从 IGRControl 继承) | 将本部件框转换为图形框的接口引用。
AsStaticBox(从 IGRControl 继承) | 将本部件框转换为静态框的接口引用。
AsSubReport(从 IGRControl 继承) | 转换本部件框为子报表的接口引用。
AsSummaryBox(从 IGRControl 继承) | 将本部件框转换为统计框的接口引用。
AsSystemVarBox(从 IGRControl 继承) | 将本部件框转换为系统变量框的接口引用。
AsTextBox(从 IGRControl 继承) | 转换本部件框为文字框基类的接口引用。
BackColor(从 IGRControl 继承) | 部件框的背景色。
BackStyle(从 IGRControl 继承) | 部件框显示时背景的填充方式。
BorderColor(从 IGRControl 继承) | 边框线的显示颜色。
BorderStyles(从 IGRControl 继承) | 边框线的显示方式。
BorderWidth(从 IGRControl 继承) | 边框线的宽度。
CanGrow(从 IGRTextBox 继承) | 指示部件框高度在运行时是否可以伸展的标志。
CanShrink(从 IGRTextBox 继承) | 指示部件框高度在运行时是否可以收缩的标志。
Center(从 IGRControl 继承) | 指定水平与垂直方向的居中对齐方式。
CharacterSpacing | 获取或设置输出文字的字间距。
ControlType(从 IGRControl 继承) | 获取本部件框的具体类型。
Cursor(从 IGRControl 继承) | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
DisplayText(从 IGRTextBox 继承) | 运行时文字框的显示文本。
Dock(从 IGRControl 继承) | 指定部件框停靠到父容器的哪一个边缘。
EndEllipsis(从 IGRTextBox 继承) | 是否用省略号(...)表示超出显示区域的文本。只有当文本不是多行显示时此属性才有意义。
Font(从 IGRControl 继承) | 输出文字时使用的字体。
ForeColor(从 IGRControl 继承) | 部件框输出内容的前景色。
Height(从 IGRControl 继承) | 部件框的显示高度。
Left(从 IGRControl 继承) | 部件框的左端显示位置。
LineSpacing | 获取或设置输出文字的行间距。
Name(从 IGRControl 继承) | 部件框的名称标识。
Parent(从 IGRControl 继承) | 父容器对象的 IUnknown 接口引用。
PrintType(从 IGRControl 继承) | 部件框的打印输出方式。
ShowMoneyLabel(从 IGRTextBox 继承) | 指定是否在此文字框中显示金额标签。
ShowMoneyLine(从 IGRTextBox 继承) | 指定是否显示成金额线格式。
Tag(从 IGRControl 继承) | 部件框的标识值。
Text | 显示文本，文本中可以包含多种树据域。
TextAlign(从 IGRTextBox 继承) | 文字的输出对齐方式。
TextAngle | 获取或设置文字的显示角度，以1/10度为计量单位。
TextOrientation | 获取或设置文字的显示方向。
Top(从 IGRControl 继承) | 部件框的顶端显示位置。
Visible(从 IGRControl 继承) | 是否显示部件框的标志。
Width(从 IGRControl 继承) | 部件框的显示宽度。
WordWrap(从 IGRTextBox 继承) | 是否多行显示文本标志。

公共方法

BringToFront(从 IGRControl 继承) | 将部件框带到 Z 顺序的前面。
LoadCursor(从 IGRControl 继承) | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
SendToBack(从 IGRControl 继承) | 将部件框发送到 Z 顺序的后面。
SetBounds(从 IGRControl 继承) | 设置部件框在其父容器中的边界位置。

请参见

IGRMemoBox 接口


IGRSharePrintSetupObject成员

IGRSharePrintSetupObject 概述

公共属性

BottomMargin | 页面的下边距。
LeftMargin | 页面的左边距。
PaperLength | 获取或设置打印纸张的长度。
PaperName | 打印纸张的名称。
PaperOrientation | 打印纸张的方向。
PaperSize | 表示打印纸张的类型。
PaperSource | 获取或设置打印机的纸张来源。
PaperWidth | 获取或设置打印纸张的宽度。
PrinterName | 获取或设置工作打印机的名称。
RightMargin | 页面的右边距。
TopMargin | 页面的上边距。
Unit | 获取或设置表示本对象计量类型属性的计量单位。

公共方法

PageSetupDialog | 显示页面设置对话框。
PrintDialog | 显示打印对话框。
PrinterSetupDialog | 显示打印机设置对话框

请参见

IGRSharePrintSetupObject 接口 | IGridppReport.SharePrintSetupObject 属性 | IGridppReport.SharePrintSetupOptions 属性 | IGridppReport.SharePrintSetupDisableAllOptions 方法 | IGridppReport.SharePrintSetupEnableAllOptions 方法 | IGridppReport.SharePrintSetupGetOptionEnabled 方法 | IGridppReport.SharePrintSetupSetOptionEnabled 方法


IGridppReport.SharePrintSetupSetOptionEnabled 方法

设定是否应用某个共享全局打印参数项的标志。

void SharePrintSetupSetOptionEnabled(GRSharePrintSetupOption Option, VARIANT_BOOL Enabled);

参数

GRSharePrintSetupOption Option

指定进行设置的共享全局打印参数项。

VARIANT_BOOL Enabled

指定共享全局打印参数项的使能状态。

请参见

IGridppReport 接口 | IGridppReport 成员 | GRSharePrintSetupOption 枚举 | IGridppReport.SharePrintSetupGetOptionEnabled 方法 | IGridppReport.SharePrintSetupDisableAllOptions 方法 | IGridppReport.SharePrintSetupEnableAllOptions 方法 | IGridppReport.SharePrintSetupObject 属性 | IGridppReport.SharePrintSetupOptions 属性


IGridppReport.SharePrintSetupGetOptionEnabled 方法

获取是否应用某个共享全局打印参数项的使能状态。

VARIANT_BOOL SharePrintSetupGetOptionEnabled(GRSharePrintSetupOption Option);

返回值

VARIANT_BOOL

指定共享全局打印参数项的使能状态。

参数

GRSharePrintSetupOption Option

指定一个共享全局打印参数项目。

请参见

IGridppReport 接口 | IGridppReport 成员 | GRSharePrintSetupOption 枚举 | IGridppReport.SharePrintSetupSetOptionEnabled 方法 | IGridppReport.SharePrintSetupDisableAllOptions 方法 | IGridppReport.SharePrintSetupEnableAllOptions 方法 | IGridppReport.SharePrintSetupObject 属性 | IGridppReport.SharePrintSetupOptions 属性


IGridppReport.LoadBackImageFromMemory 方法

从内存数据中载入报表设计页面背景图。

void LoadBackImageFromMemory(BYTE *pBuffer, ULONG BytesCount);

参数

BYTE *pBuffer

指定图像数据的内存地址。

ULONG BytesCount

指定图像数据的内存字节数。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.LoadWatermarkFromFile 方法 | IGridppReport.BackImage 属性 | IGridppReport.BackImageFile 属性


IGridppReport.LoadWatermarkFromMemory 方法

从内存数据中载入报表水印背景图。

void LoadWatermarkFromMemory(BYTE *pBuffer, ULONG BytesCount);

参数

BYTE *pBuffer

指定图像数据的内存地址。

ULONG BytesCount

指定图像数据的内存字节数。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGridppReport.LoadWatermarkFromFile 方法 | IGridppReport.Watermark 属性


IGRE2PDFOption 概述

IGRE2PDFOption 接口

表示导出PDF文件的选项。

有关此接口所有成员的列表，请参阅 IGRE2PDFOption 成员。

IDispatch
IGRExportOption
IGRE2PDFOption

请参见

IGRE2PDFOption 成员


IGRE2PDFOption成员

IGRE2PDFOption 概述

公共属性

AsE2CSVOption(从 IGRExportOption 继承) | 获取将本对象转换为导出CSV文件选项对象的接口引用。
AsE2HTMOption(从 IGRExportOption 继承) | 获取将本对象转换为导出Htm文件选项对象的接口引用。
AsE2PDFOption(从 IGRExportOption 继承) | 获取将本对象转换为导出PDF文件选项对象的接口引用。
AsE2TXTOption(从 IGRExportOption 继承) | 获取将本对象转换为导出文本文件选项对象的接口引用。
AsE2XLSOption(从 IGRExportOption 继承) | 获取将本对象转换为导出Excel文件选项对象的接口引用。
ExportType(从 IGRExportOption 继承) | 获取本导出文件选项对象的具体类型。
FileName(从 IGRExportOption 继承) | 指定导出文件的完整路径与文件名称。

公共方法

ShowOptionDlg(从 IGRExportOption 继承) 显示导出选项设置对话框，可以在打开的对话框中设定各个选项值。

请参见

IGRE2PDFOption 接口


IGRChart 成员

图表成员

图表 概述

公共属性

对齐列(从 部件框 继承) | 指定部件框水平位置对齐到明细网格列的名称。
对齐到列方式(从 部件框 继承) | 部件框对齐到明细网格列的方式。
锚定(从 部件框 继承) | 指定部件框的哪些边缘锚定到其容器边缘。
获取为图表(从 部件框 继承) | 将本部件框转换为图表部件框的接口引用。
获取为字段框(从 部件框 继承) | 将本部件框转换为字段框的接口引用。
获取为线段(从 部件框 继承) | 将本部件框转换为线段的接口引用。
获取为综合文字框(从 部件框 继承) | 转换本部件框为综合文本框的接口引用。
获取为图像框 (从 部件框 继承) | 将本部件框转换为图像框的接口引用。
获取为RTF文字框 (从 部件框 继承) | 将本部件框转换为RTF文本框的接口引用。
获取为图形框(从 部件框 继承) | 将本部件框转换为图形框的接口引用。
获取为静态文字框 (从 部件框 继承) | 将本部件框转换为静态框的接口引用。
获取为子报表 (从 部件框 继承) | 转换本部件框为子报表的接口引用。
获取为统计框 (从 部件框 继承) | 将本部件框转换为统计框的接口引用。
获取为系统变量框(从 部件框 继承) | 将本部件框转换为系统变量框的接口引用。
获取为文字框(从 部件框 继承) | 转换本部件框为文字框基类的接口引用。
背景色(从 部件框 继承) | 部件框的背景色。
背景模式 (从 部件框 继承) | 部件框显示时背景的填充方式。
多色显示单序列柱图 | 当只有一个序列时，是否用不同的颜色显示柱图。
柱图宽度百分比 | 指定柱图显示的总宽度占据整个宽度的百分比。
边框色(从 部件框 继承) | 边框线的显示颜色。
边框模式(从 部件框 继承) | 边框线的显示方式。
边框宽度(从 部件框 继承) | 边框线的宽度。
居中(从 部件框 继承) | 指定水平与垂直方向的居中对齐方式。
图表类型 | 指定图表的类型。
部件框类型(从 部件框 继承) | 获取本部件框的具体类型。
光标(从 部件框 继承) | 指定在查询显示报表时，当鼠标光标位于该部件框上时要显示的鼠标光标类型。
锚定(从 部件框 继承) | 指定部件框停靠到父容器的哪一个边缘。
字体(从 部件框 继承) | 输出文字时使用的字体。
文字色(从 部件框 继承) | 部件框输出内容的前景色。
组数 | 图表的数据组数。
组标签 | 根据顺序号获取或设置组标签文字。
高度(从 部件框 继承) | 部件框的显示高度。
左(从 部件框 继承) | 部件框的左端显示位置。
图例光标 | 指定在查询显示报表时，当鼠标光标位于图例项上时要显示的鼠标光标类型。
图例值可见性 | 指定是否在图例中显示数据值。
图例可见性 | 指定是否显示图例。
线粗细 | 指定折线图的粗细度。
MarginGap | 指定在图表的边框四周留出空白边距，以屏幕像素为计量单位。
Name(从 部件框 继承) | 部件框的名称标识。
Parent(从 部件框 继承) | 父容器对象的 IUnknown 接口引用。
PrintType(从 部件框 继承) | 部件框的打印输出方式。
SeriesCount | 图表的数据序列数。
SeriesCursor | 指定在查询显示报表时，当鼠标光标位于序列项图形上时要显示的鼠标光标类型。
SeriesLabel | 根据顺序号获取或设置序列标签文字。
Tag(从 部件框 继承) | 部件框的标识值。
Title | 指定图表的标题显示文字。
TitleFont | 指定图表的标题文字的显示字体。
Top(从 部件框 继承) | 部件框的顶端显示位置。
Value | 根据序列顺序号与组顺序号获取或设置图表数据值。
ValueAsPercent | 指定是否将图表的值统计并显示为加权百分比。
ValueFormat | 指定显示图表值的数字格式串。
ValueVisible | 指定是否显示图表的值。
Visible(从 部件框 继承) | 是否显示部件框的标志。
Width(从 部件框 继承) | 部件框的显示宽度。
XAxisLabel | 在X轴下面显示的标签文字。
XAxisTextAngle | 指定X轴的文字显示角度。
XAxisTextVisible | 指定是否显示X轴的文字。
XAxisVisible | 指定是否显示X坐标轴。
YAxisLabel | 指定在Y坐标轴的左边显示的标签文字。
YAxisMaximum | 指定Y坐标轴表示的最大值。
YAxisMinimum | 指定Y坐标轴表示的最小值。
YAxisSpace | 表示Y坐标轴的每刻度的步进值。
YAxisTextFormat | 指定生成Y坐标轴的刻度文字的数字格式串。
YAxisTextVisible | 指定是否显示Y坐标轴的文字。
YAxisVisible | 指定是否显示Y坐标轴。

公共方法

BringToFront(从 部件框 继承) | 将部件框带到 Z 顺序的前面。
LoadCursor(从 部件框 继承) | 从光标文件中载入光标作为该部件框要显示的鼠标光标。
LoadLegendCursor | 从光标文件中载入要在图表图例项上显示的鼠标光标。
LoadSeriesCursor | 从光标文件中载入要在图表序列项上显示的鼠标光标。
PrepareSnapShot | 准备为明细网格中的内容行，分组头或分组尾中的图表提供数据。
SendToBack(从 部件框 继承) | 将部件框发送到 Z 顺序的后面。
SetBounds(从 部件框 继承) | 设置部件框在其父容器中的边界位置。
SnapShot | 保存为明细网格中的内容行，分组头或分组尾中的图表提供数据。

请参见

IGRChart 接口


IGRChart.TitleFont 属性

指定图表的标题文字的显示字体。

IGRFont *TitleFont

特征

只读

设计器中可见

请参见

IGRChart 接口 | IGRChart 成员 | IGRFont 接口 | IGRChart.Title 属性 | 属性特征说明


IGRChart.LegendValueVisible 属性

指定是否在图例中显示数据值。

VARIANT_BOOL LegendValueVisible

默认值

FALSE

特征

可读写

设计器中可见

说明

只有当图表的组数与序列数之一为1且本属性值为真时，才会将数据值显示在图例中。

请参见

IGRChart 接口 | IGRChart 成员 | IGRChart.LegendVisible 属性 | IGRChart.ValueFormat 属性 | 属性特征说明


IGRChart.GroupLabel 属性

根据顺序号获取或设置组标签文字。

BSTR GroupLabel

特征

可读写

设计器中可见

请参见

IGRChart 接口 | IGRChart 成员 | IGRChart.SeriesLabel 属性 | 属性特征说明


IGRChart.SeriesLabel 属性

根据顺序号获取或设置序列标签文字。

BSTR SeriesLabel

特征

可读写

设计器中可见

请参见

IGRChart 接口 | IGRChart 成员 | IGRChart.GroupLabel 属性 | 属性特征说明


IGRChart.Value 属性

根据序列顺序号与组顺序号获取或设置图表数据值。

DOUBLE Value

特征

可读写

设计器中可见

请参见

IGRChart 接口 | IGRChart 成员 | IGRChart.ValueAsPercent 属性 | IGRChart.ValueFormat 属性 | IGRChart.ValueVisible 属性 | 属性特征说明


IGRTextBox.ShowMoneyLabel 属性

指定是否在此文字框中显示金额标签。

VARIANT_BOOL ShowMoneyLabel

默认值

FALSE

特征

可读写

设计器中可见

请参见

IGRTextBox 接口 | IGRTextBox 成员 | IGRTextBox.ShowMoneyLine 属性 | IGridppReport.ShowMoneyDigit 属性 | IGridppReport.ShowMoneyLineColor 属性 | IGridppReport.ShowMoneySepLineColor 属性 | IGridppReport.ShowMoneyWidth 属性 | 属性特征说明


IGRTextBox.ShowMoneyLine 属性

指定是否显示成金额线格式。

VARIANT_BOOL ShowMoneyLine

默认值

FALSE

特征

可读写

设计器中可见

请参见

IGRTextBox 接口 | IGRTextBox 成员 | IGRTextBox.ShowMoneyLabel 属性 | IGridppReport.ShowMoneyDigit 属性 | IGridppReport.ShowMoneyLineColor 属性 | IGridppReport.ShowMoneySepLineColor 属性 | IGridppReport.ShowMoneyWidth 属性 | 属性特征说明


IGRImageList成员

IGRImageList 概述

公共属性

Count | 获取当前图像集合中图像个数。
Item | 通过图像序号获取共享图像的引用。

公共方法

Add | 根据图像对象引用增加该图像到图像集合中。
AddFromFile | 根据图像文件路径名将该图像添加到图像集合中。
AddFromMemory | 将内存缓冲区中的图像添加到图像集合中。

请参见

IGRImageList 接口 | IGridppReport 接口 | IGRPictureBox 接口 | IGridppReport.ImageList 属性


IGRImageList.AddFromMemory 方法

将内存缓冲区中的图像添加到图像集合中。

SHORT AddFromMemory(BYTE *pData, ULONG ByteCount);

返回值

SHORT

指定新增图像的序号。

参数

BYTE *pData

指定添加图像数据的内存地址。

ULONG ByteCount

指定添加图像数据的字节数。

请参见

IGRImageList 接口 | IGRImageList 成员 | IGRImageList.Add 方法 | IGRImageList.AddFromFile 方法


IGRPictureBox.AttachSystemImage 方法

关联一个系统图像到本图像框,从而在本图像框中显示一个系统图像。

void AttachSystemImage(GRSystemImage SystemImage);

参数

GRSystemImage SystemImage

指定系统图像。

请参见

IGRPictureBox 接口 | IGRPictureBox 成员 | GRSystemImage 枚举 | IGRPictureBox.ImageIndex 属性


IGRControl.LoadCursor 方法

从光标文件中载入光标作为该部件框要显示的鼠标光标。

void LoadCursor(BSTR PathFile);

参数

BSTR PathFile

指定光标文件的文件路径名。

请参见

IGRControl 接口 | IGRControl 成员 | IGRControl.Cursor 属性


IGRChart.LoadSeriesCursor 方法

从光标文件中载入要在图表序列项上显示的鼠标光标。

void LoadSeriesCursor(BSTR PathFile);

参数

BSTR PathFile

指定光标文件的文件路径名。

请参见

IGRChart 接口 | IGRChart 成员 | IGRChart.SeriesCursor 属性 | IGRChart.LoadLegendCursor 方法


IGRChart.LoadLegendCursor 方法

从光标文件中载入要在图表图例项上显示的鼠标光标。

void LoadLegendCursor(BSTR PathFile);

参数

BSTR PathFile

指定光标文件的文件路径名。

请参见

IGRChart 接口 | IGRChart 成员 | IGRChart.LegendCursor 属性 | IGRChart.LoadSeriesCursor 方法


IGRColumnContent.LoadCursor 方法

从光标文件中载入要在内容行上显示的鼠标光标。

void LoadCursor(BSTR PathFile);

参数

BSTR PathFile

指定光标文件的文件路径名。

请参见

IGRColumnContent 接口 | IGRColumnContent 成员 | IGRColumnContent.Cursor 属性


IGRColumnContentCell.LoadCursor 方法

从光标文件中载入要在本内容格上显示的鼠标光标。

void LoadCursor(BSTR PathFile);

参数

BSTR PathFile

指定鼠标光标文件的文件路径名。

请参见

IGRColumnContentCell 接口 | IGRColumnContentCell 成员 | IGRColumnContentCell.Cursor 属性


IGRColumnContentCell.Cursor 属性

指定在查询显示报表时，在本内容格上显示的鼠标光标。

GRDisplayCursor Cursor

默认值

grdcDefault

特征

可读写

设计器中可见

说明

如果本属性为 grdcDefault，内容格将把内容行的光标作为默认光标。

请参见

IGRColumnContentCell 接口 | IGRColumnContentCell 成员 | GRDisplayCursor 枚举 | IGRColumnContentCell.LoadCursor 方法 | IGRColumnContent.Cursor 属性 | 属性特征说明


IGridppReport.TextBoxGetDisplayText 事件

当文字类型的部件框准备生成其显示文本时触发。

void TextBoxGetDisplayText(IGRTextBox *Sender);

参数

IGRTextBox *Sender

指定触发本事件的文本部件框对象的接口引用。

说明

当文字类型的部件框准备生成其显示文本时触发。如果其显示文本不是内部生成的文本，就需要在此事件中为其设定显示文本，通过给其 DisplayText 属性赋值改变字段的显示文本。

请参见

IGridppReport 接口 | IGridppReport 成员 | IGRTextBox 接口 | IGridppReport.FieldGetDisplayText 事件 | IGRTextBox.DisplayText 属性 | IGRTextBox 接口


GRDuplexKind 枚举

表示报表对双面打印的应用方式。

成员名称 | 说明
grdkDefault | 打印机默认的双面打印设置。
grdkHorizontal | 双面水平打印。
grdkSimplex | 单面打印。
grdkVertical | 双面垂直打印。

请参见

IGRPrinter.Duplex 属性 | IGridppReport.DesignPrintDuplex 属性


IGridppReport.DesignPrintDuplex 属性

指示报表在设计时指定的双面打印模式。

GRDuplexKind DesignPrintDuplex

默认值

grdkDefault

特征

可读写

设计器中可见

仅用于打印

请参见

IGridppReport 接口 | IGridppReport 成员 | GRDuplexKind 枚举 | IGRPrinter.Duplex 属性 | 属性特征说明